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Introduction

Overview

Master PDF Editor is easy to use but effective application for work with PDF files. Its features enable you  
to create, edit, view, encrypt, sign, and print interactive PDF documents with just a couple mouse clicks.  
Applications features include full PDF files support, import/export of PDF pages to images of different  
formats, XPS conversion to PDF and 128-bit encryption. You can also add different control elements such 
as buttons, text fields, flags, and many other. Each control element can have event handlers assigned for 
predefined user actions, such as click, scroll, or selection. Your work will become even simpler than ever  
before with powerful comment tools like Sticky Note and Stamp.

Master PDF Editor provides extensive functionality for work with PDF files, which makes it one of the 
best PDF editing software:

• Create new PDF file or edit existing.
• Change any element in PDF file.
• Add or edit bookmarks in PDF file.
• Encrypt/protect PDF files with 128-bit key.
• Convert XPS files to PDF format.
• Add control elements like buttons, checks, lists etc to your PDF files.
• Import/export PDF pages to/from BMP, JPEG, PNG, CSV, SVG/TIFF, TXT, CSV formats.
• Split and merge PDF files.
• JavaScript support.
• XFA dynamic forms support.
• Forms values validation and calculation.
• Editing PDF text, any forms, images, and pages.
• Fast and simple PDF forms filling. 
• Signing PDF documents with digital signature.
• Changing font attributes (size, family, color etc).
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System requirements

Microsoft Windows: Windows 7, 8, 10, 11 (32 & 64 bit).
Linux: Qt 5.15.1 or higher, glibc 2.27 or higher (64 bit).
macOS: Intel 12.0 or M1 12.0.

Information security guidelines

• It’s not recommended sharing passwords and digital certificates with third parties after documents 
being encrypted.

• It’s recommended using one of the following document encryption algorithms to ensure 
information security when applying a password to open a document: 40 bit RC4, 128 bit RC4, 128 
bit AES, or 256 bit AES. 

• It’s recommended setting the encryption permissions and selecting the actions that are allowed to 
be performed on the document to limit the range of actions allowed in a document. Go to File > 
Properties > Security to configure settings.   

• It’s not recommended following third-party links. By default, warnings are enabled in the settings 
when opening links. Go to Tools > Settings > Forms > Show warning when opening links to 
configure settings. 

• It’s recommended viewing documents in a safe reading mode, by default this option is enabled. 
Also, it is recommended turning off JavaScript execution in the document if you are unsure of the 
JavaScript functions that are executed when certain actions are performed. If JavaScript execution 
is disabled, some Java functions are prohibited from executing. Go to Tools > Settings > 
JavaScript > Enable JavaScript/Enable safe reading mode to configure settings. 

• Master PDF Editor allows users to manually configure the proxy. Data is filtered to ensure 
network security when using a proxy server in a corporate network. Go to Tools > Settings > 
Network > Manual proxy configuration to configure settings.

• It is necessary to download packages only from the official website code-industry.ru when 
installing or updating the program. You can open the website though the program: Help > Home 
Page. 

• Master PDF Editor provides removing the document metadata. Choose File > Properties > 
Document Info to remove it.

• It’s recommended applying a digital signature to a document for ensuring the authenticity and 
integrity. Select Forms > Signature to add a digital signature.

• Master PDF Editor has the data backup function that saves documents automatically so that users 
do not lose them. By default, creating backup file is enabled Tools > Settings > General > Create 
backup file.

Technical Support

Please, contact us by support@code-industry.net email if you have any questions concerning software 
purchase, functionality, Master PDF Editor licensing. Likewise, do not hesitate to contact if you have 
found any issues or have any suggestions about application improvement.
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We are always eager to hear from you. If you have any issues or questions, please, make sure you use last  
software version and cannot find required information in User Manual before contacting us. 

Installing Master PDF Editor on Linux

To install Master PDF Editor on major Linux distributions, you just need to download a DEB or RPM 
package and install it using the command line or a package manager like Gdebi or QApt. First, you have 
to figure out which package (DEB or RPM) you need to download.

For installation on the Debian derivatives like Linux Mint, Ubuntu etc. you need a DEB package.
RedHat derivatives like Fedora, openSUSE etc. require an RPM package.

Installing Master PDF Editor on Ubuntu using DEB package

Let's consider an example of installing the PDF editor in the latest version of 64-bit Ubuntu using the deb 
package.

This method is suitable for the vast majority of users.

Please be aware that downloading is all you need to do, not opening the package as Mozilla Firefox might  
recommend by default.

Link to download:
https://code-industry.net/free-pdf-editor/

Open the directory containing the downloaded package once the download has finished.

The application installation window will open when you double-click the downloaded file. Alternatively,  
you might right-click the file and select Open, for instance with the QApt Package Installer.

Click Install Package. Before the installation, you will probably need to enter the system administrator 
password. After that, the icon to launch Master PDF Editor will appear in the list of installed programs.
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Installation with QApt

Install a deb package from the command line:

• sudo apt install ./master-pdf-editor-5.9.10-qt5.x86_64.deb 

Please n  ote  : replace 5.9.10 with the current version.

Installing Master PDF Editor on Fedora using RPM package

Download an rpm package:

https://code-industry.net/free-pdf-editor/

Run the following commands in terminal, replacing 5.9.10 for the most recent version you downloaded:

• sudo yum install ./master-pdf-editor-5.9.10-qt5.x86_64.rpm

Installing Master PDF Editor on Ubuntu using Tar.gz package

Download a tarball:

https://code-industry.net/free-pdf-editor/

Then, run the commands below in terminal, replacing 5.9.10 with the current version you downloaded:

• sudo tar xf master-pdf-editor-5.9.10-qt5.x86_64.tar.gz -C /opt  OR sudo tar xf master-pdf-
editor-5.9.10-qt5.x86_64.tar.gz --directory /opt

• sudo cp /opt/master-pdf-editor-5/masterpdfeditor5.desktop /usr/share/applications/
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Installing Master PDF Editor on Windows

After downloading the installer, launch the installation by double-clicking the installer icon with a mouse. 
When it is launched, you will see a greeting window. Press the Next button.

After you have read the End User License Agreement, put a tick next to the option I accept the terms in  
the License Agreement and click Next.

If  you  do  not  accept  any  of  the  agreement  items,  click  Cancel.  The  installation  will  be  canceled.
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Click the Install button in the next dialog window to install the application.
Status bar shows installation progress. This should take less than a minute.

After the installation of Master PDF Editor is completed, you will see a dialog window informing you 
about it. Press the Finish button. 

When the installation is finished, you can launch Master PDF Editor with a desktop shortcut or from the 
system menu.
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Deleting Master PDF Editor

To delete Master PDF Editor, open the Control Panel > Programs > Programs and Features.
Select Master PDF Editor from the list and press the Uninstall button. The application will be uninstalled 
automatically.

«Silent» Installation

After you have read License Agreement and agreed to all its items, you can use "Silent Installation", 
which neither pops up any dialog window nor asks for agreement on installation stages.

Parameters for "Silent Installation" launch in command window:
msiexec /i c:<Installation_file_path><MasterPDFEditor-setup-x64>.msi /quiet
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Installation using Group Policy

It’s possible to install  Master PDF Editor using Group Policies (GPO) to automatically distribute the 
program  to  client  computers  or  users.  Download  the  following  msi  package  from  our  website:
MasterPDFEditor-setup-ru-x64.msi

Place the Installer package (.msi package) to a shared network folder. Then, create a Group Policy object 
and add the Installer package:

1. Start Group Policy Management Console (gpmc.msc). 
2. Select Create a GPO in this domain, and link it here to create a new GPO. 
3. Click  Add… and select  the MasterPDFEditor-setup-ru-x64.msi  file  stored in a  shared network 

folder. 

Configure additional settings of the Installer package when it is added to the Group Policy:

1. Under User Configuration, expand Software Settings. Then, right-click the Software installation 
and click the package. 

2. Select MasterPDFEditor-setup-ru-x64.msi file. 
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3. In the Properties dialog window, click the Deployment tab. Select Assigned as Deployment Type 
and enable Install this application at logon deployment option, then press OK. Master PDF Editor 
will be installed when the user logs on to the computer. 

4. Press Advanced button in the Properties dialog window, Deployment tab. Enable Ignore language 
when deploying this package option and press OK. 
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Installing Master PDF Editor on macOS

Download DMG file. Link to the page to download it:

https://code-industry.net/downloads/

After you've completed downloading the installer, launch installation by double-clicking the installer icon 
with a mouse.

When the installation process is over,  you need to drag and drop the Master PDF Editor icon to the  
Applications folder.

Now you can launch the Master PDF Editor on your device, opening it directly from the Applications 
folder.

Activation

You may use Master PDF Editor for free for reading, filling PDF forms and printing documents. The only  
limitation of unregistered version is watermarks on saved documents.

In order to activate the application you have to purchase a license. This will grant you registration key for  
Master PD Editor activation.

One registration key can be used for Master PDF Editor activation on a workstation and a home PC or  
laptop within one local user account on any of the supported OSes (Windows, Linux, or Mac OS X).

Follow this link for purchase:
https://code-industry.net/purchase/

All licenses are valid for unlimited term for the software version they were purchased for. Besides, our  
clients are provided with technical support and free updates for a year after purchase date. After this term 
registered users can renew the license by purchasing new version for 50% of the actual price, which 
automatically gives another year of support and updates.

Copyright © 2026 Code Industry Ltd

https://code-industry.net/purchase/
https://code-industry.net/downloads/


For payment with a discount, you can contact us with technical support contact form on our Contact Us 
page on the official website or by email address sales@code-industry.net.

Please make sure to inform Order ID or email address you used when purchasing, if you contact us 
about license renewal! 

Online Activation

You can use either online or offline activation. For online Master PDF Editor activation your computer 
has to be connected to the internet. If you are already connected, preform following actions:
Document Security
Double click Master PDF Editor icon on desktop and choose Help > Register... on the main menu.
You'll see following screen:

Copy registration code you received before and paste it into corresponding field (look at screenshot). Then 
click Activate button. Application activation allows you to use all Master PDF Editor functions without 
watermarks in output file. 
After completing activation you will receive free updates for your Master PDF Editor copy within 1 year.

In order to find out are there any updates available for you, choose Help > Check for Update.
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Offline Activation

In order to activate Master PDF Editor in autonomous mode, preform following actions:
Double  click  Master  PDF  Editor  icon  on  your  desktop  and  choose  Help > Register... Set  Offline 
Activation checkbox on. Activation Code field will appear near Registration Code field. System will also 
generate unique identifier for you (ID is selected on screenshot below). Please, copy-paste to e-mail and 
send ID and Registration Code to our e-mail address support@code-industry.net. 

Please,  inform your  Order  ID or  e-mail  address  you  used  for  purchasing!  Letter  without  this 
information will be ignored!

After you receive the response with activation code, do not type it in manually. Instead, copy-paste it to 
Activation Code field, also paste registration code to Registration Code field and then click Activate.

Copyright © 2026 Code Industry Ltd

mailto:support@code-industry.net


License Deactivation

Use that function if you want to activate Master PDF Editor on another PC.
After that you can activate Master PDF Editor on another PC with your registration code.

Choose Help > Register...  and click Deactivate button.

A message will pop up informing that the license has been deactivated.

After that, you can activate Master PDF Editor on another computer using your registration code.
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Workspace

At the top of the program workspace are the Main Menu and Toolbars. There are numerous controls for 
working with files on the toolbars.

The Navigation Panel on the left side of the screen helps to navigate the document. In the center of the 
workspace, you can see the  Document Area. It displays the PDF files that a user is currently working 
with. It is easy to switch between files by clicking on their tabs in the Document Area when working with 
multiple documents in one Master PDF Editor application.

If the PDF document is password-protected or has forms, the Popup Message will appear at the top of the 
Document Area.

The Object Inspector is located on the right side of the application workspace. The Object Inspector  is 
used to configure object parameters as well as manage actions. 

The Status Bar displays at the bottom of the workspace.

The width of the Navigation Panel and the Object Inspector can be adjusted by dragging with a mouse to 
customize it.

Master PDF Editor workspace:
1 - Main Menu; 2 - Toolbars; 3 - Pop-up Message;

4 - Status Bar; 5 - Navigation Panel; 6 - Object Inspector; 7 - Document Area.
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1. Main Menu. All the application functions are available here. 
2. Toolbars  . You can customize buttons for easy access to tools.
3. Pop-up message  . A message popping up at the top of the document area informs that a document 

contains forms or is password-protected. 
4. Status Bar  . Provides some general information on: the current page, the selected object, its size, 

etc. 
5. Navigation Panel  . Allows navigating in different ways: by page thumbnail, by bookmarks or 

using search panel. 
6. Object Inspector  . Allows editing the properties of the selected objects. 
7. Document Area  . The open PDF file displays here. You can perform various actions with the 

objects that are in the PDF file and view the file as well in this area. 

Main Menu

With the main menu, you can access different tools. It includes the following items:

 File  
 Edit  
 View  
 Objects  
 Comments  
 Forms  
 Document  
 Tools  
 Help  

Context Menu

When you right-click on any workspace object, a context menu appears. It displays a list of commands 
related to the selected object or panel.
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Toolbars

Toolbars  providing  easy  access  to  different  functions  of  the  application.  The  following  toolbars  are 
available in Master PDF Editor:

 Main.
 Edit.
 View.
 Find.
 Tools.
 Forms.
 Comments.
 Redaction.

Hover your cursor over the tool icon to see the tooltip.

Perform the following actions to show or hide toolbars:
 Open View tab in Main menu and choose Toolbars item. Check items with toolbars you want to 

display on the screen or uncheck to hide them.
 Right-click a toolbars area or main menu and check or uncheck items for panels to show or hide 

them.

Document tab

You can switch between files when working on multiple PDF files in one Master PDF Editor instance.

Popup Message

Pop up message appears only if the current PDF document contains forms or is password-protected.
When opening a document, pop up message informs if it contains forms providing a button to highlight all  
forms in the document. 
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If the document is password-protected to edit the document,  pop up message will inform you that the 

document is encrypted when selecting Edit Document  tool. In this case, you don't have permission to 
edit. You can click Change button here to change owner's password and remove restrictions.

Status Bar

Status bar is a part of the workspace. It displays:

 When  Edit Document,   Edit Text or   Edit Forms is on, you can see number of current 
page, total number of pages, width and height of the page in pixels and number of objects on the 
current page.

 Object type and some other info when an object is selected.

 When   Hand Tool or  Select Text is on, you can see number of current page and total 
number of pages.

 When opening PDF files, you can also see Status bar by default. Main menu item in View 
submenu allows you to show it or hide.

When hovering a tool with a mouse cursor you can see its description in the Status bar.

Navigation Panel

Navigation panel is a window with the following tabs: 
 Pages. Displays pages thumbnails;
 Bookmarks. Lists all bookmarks in the current document;
 Attachments. Allows to insert, edit and remove attachments;
 Search. Searches text case-sensitively in the current document including comments;
 Object TreeView. Displays every object on every page of the document;
 Signatures. Displays signatures created in the current document;
 Layers. Displays all the layers in the document.
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You can change the width of Navigation Panel by dragging it with a mouse.
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Document Area

Document Area displays PDF file user works with currently. 
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Object Inspector

Every object in PDF document has unique parameters, which can be changed by Object Inspector. It is 
good tool for both changing object parameters (open page, open file, etc.) and controlling event (button 
pressed, button released, etc.), which objects react to.

Open Object Inspector by clicking its tab in the right part of the workspace. Switch mode to  Edit Tool 

(you can do that by clicking Edit Document  button on the toolbar) and choose any object. Parameters 
of the object will be displayed in Object Inspector. Now they can be easily changed as you require.

You can also open Object Inspector with the context menu. In edit mode right click selected object and 
choose Parameters item. 
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Main Menu

File Menu

Common file operations for XPS and PDF can be found in File menu. They include:
 New (Ctrl+N). Сreate a new file: Blank file (Ctrl+N), From Files, From Scanner. 
 Open (Ctrl+O). Open existing PDF or XPS file.
 Reload. Reload current file from a disk. It's useful if any external changes have been made to it.
 Recent Files. View files which were opened and/or changed recently. You can also clear that list 

by choosing Empty recent files list. You can open multiple documents in same Master PDF Editor 
at a time. When multiple files opened you can easily choose required file by clicking 
corresponding tab below the toolbar. 

 Sessions. Open, save and manage sessions. 
 Save (Ctrl+S). Save current file.
 Save As... (Ctrl+Shift+S). Save current file with new name.
 Save Optimized As...   (Ctrl+Alt+S). Optimization allows to reduce size of images in PDF file. 

Using all or only some of the optimization parameters depends on planned file usage and its 
desired properties. 

 Export. Allows you to save the current document in the following image formats: BMP, JPG, 
PNG, TIFF, as well as in the TXT format and CSV. More information here: Export PDF to Image, 
Export PDF to Text, Export PDF to CSV. 

 Email. Send current file via email. Save a file before sending if it’s been edited. 
 Print (Ctrl+P). Print current file. This will show default print dialog, where you can set printing 

properties.
 System Print… Print using system dialog.
 Properties (Ctrl+D). Current document properties.
 Close. Close current document.
 Quit. Quit the application.

Edit Menu

Master PDF Editor supports a set of common operations on PDF documents. They are accessible via Edit  
menu.

 Undo (Ctrl+Z). Undo previous action.
 Redo (Ctrl+Y). Redo last undone action.
 Cut (Ctrl+X). Cut selected element and puts it into clipboard.
 Copy (Ctrl+C). Copy selected element and puts it into clipboard.
 Paste (Ctrl+V). Paste cut/copied element from the clipboard.
 Paste at Copy Position. Paste object with original coordinates.
 Paste to multiple Pages. Paste selected object or text to multiple pages at once.
 Delete (Del). Delete selected element.
 Select All (Ctrl+A). Select all elements on the current page.
 Send to Back (Ctrl+-). Move selected element to the background.

Copyright © 2026 Code Industry Ltd



 Send Backward. Move the selected element to the back by only one object.
 Bring Forward. Move the selected element to the front by only one object.
 Bring to Front. Move selected element to the foreground.
 Set Fit to Page. Move selected element to the foreground.
 Align Objects. Automatically move or align selected objects. There are 4 types of alignment: Left,  

Right, Top and Bottom.
 Set Fit to Page. Set width of the current document to match page size.

View Menu

Master PDF Editor supports a set of general operations for PDF document view. They can be accessed via  
View menu.

 Go To. Move to the corresponding page.
• First Page (Home).

• Previous Page (PgUp).

• Next Page (PgDown).

• Last Page (End).

• Go to Page… (Ctrl+Alt+G).

• Next View.

• Previous View.

 Zoom. 
• In (Ctrl++). Increase current zoom.

• Actual Size. Display content at 100% scale.

• Zoom Out (Ctrl+-). Decrease current zoom.

 Page Display.

• Fit Page (Ctrl+1). Scale page to fit window in height.

• Fit Width (Ctrl+2). Scale page to fit window in width.

• Facing Pages (Ctrl+3). Displays two pages at once for multipage PDF files (with 2 or more 
pages).

• Continuous. Provide uninterrupted page browsing.

• Show Cover Page During Facing. Displays first image separately in Facing Pages view mode.

 Grid (Ctrl+U). Used for more accurate objects positioning in the document.

 Snap to Grid (Ctrl+Shift+U). The object will be automatically aligned by the closest grid line 
after movement.

 Replace document colors. Change document colors for view to ones set in Tools > Setting > 
Display.

 Rotate 90 degrees Clockwise. Rotation is performed in 90-degree clockwise.
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 Rotate 90 degrees Counterclockwise. Rotation is performed in 90-degree counterclockwise.

 Search. Search for symbol sequences in a document.
• Find (Ctrl+F).

• Find Next (F3).

• Find Previous (Shift+F3).

 Navigation Panels. Show/hide a specific panel.

• Documents only.

• Pages.

• Bookmarks.

• Attachments.

• Object.

• Object TreeView.

• Signatures.

• Layers.

 Object Inspector (Ctrl+11). Show/hide Object Inspector.
 Menu (F12). Show/hide the Main Menu. 
 Full Screen (F11). Allows you to use the entire computer screen for viewing and editing.
 Toolbars. Allow to show/hide one of six available toolbars.
 Status Bar. Hide/show status bar in the bottom of the window.

Objects Menu

Master PDF Editor allows to add different objects to PDF files with Objects menu.
Every object has unique parameters which can be changed with Object Inspector. 

 Formatted Text. Add formatted text to your document.
 Text (Ctrl+T). Add text to your document.
 Image (Ctrl+I). Add image to your document.
 Line. Draw straight line.
 Rectangle. Draw rectangle.
 Ellipse. Draw ellipse.
 Pencil. Use to draw lines by hand.
 Place Initials. Allows inserting initials to your document.
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Comments Menu

Comments are used for text reviewing or suggesting possible changes in PDF documents. They are not 
editing tools itself, since their use doesn't alter source file content.
Comment tools:

 Add Sticky Note.  Note is one of the most basic comment tools.  Mouse click a place where 
you want to locate your note and insert your comment. Author's name will be automatically 
included into the header. Other users may answer notes. 

 Typewriter.  Add comment text at the cursor position without complicated editing.

 Callout.   Add comment text with an arrow pointing to a specific location on the page that you 
want to point out. 

 Label. Add a note with a specific graphic label.

Available labels and corresponding icons:

Labels Icon

Check mark

Circle

Comment

Cross

Help

Insert text

Key

New paragraph

Text note

Paragraph

Right arrow

Right pointer

Star

Up arrow

Up left arrow

Graph

Paper Clip
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Attachment

Tag

 Comment View. Hide/show/select the type of comment displaying.
 Show comments List. Show/hide comments as a list on the navigator panel.
 Measurements. Designed to measure distances, areas and perimeters.
 Drawing  . Drawing tools are used to emphasize commented objects in the document.
 Stamp. Place stamps on the pages of a PDF document in a same manner as on paper pages.

 Highlight Text.  Mark important parts of text for later usage.

 Strikeout Text.  Text selection with strikeout. 

 Underline Text.  For text underlining.
 Attach a File as a Comment. Attaching a file to the current document as comment.
 Export Comments Data… Export comments with records to separate FDF file.
 Import Comments Data… Add exported and saved to FDF file comments to current document.

Detailed information on Comments described in section Commenting PDF Files.

Forms Menu

 Highlight Fields (Ctrl+H). Highlight all forms in the document.
 Reset Forms. Reset all form values in the document. Values will be set to default or empty if 

default is not specified.
 Edit Tab Order. Change the tab order.
 Edit Forms (Alt+3). Tool for selecting and editing PDF forms only.
 Link (Ctrl+L). Add hyperlink.
 Text Field (Ctrl+E). Create field for text input. For example, name, date, phone number etc.
 Check Box. Create check box, which has two states: disabled or enabled. When enabled, it has a 

check mark inside of it.
 Radio Button. Create a switch, which allows to choose one option of a limited set of mutual 

exclusive options.
 Combo box. Create a list, which allows to choose single item or input a value.
 List box. Create a list, which allows to choose single item or input a value.
 Button. Create a button, which can launch any action.
 Signature. Apply digital signature to a document.
 Invisible Signature  . Apply digital signature that is not displayed in the document.
 Export Form Data… Export forms data with records to separate fdf file.
 Import Form Data… Add exported and saved to fdf file forms data to current document.
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Document Menu

 Insert Blank Pages (Ctrl + Shift + N). Display a dialog window where you can choose position 
and  number of new pages and their parameters (size, orientation, field contents size). 

 Replace pages. Replace current or selected pages. You can also use a panel with thumbnails to 
select and replace pages.

 Delete Pages (Alt+Del). Remove current or selected pages. You can also use a panel with  
thumbnails to select and delete pages.

 Move Pages. Display a dialog window where you can set specific pages to move and their 
destination. Can be used with thumbnails panel, which allows to choose pages with mouse. You 
can use Shift key with left mouse button to select a continuous group of pages. You can choose any 
group and number of pages if holding Ctrl key. 

 Crop Page (Ctrl+K). Crop page content with mouse.
 Page Layout (Ctrl + Shift + L). Display a window which allows to set page layout (width, height 

in pixels, inches or mm) and content size if user needs to display only part of a page (left, right, top 
and bottom fields). 

 Rotate Pages (Ctrl + R). Rotate current or selected pages by 90, 180 or 270 degrees.
 Extract Pages (Ctrl + Shift + E). Specify file name to export pages to (you can also use Browse 

button) and numbers of pages to export. It is possible to export all the pages to same file or create 
separate file for each page. You can also export bookmarks.

 Insert Pages (Ctrl + Shift + I). Import pages from specific PDF file (use Browse button), specify 
location for import in the current document and numbers of pages for import. Allows to   import 
bookmarks as well.

 Organize Pages… View the pages of the PDF file in the Navigation Area in thumbnail format.
 Document Actions. Creation and modifying of JavaScript functions to be executed on specific 

document actions, such as: Document Did Print, Document Did Save, Document Will Close, 
Document Will Print, Document Will Save.

 Document JavaScript. Creation and modifying of JavaScript code to be executed on document 
opening. Global JavaScript functions and variables called from local events are also defined here.

 JavaScript Console. Allows to execute any JavaScript code or get debug JavaScript output of 
current document. 

 Header and Footer  . Add/Delete headers and footers into PDF documents.
 Watermark  . Add/Delete watermarks into PDF documents.
 Background  . Add/Delete background into PDF documents.
 Page Properties. Setting tab order for PDF forms in Hand Tool mode. 
 Tab order. Set tab order for PDF forms in Hand Tool mode: Row Order, Column Order, 

Document Structure, Unspecified. 
 Actions. Create and modify JavaScript code to be executed on page opening and closing.

 Redaction  . Hide sensitive or private information in PDF documents.
 OCR  .   Convert an image to text that way you can further work with the converted text. 
 Optimize Scanned Pages  . Reduce the size of PDF documents through optimization.
 Convert to Scanned Pages  . Change the pages of your document so that they look like they were 

scanned.
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Tools Menu

 Edit  Document  (Alt+1). Select  PDF objects  to  move,  resize  or  delete  them or  change  their 
properties. 

 Edit Text (Alt+2). Text editing only. 
 Edit Forms (Alt+3). Forms selection and editing. 
 Edit Images (Alt+4). mages selection and editing.
 Edit Vector Images (Alt+5). Vector images selection and editing.
 Select Text (Alt+5). Text selection only.
 Select text (Alt+7). Text selection only.
 Take a Snapshot. Copy the selected area.
 Hand Tool (Alt+6). Move pages, open links, select text, and fill in PDF forms.
 Settings. Use this item for application settings.
 Toolbar Settings. Customize the display of items in the toolbar.
 Edit Text Elements as Blocks. Edit text elements as a block.
 Certificate Manager. Open the certificate manager window.

Help Menu

 Contents. Help contents.
 Home Page. Open main Master PDF Editor page.
 Register… Register Master PDF Editor copy.
 Check for updates. Check for Master PDF Editor updates available for you.
 About. View Master PDF Editor information. Use to see registration and version number.
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Preferences

In order to open settings window, choose Tools > Preferences in Main menu.
In Mac OS X it is Master PDF Editor > Preferences…

General tab

 Saving documents.
• Create backup file. Master PDF Editor creates a backup copy of the file when saving the 

current document. The backup is created only once.
• Choice destination for "Save As" documents. Choose folder to open when saving file with 

«Save As…».
• PDF Specification. Selecting of the required electronic format; set to automatic by default.
• Autosave. Master PDF Editor automatically saves the document for a certain period of time.
• Autosave interval. Selecting the frequency of auto-saving the document. 

 History.
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• Restore last session when application start. Master PDF Editor saves and restores all opened 
documents and panel locations when relaunching the program, if any were open when the 
application was closed last time.

• Restore last view settings when reopening. If enabled, the last specified viewing options are 
restored when the document is reopened.

• Save recent files list. Pinning files to the list of recently used documents. When you open 
Master PDF Editor, these documents will be displayed in the Recent Files list on the Start 
page.

 Open documents as new tabs in the same window (requires restart). If disabled, each PDF file 
will be open in a new window. (Option is absent in Mac OS, because there it is set in general 
system preferences.)

 Allow opening same document in multiple tabs. This option is disabled by default. 
 Lock file from opening by other instances of Master PDF Editor. Master PDF Editor locks 

simultaneous opening of the same file; the option is disabled by default.
 Enable scroll wheel zooming. Disables/enables zoom control when the Ctrl key and the mouse 

wheel or touchpad are pressed.
 Show Quick actions on text and comments selection. Displaying the quick actions when a text 

or comment is selected with the help of the Hand tool. 
 Show Start page. Displaying the Start page with a list of recently opened documents and the most 

frequently used functions. The start page is displayed only when there is no open document.

Application relaunch is required for settings to take effect.
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System Tab

 Alternative method for PDF render. An alternative method for rendering PDF on the screen, in 
some cases it speeds up rendering up to 4 times.

 Load all objects separately. If enabled (it’s enabled by default), all container objects will be 
loaded separately. This option is used for the convenience of editing the objects contained in the 
container. Disable this option if you have problems displaying the PDF.

 Memory/Speed. The setting allows you to set either saving RAM, or speeding up drawing by 
using previously rendered pages in the cache. 

 Enable logging to file. When enabled, Master PDF Editor saves warnings and errors in a log file 
while operating. 

Application relaunch is required for settings to take effect.
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Forms Tab

 Highlight color. Set color for highlighted PDF forms.
 Required field highlight color. Set color for highlighted required PDF forms.
 Always hide document message bar. Always hide pop up message. 

You can set the default settings for newly created PDF forms below on this tab.
 Options. Set default options for creating various forms.

• Line thickness.
• Border Color.
• Line style.
• Highlight.

 Export.
• Add full path to filename in export file. Set file name when exporting form information.

  Recreate PDF forms when opening. This option allows you to avoid display errors of some 
forms, but slows down the opening of files when enabled.

 Show warning when opening links. If enabled, a warning notice appears when links are opened.
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 Convert static XFA into normal PDF when opening file. If this option is enabled, static XFA 
forms are automatically converted into standard PDF form format. This allows you to properly fill 
out and edit the form fields. If the option is disabled, forms can still be filled out, but editing is not 
possible.

When enabled, XFA data will be removed from the document structure after saving. When disabled, 
XFA data remains in the document, and filled forms will display correctly in third-party applications.

If the document contains XFA forms and the Convert static XFA into normal PDF when opening file 
option is disabled, the following features will be unavailable:    

 Exporting pages to Text, Excel, CSV, or Word formats; 

 Extracting all images from the document;  

 Converting the document to PDF/A.

To use these features, it is recommended to enable this option when opening the document. 

Application relaunch is required for settings to take effect.
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Editing

 Page scrolling options

• Enable scroll without delay. Scrolling pages without delay in time. 
• Configure scroll value. Set the necessary number of mouse scrolls for page scrolling. 
• Time before a move or resize starts. Time after object selection before it can be dragged or 

resized. Prevents random mouse dragging. 

 Default font. Set default font settings for application.
 Automatically change font when editing text. Automatic replacement of PDF font for system 

TTF font when editing text. Automatic replacement happens only if the application finds similar 
font in the system. 

 Exact match only.  Disables changing the font to  a similar one, and do it  only if  you have a 
completely appropriate font.

 Edit Text Elements as Blocks. Editing text elements as blocks.
 Save last editing Tool. When closing the program, the last tool is saved enabled it by default the 

next time you open it.
 Always show Object Inspector. Open the Object Inspector by default.
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 Create Pencil lines as single object. Lines are created as a single object when using Pencil tool. 
 When dragging pages through Navigation Panel,  navigate to the selected of  the dragged 

pages. If enabled, page selected in Navigation Panel opens when dragging.
 Show check boxes to select pages. Shows or hides check boxes on page thumbnails that allows 

selecting multiple pages. By default, the option is enabled.
 Selected text color. Choose a selected text color used by default. 
 Custom Page Manager. Add, edit, or delete a custom page size. 

Grid

The grid is used for more detailed positioning of text and objects in a document. With the Snap to Grid 
option enabled, the object will automatically align to the nearest grid line after it is moved. Enable/Disable 
positioning in the main menu View > Snap to Grid.

The grid is displayed on the screen but not printed in the document. You can show/hide the grid in the 
main menu View > Grid.

 Units. Selecting the unit of measure for the grid dimensions.

Copyright © 2026 Code Industry Ltd



 Width between lines. Setting the width of the grid cell.
 Height between lines. Setting the height of the grid cell.
 Left offset. Selecting the grid offset value from the left edge.
 Top offset. Selecting the grid offset value from the top edge.
 Subdivision. Setting the number of additional cells within each main cell.
 Color. Selecting the color of the grid lines.
 Line width. Setting the line width of the grid. 
 Opacity. Setting the grid opacity.

 Additional cell lines are lighter than the main ones.

JavaScript

 Enable JavaScript. Enables or disables JavaScript usage in PDF files.
 Show errors and messages in console. Show errors and messages in console. Outputs all 

JavaScript messages to the console after executing document’s code. JavaScript console can be 
opened in Document > JavaScript Console.
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 Enable safe reading mode. When enabled, some Java functions are prohibited. 

Application relaunch is required for settings to take effect.

Comments

This tab allows you to configure default properties for all comment and annotation types. Settings are 
applied automatically when creating new comments.

General Settings:

• Author. The name that will appear as the comment author. By default, the system username is 
used. You can specify a custom name, which will be saved with all newly created comments.

• Comment type (Sticky Note). Select the comment type for which you want to define default 
parameters.

To configure settings for a specific comment type, select it from the Comment type drop-down list. 
All subsequent changes will apply only to that type. Configure one type, then select the next from the list 
and set its parameters. Click OK after completing all settings.

Settings for all comment types

• Pop-up Opacity. Sets the transparency level of the pop-up window that appears when hovering 
over a comment.
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• Tooltip Display Delay. Sets the delay (in milliseconds) before comment text appears as a tooltip 
when hovering over an annotation.

• Repair Original Comment View. When enabled, the program automatically restores comments 
with damaged or incomplete structure (e.g., after export in third-party applications) when opening 
a document.

Sticky Note settings

• Type. Choose the appearance of the Sticky Note: comment, check mark, circle, cross, star, and 
others.

• Opacity. Sets the transparency level of the Sticky Note.

• Color. Sets the color of the Sticky Note icon and pop-up panel.

• Size. Sets the size of the Sticky Note on the page.

Settings for Highlight Text, Underline Text, Strikeout Text, Measurements, and Drawing Tools

• Opacity. Sets the transparency level of the annotation line.

• Color. Sets the color of the annotation line.

• Line Width. Sets the thickness of lines.

Drawing Tools Specific Setting

• Create Pencil and Brush lines as single object. When enabled, all strokes created with the Pencil 
or Brush tools are combined into one object.

Typewriter settings

• Text. Configure font properties: family, size, style, color, and alignment.

• Border and Colors. Sets the color and thickness of the border, the fill color.

Callout settings

• Default Width. Sets the default width of the border.

• Callout arrow. Configure the appearance of the leader line arrowhead: select its size and symbol 
type (arrow, circle, diamond, etc.).

• Show move grip. When enabled, allows you to drag the entire text block (including borders) to 
another location on the page.
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Display

 Default Layout and Zoom. Page settings for newly opened and created PDF files.
 Smooth text and images. Choose objects to apply antialiasing.
 Replace Document Colors. If enabled, provides possibility to change font and background color 

in the document.
 Resolution.

• System PPI. Uses the system PPI setting to display the document on the monitor.
• Custom resolution. Allows to set monitor resolution manually if it's required for your work or 

Master PDF Editor incorrectly identified it.
 Layer Visibility by default. Allows configuring layer visibility for the newly opened documents.

• Use configuration in document. Displays layers as they were previously saved in the settings 
for default visibility in the document.

• Show all layers. Shows all layers when opening a document.
• Hide all layers. Hides all layers when opening a document.
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Toolbars

Users can configure the number and location of toolbars, as well as a specific set of tools on the Toolbars 
tab.

 Toolbars.  This list contains existing toolbars. It’s enough just to select a toolbar and click the 
Delete Toolbar button To delete a toolbar. The tools in the selected panel will be displayed in the 
Current toolbar tools list.

 Add Toolbar.  If the text field to the left of this button is filled, then when you click, an empty 
toolbar with the specified name will be created and added to the list.

 Toolbars customization.

You need to  create  a  toolbar  (if  it  hasn't  already been created)  and select  it  in  the  Toolbars list  to 
customize it.

All tools that are available yet not added to the selected panel are listed in the tree menu All Tools. Tools 
are divided into categories according to which you can find them in the main menu. To add a tool to the  
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current panel, choose it from the list and push the ► button. Press the ◄ button to delete the selected tool  
from the list of tools in the Current toolbar tools list that includes the tools from the specified panel. 

Despite appearing in the list of All Tools, outside of the category, the Separator is not a tool.  This graphic 
divider makes it possible to group the tools into different categories within a single panel. It can be added 
multiple times.

The selected tool in the Current toolbar tools list can be deleted with the ◄ button. It can also be moved 
up or down with the corresponding ▲ and ▼ buttons relative to other tools.

The Reset All button allows you to reset the toolbars to one of the two predefined ones. The Minimum 
Tools set includes the minimum required tools in the visible panels, and a few in the hidden ones. Right-
click any active tool in the main window to display hidden toolbars.  The drop-down list  has marked 
toolbars that are clearly visible. Panels may then be checked or unchecked to be visible or hidden.

All of the tools that are readily available and visible on toolbars are already included in the  Maximum 
tools set.
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Appearance

Tab is available on Windows and Linux only.

 Application style. Select color theme from the drop-down menu. 
 Icons. Select set and size of icons. 
 Icons in menus. Check or uncheck to show or hide icons in the Main menu. This option does not 

work for some Linux desktop shells, such as Unity.

Application relaunch is required for settings to take effect.
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Keyboard

On this tab, you can set up hotkeys in Master PDF Editor. You can set the hotkeys for each tab of the 
Main menu. 

Application relaunch is required for settings to take effect.
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Email

Setting up email sending options in Master PDF Editor.

 Use default program. Launches the email client installed by default on the system.
 Use SMTP. There are the basic SMTP server settings, such as the address, port, username, and 

password used to send email. If you do not know how to complete them, contact your system 
administrator.
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OCR

Master PDF Editor implements Optical Character Recognition (OCR) in PDF files containing images (for 
example: scanned documents that have been previously converted to PDF files). This function allows you 
to search, edit and copy text in a PDF document.

 Default path to tesseract ocr data files. Allows you to install one directory for multiple users. 
The setting is mostly used on servers.

 Additional tesseract ocr config file. Used for more precise and fine setting of tesseract ocr. See 
the help system for tesseract ocr, for more information.

 Maximum CPU usage for OCR. Maximum usage of CPU when performing OCR.
 Automatically recognize text. When enabled, documents will be recognized automatically. By 

default, automatic text recognition is enabled.
 Install languages. Select languages for text recognition.
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Redaction

On the Redaction tab, you can configure settings for redacting sensitive information in a document. 

 Redacted Area Fill Color. Specifies the default color to fill the redacted area blocks.
 Use Overlay Text. This option puts a specified text over each redacted block. You can specify 

Font, Size, Color, and alignment of the text.
 Auto-size text. Automatically adjusts the size of the overlay text to the size of the redacted area.
 Repeat Overlay Text. This option will fill the entire redacted area with the specified text, repeated 

multiple times.
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Network 

On the Network tab, you can set up a connection to the Internet. If you don’t know the required settings, 
contact your system administrator.

 Direct internet connection. Allows connecting to the Internet directly.
 Manual proxy configuration. Allows selecting the required protocol and configuring additional 

settings for the connection.
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Certificates

On the Certificates tab, you can configure settings for a digital signature and certificates in Master PDF 
Editor. 

 Strong verification of signatures. When enabled, only the last added digital signature is valid. 
 PKCS#11 provider. Allows setting a path to the library when configuring a token for signing 

documents.
 Default paths for system certificates. Shows information about the location of system certificates 

and allows specifying a path if needed.  
 Database for Certificate Manager. This section contains a path to the database for the Certificate  

Manager and a database password. 
 Certificate manager. Opens the Certificate Manager on Linux.

Language

Select the language for the program interface.

Application relaunch is required for settings to take effect.
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Update

Set frequency for automatic update check. You can set to check never, weekly or monthly. In order to  
check for updates manually choose Help > Check for Updates in Main menu.

Document Properties

Choose File > Properties in Main menu or press Ctrl + D.
Document properties window includes four tabs:  Document Info,  Security,  Initial View and  Fonts. You 
can see how it looks below.

Document Info

Document Info tab contains the following PDF Information (metadata): Title, Subject, Author, Creator and 
Producer.  Users  can  add  as  well  as  remove  the  metadata.  User  can  also  specify  some  keywords  
corresponding to the content of the document in the bottom field.
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Document Security

Access to PDF can be limited with a password. For security purposes you can also disable some functions, 
for example printing or editing. However, it is impossible to prohibit saving PDF copies. It is ensured, that 
copies will have same limitations as original PDF file.

Push Change button to set password and edit items in Permissions group. Additional window will appear, 
it allows to set passwords for the document.
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Two types of passwords can be used for PDF encryption:
 Document open password. A password required to open the document. 
 Permissions password. If some functions are disabled for the document (Permissions list), a 

permissions password for access rights modification must be set. Document open password is not 
required.

If PDF file is protected with passwords of both kinds, it can be opened with any of the passwords. But  
user has to enter  Permissions password to access  Permissions.  It is advised to set both passwords to 
establish better security.

 Printing the document. Printing is possible with 150 dpi or lower resolution.
 Print a high resolution version of the document. Printing is possible with any resolutions.
 Content copying for accessibility. Allows users to select and copy document text.
 Extract the content of the document. Allows to copy text and other objects.
 Fill in existing form or signature fields. Users may fill and sign form fields. Doesn't allow to add 

comments and create new form fields.
 Commenting. Filling form fields and digital signature signing. Users may sign with digital 

signature, leave their comments and ,fill forms. However, users cannot move objects on the page 
or create new form fields.
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 Manage pages and bookmarks. Allows to insert, remove and rotate pages, create bookmarks and 
thumbnails.

 Modifying document. Allows to change document content (text, images etc).

Initial View

Initial View tab provides means to set view of the document workspace for any PDF viewer used to open 
it.
This tab allows to set the initial appearance of the pages and the navigation panel, zoom level, window 
options, and user interface options. You can set the initial view to Open in Full Screen mode to view PDF 
presentations.

When reopening, the settings of these parameters will be ignored if the option  Restore last view 
settings when reopening is enabled on the main menu Tools > Settings, the General tab.

 Layout and Destination.
• Navigation Tab. Select the tab displaying on the Navigation Panel. 
• Page layout . Select required page view mode from the list.
• Zoom. Set the document zoom. 
• Open to Page. Specify number of the first page for view.
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Zoom will only be applied correctly in the document properties if the option Automatic for the Zoom 
parameter is enabled on the main menu Tools > Settings, the Display tab.

 Window options.
• Center window on screen. The option is not available. It’s added for compatibility with some 

other programs. 
• Display document title.  Shows the file name or document title in the title bar. The document 

name is indicated on the Document Info tab.
• Open in Full Screen mode.  Set a maximum size of the document window and displays the 

document without the menu bar, toolbar and management elements.

Use F11 key to exit the full-screen view of the document. Use hotkeys to edit in this mode. 

 User Interface Options.
• Hide menu bar. Show/hide the menu.
• Hide tool bar. Show/hide the tool bar.
• Hide Window Controls. The option is not available. It’s added for compatibility with some 

other programs. 

Fonts

Fonts tab provides a list of all fonts used in the document.
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Actions

On this tab, the user can set the action performed when opening this PDF document in any viewer: Go to 
a Page View, Open/execute a File, Open a web link, Reset form, Show/Hide fields, Submit a form, Run a 
JavaScript.

 Setting an action to be performed when opening a document, the settings of the Go to a Page View 
parameter of the Layout and Destination (Initial View tab) will be ignored.
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Create a new document

There are several ways to create a document in Master PDF Editor:
 Create a new document with blank pages.
 Create a new document from PDF or image files.
 Insert pages from other PDF or image files into the current document.
 Create a new document using a scanner.
 Import PDF pages from another PDF file.
 Insert blank pages into an existing document.
 Create a new document using the virtual PDF printer.

 Click the drop-down list icon ▼ to the right of the New Document button  to select one of the 

options to create a new document on the toolbar. This option will be saved during the current session in  
Master PDF Editor and will change the icon to the one you used (  or ).

Create a blank PDF

Select File > New > Blank PDF in the main menu, or click the New Document button on the toolbar (or 
press the keyboard shortcut Ctrl+N) to create a blank PDF.

There are parameters in the dialog box Create a new blank PDF: page size and orientation, content size, 
and number of pages in the document.
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 Page Size. Select one of the page sizes in the suggested list or set a custom page size in the 
following units: points, inches, and millimeters.
• Add new format. Save a custom page size in the page size selection as a preset.

You can delete or edit a custom page size in the Custom Page Manager. To open the Custom Page 

Manager, click the Tools > Settings menu and switch to the Editing tab.

 Contents Size. Set indent sizes to display only part of the PDF document page.
 Number of pages. Specify the number of pages to create in the document. 
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Create a new document from files 

Master PDF Editor allows creating a new document by adding several files to it at once. It supports the  
following formats: *.pdf, *.svg, *.svgz, *.tif, *.tiff, *.png, *.jpg, *.jpeg, *.bmp, *.ppm. They can be added 
both individually and entire directories, followed by sorting the list of files by the order of addition and  
selecting the necessary pages from multi-page files. Also, it’s possible to add new files and individual 
pages to the current document by specifying the insertion position.

Select File > New > From files in the main menu to create a new document from files, or click the Create  
new document from files button on the toolbar.

Click the corresponding button on the toolbar to add the necessary files or directories with files In the  
Create a new document from files dialog box: 

 Add files.
 Add Folder.

Then, specify the order in which files and pages from these files are added to the document in the sort 
added files window. Next step is choosing which document (new or current) you want to add them to. 
Specifying the location is necessary to add to the current document.

 Add files. Add files separately.
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 Add Folder. Add a folder with files.
 File information in the list. 

• File Name. Location path and file name.
• Page Range. The number and order of pages to be added to the document.
• Total pages. Total number of pages in the added file. 

 Selected files in the list.
• Up. Move the selected files to the top of the list.
• Down. Move the selected files to the bottom of the list.
• Delete. Delete selected files from the list. 
• Page Range. Select the page range for the selected file. 

 Create New Document. 

 A new document is saved to the Documents folder by default.

 Append to Current Document. Add the file to the current document.
 Position. Specify the position of the inserted pages in the current document:

• Before current page.
• After current page.
• Before first.
• After last page.

 Import Bookmarks. Import bookmarks from the selected files or pages. 
 Create a bookmark with the name of imported document. If enabled, a bookmark will be 

created with the same name as the imported document has. 
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Scan a paper document to PDF

This function allows creating a PDF file directly from a paper document, using your scanner and the 
Master PDF Editor. 
To create a new document from scanner, choose File > New > From Scanner in the main menu or press 

Create a new document from scanner button  on the toolbar. 

Scanner selection

Scanner selection is available only on Linux systems.

Upon the first scanning session, the Select Scanners dialog will open. It displays a list of available 
devices.

Check one or several scanners you need and click OK. The selected scanners will be added to the 
Scanner drop-down list in the Scan dialog.

In this window, you can select scanners for further work

The Select Scanners dialog also includes the following options:

• Always search for devices – automatically search for available scanners each time scanning is 
started.

• Show network scanners – display scanners connected to the network in the list.

The Reload button performs the search again and refreshes the list of scanners.
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After selecting a scanner, the Scan dialog opens to configure scanning parameters.

How to change the selected scanner

Further actions depend on whether the Always search for devices option is enabled:

If Always search for devices is enabled:

The Select Scanners dialog opens automatically each time scanning is started. Uncheck the device which 
is no longer required, check the needed scanner, and click OK.

If Always search for devices is disabled:  

1. Open the Scan dialog by selecting File > New > From Scanner in the main menu or select Create 
a new document > From scanner on the toolbar. 

2. Open the Select Scanners dialog using one of the following methods:

2.1. Click the refresh button  to the right of the Scanner drop-down list.

2.2. Click the Scanner drop-down list and select Select Scanners at the bottom of the list.

3. In the opened dialog, uncheck the device which is no longer required, select the new scanner, and 
click OK.
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Scan settings

The Scan dialog allows you to save frequently used parameter combinations as presets and to configure 
device, source, and visual scanning parameters.

You can adjust scan settings here

All the inputs that can be changed are described below.

Saved settings 

Allow saving all the settings that were applied previously and saved as a template. Once you choose this 
template from the list, all the preset settings will be applied.
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Input

• Scanner. Choose one of the connected scanners installed in the system from the list in Scan dialog 

box. To find new devices, you need to update the list by clicking the refresh button  on the right of 
the Scanner drop-down list. Note: if there are many connected scanners, the updating process can 
take some time. 

        If the scanner is disconnected or offline, a red Offline text will appear next to its name in the list 
after selection.

• Scan. Choose if you need to scan a single page or all pages from the feeder.

• Page Size. Allows selecting the size option of the scanned document from the list below that suits 
your needs.

Options

This tab allows configuring visual scan settings  

• Scan source. Note: during the scanning process, Master PDF Editor uses the driver of the scanner 
installed in the system, so the number of scan settings may vary. Below are some types of options 
that you can find.

1. Flatbed. Place the document manually on the scanner glass. Suitable for single pages.

2. ADF (Automatic Document Feeder). Automatic feeding of a stack of pages. Only the front side 
of each page is scanned. 

3. ADF (Automatic Document Feeder) Duplex. Automatic feeding with simultaneous scanning of 
both sides of the page in a single pass. 

4. ADF (Automatic Document Feeder) Front/Back. Automatic feeding with sequential scanning. 
First all front sides of the stack are scanned, then the scanner prompts you to reload the pages 
for scanning the back sides.

• Negative. Allows changing a colored PDF to black-and-white.

• Scan mode. Choose a scanning mode that best matches the type of document that is scanned. The 
available modes are Color Document and Grayscale Document.

• Scan resolution. Master PDF Editor supports scan resolutions ranging between 75 DPI and 600 
DPI. Typically, 300 DPI is the optimal resolution for scanning documents in order to balance 
readability and file size. It is set by default. 
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Size

Here you can manually adjust the page size

These tab values are compliant with the Page Size option. You can change the values manually if needed.

Additional

In this tab, you can choose actions to be performed after completing the scanning session

• Prompt to Scan More Pages. Allows scanning multiple files into a PDF. 

• Show Crop Page Dialogue. Crop pages visually and then refine the cropped area.

Output

• Create  New Document. After  scanning  a  file,  a  new document  with  the  scanned  content  is 
created.

• Append to  Current  Document.  Choose  this  option to  append  a  scanned  file  to  the  opened 
document. 

Miscellaneous

• Deskew. Allows straightening a scanned document if it is scanned at an angle. 

• Remove background. Removes an unwanted background from the scanned document. 

• Skip empty pages. Allows skipping pages without content while scanning a document. 

• Preview. Select this option to preview the scanned file before adding it to a new document. 

• Scan. After the setting all the parameters, click Scan to scan your document. 

Opening and Saving Files

Master PDF Editor is fully compatible with PDF specification 1.7 and also supports files with dynamic 
XFA forms, which allows the application to open and view any files created in other PDF editors while 
saving their settings.
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Opening PDF Files

PDF document can be opened:
 From Master PDF Editor application. Choose File > Open or press Ctrl+O. Select the PDF file 

and open it. 

 From the Toolbar panel. Select Open File  on the Toolbar panel. 
 From file system. Open Master PDF Editor window and drag PDF file into it.
 From Explorer window. Right-click a PDF file on any Explorer window to open a contextual 

menu, then select Open with Master PDF Editor. 
It’s possible to open PDF files downloaded on the Internet and a local network or sent by email the same 
way.

Opened files are displayed in the form of tabs:
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Recently Opened Files

Master PDF Editor saves files that have been recently opened. To view recently opened documents do the 
following:

 Select one of the recently opened files on the start page.

 Select File > Recent files on the main menu and choose one of the recently opened files. 
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• Click dropdown list ▼ icon to the left   Open file button on the toolbar.

To clear history of recently used files select File > Recent files > Empty recent files list.
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NOTE: Master PDF Editor fully supports the PDF 1.7 specification as well as dynamic XFA files that  
allows the program to open and view any files created with other PDF editors.

Opening Protected PDF Document

Password protection allows you to prevent unauthorized persons from performing certain actions with the 
document. Without the password, a user cannot open the document or is not allowed to edit, print or 
comment the document. There are two types of protection. 

 With a password. 
• The first one is a password to open the document. If you just want to share the document with 

another person and don’t want others to be able to open it, you most likely need a password to 
open. 

• The second type is  a permission password. A permission password allows only the selected 
actions and prohibits all others. So, for instance you may create a password that allows viewing 
and commenting the PDF document, but does not allow printing or editing.
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 With a certificate. Securing a PDF file using a certificate is a reliable way to limit the scope of 
persons  who  can  access  the  document.  The  encrypted  document  will  only  be  accessible  by 
recipients whose certificates are explicitly included to the list  of valid recipients for this PDF 
document. If the certificate isn’t included, the following window pops up:

 More detailed information is provided in Document Properties section.

Opening PDF documents locked by another instance

If  Lock file from opening by other instances of Master PDF Editor is enabled, another  instance can be 
opened only in a read-only mode. 

If enabled, a lock.pdf.lock file is created when opening other instances. In this way, another instance can 
be opened only in a read-only mode. The lock.pdf.lock file is a temporary file that is automatically deleted 
when all instances are closed. 
At the same time, a work opened in other instances can be saved only to another file.
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If  Lock file from opening by other instances of Master PDF Editor is disabled, other instances can be 
opened and edited. 

Saving PDF Files

Master PDF Editor allows to save PDF documents with comments, records in form fields and digital  
signatures. Users may modify files, if document owner hadn't set certain limitations. 

All  additional  prohibitions  for  using  and  saving  files  may  be  viewed  in  menu  File > Document  
Properties, Security tab.
In order to save changes in the current file, do the following:

 Select File > Save in the Main menu or press  Save button on the toolbar. You can also use 

Ctrl+S keyboard shortcut.

 To save PDF file copy, choose File > Save As… in Main menu or press  Save As... button on 
the toolbar. You can also use  Ctrl+Shift+S keyboard shortcut.

To export PDF into variety of image formats choose File > Export to > Images.

Repeated saving of PDF file with digital signature invalidates the signature.

Save session

Master PDF Editor allows saving open documents as a session for later viewing or editing.  A saved 
session recovers the number and tab order of open documents and the last saved modifications in the 
documents. 

The following ways are available to save a session selecting  Files > Sessions menu item:

 Save session. Save a session either to the session list or as a file, depending on the way of session 
opening. 

 Save session to file. Save a session as the.mpesession file to a local folder.
 Save session to managed sessions. Save a session to the sessions list (Manage sessions dialog).
 Save and close current session. Save a session and close the open documents. 
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Users can open a stored session at a later time by selecting File > Sessions > Manage sessions or from 
recent sessions list in the  Sessions drop-down menu. A current session name displays below the recent 
sessions list. To clear the history of recently used session, select File > Sessions > Clear recent sessions  
list.

Sessions  are  automatically  saved when opening a  new document,  closing  a  document  tab,  closing  a  
window, switching sessions.
 
Autosave session is automatically created when opening any document. You can edit a session name in 
the Manage sessions window and then continue editing documents. 

 Session behavior may change if the general parameters below are enabled:

 If  Restore last session when application start  is enabled, all last session documents are restored 
when relaunching the program, if any were open when the application was closed last time. 

 To restore the last specified viewing options when the document is reopened, enable Restore last  
view settings when reopening.

 Enable Save recent files list to pin sessions to the list of recently used sessions. 
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Manage sessions

When selecting File > Sessions > Manage sessions, the dialog opens:

This  will  display  the  stored  sessions  list.  You  can  sort  sessions  by  session  name,  creation  and  last  
modification date, and the number of documents opened in the session. 

The following actions are available to manage sessions:

 New. Create a new session.
 Clone. Copy the selected session.
 Switch to. Switch to the selected session or double-click the selected session to open it. 
 Import. Import the selected session to the Sessions list. 
 Export. Export the selected session to a local folder. 
 Rename. Change the selected session name.
 Remove. Remove the selected session from the Sessions list. 
 Remove all. Remove all sessions from the Sessions list.
 Store paths to documents relative to session file when exporting sessions. When exporting 

sessions, the file path is saved relative to the current directory. 

 Follow the recommendations when exporting and importing a session file so it’s opened correctly:

1. Export a session file to the folder holding all documents that saved in a session. Moreover, all 
documents saved as a session should be in the same folder.

2. It’s not recommended to change folder names and order when session file path is saved. 
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3. When opening a saved session file, a session file and all documents opened in a session, should be 
in the same folder at the moment a session was saved.   

Document backup and auto-saving

The backup saving option allows to create a backup file for your file when you save it while the Autosave 
function automatically saves your content at certain intervals. 

 Create backup file. Allows to create a backup file for your file when you save it. The backup file 
is saved with a .backup postfix, it’s created only once. 

 Select destination. Select a destination folder from the list for Save As documents.

 PDF Specification. The PDF Specification describes the required electronic format. The 
specifications are a required version of the PDF standard and must be followed in order for the 
data file to be processed. You can choose the specification from 1.3 to 1.7. to auto by default. It's 
recommended to keep the default setting (auto) if it's not entirely clear what the PDF Specification 
is.

 Autosave. If enabled, automatically saves your content at certain intervals. The menu allows you 
to enable this option only for open files, which is off by default after an installation.

 Autosave interval. If enabled, Master PDF Editor automatically saves the unsaved content; set to 
5 minutes by default.

 If your file is corrupted, you can use the backup file to recover it. Please note that you can’t see 
changes made after the last save in the backup file. Backup saving is disabled by default. 

 Since it’s not necessary to make all data backup, Master PDF Editor allows creating only document 
backup.  However,  user  can  make  configuration  file  backup  saving  it.  The  directory  location  of  the 
configuration file that contains information determining the application behavior is /Home/.config/Code 
Industry. 
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Optimization and Saving

When  bandwidth  is  crucial,  you  can  reduce  size  of  PDF  documents  by  applying  optimization. 
Optimization removes unnecessary and unused elements from the PDF file and compresses images and 
forms to reduce the overall size of the document.

Please note that optimizing file with some compression methods may damage images, which will 
lead to poor printing quality.

To optimize and save PDF file go to File > Save Optimized As... from the main menu or use Ctrl+Alt+S 
shortcut.
This will open a window, which allows to set following preferences for color and black and white images.
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Settings available for optimization: 
 Remove unused elements.  Check the structure of the PDF document and removes any element 

that is not related to other elements and does not have links from other elements.
 Flatten form fields. Convert the form fields in the PDF document to exactly the same form fields, 

but nothing can be entered there. The existing shape values become text in the document. This 
option  is  useful  if  the  document  is  being  prepared  for  printing  and interactive  forms are  not 
required anyway. Conversion of PDF file to grayscale removes all comments and forms from the 
document. To save comments and forms, uncheck Flatten form fields box.

 Merge all layers. The optimized document looks the same, but loses all layer information.
 Font  embedding  and  substitution.  Non-embedded  fonts  in  the  optimized  document  will  be 

substituted by similar system-installed fonts. The fonts will then be embedded into the document.
 Convert document to grayscale. Convert all colors in the document to grayscale.

• Shades  of  gray  with  alpha  channel.  Convert  all  colors  to  grayscale,  preserving  the 
transparency.
• Black and white. Convert all colors to black and white.

 Color  and  Grayscale  Images. Adjust  the  compression  of  color  and  grayscale  images. 
Compression is performed by decreasing DPI, or by using one of the compression methods (see 
below).

 Black and White Images. Set the compression of black and white images. Compression reduces 
the size of B&W images.

Resolution cannot be further reduced for images with 16x16 DPI.

Set the following preferences if required.

DPI. Reduce image resolution to decrease file size.

Compression. Decreasing file size with different algorithms.  JPEG compression yields best results for 
photos with smooth color gradients. ZIP is the best choice for drawings and patterns with big areas of the 
same color. JBIG2 is applied for black and white pages. If the right algorithm is chosen, compression is 
conducted without losses, and lower quality images are better compressed. Images with text can be better  
compressed than with CCITT Group 4 algorithm, but compression takes more time. Currently, Master 
PDF Editor uses lossless compression.  CCITT Group 4 is also applied for pages with black and white 
images and is the fastest lossless compression algorithm. 

Quality. Available only for JPEG format. JPEG compression is always done with loss of image quality, 
since some pixel data are removed without possibility of restoring during compression. Color images are 
better compressed with lossy JPEG compression algorithm. Quality level around 75-95 has best size-
quality  ratio.  Quality  60-70 yields  small  picture  with  acceptable  quality.  30-50 quality  percentage  is 
optimal when small file size is important and image quality is not prioritized. 

Grayscale images are compressed with CCITT, JBIG2 and ZIP without losses. 
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Compression options

This option determines DPI of images. The lower DPI, the smaller is the size of compressed images. 
However, lower DPI leads to reduced quality as well.

Compare these two documents:

Original document (150 DPI)

Compressed document (75 DPI)
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Compression algorithm 

Master PDF Editor can compress images using several compression algorithms.

For color and grayscale images the following methods are available:

 ZIP is  lossless  compression  that  works  best  for  images  with  large  areas  of  solid  colors.  For  
photographic images provides low or no compression. 

 JPEG  is  a  lossy  compression  algorithm that  can  deliver  a  good  compromise  between  image 
quality  and  size.  This  method  yields  the  best  results  for  images  with  smooth  gradients 
(photographs). The  JPEG Quality option allows you to set the desired compression rate where 
higher values mean lower compression and better quality. 

NOTE:  JPEG  quality  level  of  75-90  provides  the  best  size-to-quality  ratio.  Values  of  60-70  offer  
acceptable quality and decent compression. Quality of 30-50 is used to achieve the smallest size of images  
where quality is not a priority.

Compare these documents optimized with different JPEG quality values:

JPEG Quality 80

JPEG Quality 60
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JPEG Quality 40

For black and white images the algorithms are:

 ZIP is lossless compression that is best for solid color areas or repeated patterns. 
 CCITT Group 4 is the fastest lossless compression algorithm to reduce size of black and white 

images. 
 JBIG2 provides lossless compression for BW images and delivers better compression ratio of 

images with text on them for the cost of compression speed. 
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Optimize scanned pages

In Master PDF Editor, you can optimize scanned documents using different image compression methods 
and advanced filters.

Choose Document > Optimize Scanned Pages. A dialog box will pop up.

In the Page Range section, you need to specify pages to optimize.

Select one of the following options:

 Current Page. Optimize the current page of the document.

 All Pages. Optimize all pages of the document.

 Pages. Optimize pages within a specified range.
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Image Compression

With the Apply Adaptive Compression option enabled, you can configure image optimization.

Select image compression methods, using the following options:

 Color and Grayscale Images. Compress color and grayscale images using JPEG or ZIP 
compression algorithm. For more information about these compression algorithms, see 
Compression algorithm.

JPEG compression algorithm is the best for compressing full-color images. ZIP is optimal for 

compressing pictures and images containing large areas of solid color.

 Black and White Images. Compress black and white images using ZIP, CCITT Group 4 or JBIG2 
compression algorithm. For more information about these compression algorithms, see 
Compression algorithm.

CCITT Group 4 algorithm is the best for compressing black and white images with text. JBIG2 is 

optimal for compressing black and white images with minimum quality loss.

In the lower part of the section, there is a slider that allows configuring the quality of optimized images.
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Move the slider to the left (towards Small Size) to apply maximum image compression. Move the slider to 
the right (towards High Quality) to maintain high image quality. 

Filters

The Filters section contains advanced settings for optimizing scanned documents. You can configure the 
following options:

 Deskew. Straighten pages scanned at an oblique angle.

 Remove background. Remove unwanted background from the scanned document.
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Exporting PDF documents

Export PDF to Image

Master PDF Editor allows to export PDF documents into image formats and then reopen them and use in  
another applications. 
When saving PDF file in image format, each page is saved in separate file. The only exception is export to 
TIFF format. When exporting to TIFF, user can choose whether to save whole PDF file into one file or 
each page separately.
To export PDF file to image, choose File > Export > Pages to Images.
This will open a dialog box with the following settings.

 File Name. Specify name and path for document export destination file (you can use  button).
 Page Range. Choose pages to export.
 Format. Choose compression format for output image (BMP, PNG, JPEG, TIFF).

• Transparent. If enabled, exported pages will have transparent background (available only 
when exporting to PNG).

• MultiPage. All PDF document pages will be exported into single file if enabled (available only 
when exporting to TIFF).

 Size. Specify DPI.
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 Export. Choose whether to export PDF file with or without annotations.

Press Export button, to convert PDF document to image, then click OK in the next window.
Export operation will be canceled, if cancel button is pressed. 

If the document contains XFA forms and the Convert static XFA to standard PDF when opening file 
option is disabled, the Export PDF to Image feature will be unavailable. To use this feature, it is 
recommend enabling the Convert static XFA to standard PDF when opening file option. 

Export PDF to Text 

To convert PDF file to text, choose File > Export > Export Pages to Text. This will open a dialog box 
with the following settings.

Specify a text file name, then all text content containing in a PDF document will be saved to this file. A  
user can choose whether to save whole PDF file into one text file or each page separately.
Page Range option allows to limit the exported page range. 

If the document contains XFA forms and the Convert static XFA to standard PDF when opening file 
option is disabled, the Export PDF to Text feature will be unavailable. To use this feature, it is recommend 
enabling the Convert static XFA to standard PDF when opening file option. 
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Export PDF to CSV

Choose File > Export > Export Pages to Text to convert PDF file to CSV format. This will open a dialog 
box with the following settings.

 File Name. Specify name and path for document export destination file (you can use Browse 
button).

 Page Range. Choose pages to export.
 Separator. Choose a field separator. 

If the document contains XFA forms and the Convert static XFA to standard PDF when opening file 
option is disabled, the Export PDF to CSV feature will be unavailable. To use this feature, it is 
recommend enabling the Convert static XFA to standard PDF when opening file option. 
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Export to Excel 

To convert PDF file to XLSX, choose File > Export > Export Pages to Excel. This will open a dialog box 
with the following settings.

 File Name. Specify name and path for document export destination file (you can use Browse 
button).

 Page Range. Choose pages to export.
 Excel Workbook Settings. Select a worksheet type to be created: for each table, for each page, 

single worksheet for the document. 
 Open the created file in the default application. Open the converted file with the default 

program right after exporting. 
 Export content other than Tables. Export the whole content of a page when converting to Excel 

tables.

Tables will be placed on the same Worksheet if they have similar structure. 

If the document contains XFA forms and the Convert static XFA to standard PDF when opening file 
option is disabled, the Export PDF to Excel feature will be unavailable. To use this feature, it is 
recommend enabling the Convert static XFA to standard PDF when opening file option. 
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Export to Word 

To convert PDF file to DOCX, choose File > Export > Export Pages to Word. 

The following options will be available in a dialog box that opens:
 File Name. Specify name and path for document export destination file (you can use Browse 

button).
 Page Range. Choose pages to export.
 Fill vertical space with empty lines. Text objects are separated vertically by empty lines with no 

characters. 
 Open the created file in the default application. Open the converted file with the default 

program right after exporting. 

If the document contains XFA forms and the Convert static XFA to standard PDF when opening file 
option is disabled, the Export PDF to Word feature will be unavailable. To use this feature, it is 
recommend enabling the Convert static XFA to standard PDF when opening file option. 

Convert to PDF/A

PDF/A is an ISO standard format for long-term preservation of electronic documents in PDF.  It ensures 
that the visual and structural content of documents is preserved, allowing them to be displayed 
appropriately throughout time.

To convert PDF to PDF/A format, go to File > Export > Convert to PDF/A from the main menu or use 
the keyboard shortcut Ctrl + Shift + A. The following dialog box will appear:
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Select the required level of PDF/A compliance from the PDF/A Compatible Level drop-down menu and 
click OK. 

The following is a list of PDF/A compliance levels available for converting documents in Master PDF 
Editor:

 PDF/A-1a. The PDF/A-1a format preserves all elements of the document, including its semantic 
structure, and ensures the material is accessible.

 PDF/A-1b. The PDF/A-1b format preserves the visual integrity of the document while not 
requiring preservation of the structure.

 PDF/A-2a. PDF/A-2a is a more flexible format than PDF/A-1a. This format supports modern 
functions like layers while preserving the semantic structure of the document for accessibility.

 PDF/A-2b. PDF/A-2b ensures visual integrity, similar to the PDF/A-1b format while also 
supporting modern PDF functions like font embedding and transparency.

 PDF/A-2u. PDF/A-2u supports new functions that improve document accessibility for people with 
disabilities. The format includes the use of text, alternative descriptions for images, and data 
structuring.

 PDF/A-3a. PDF/A-3a allows embedding files of other formats into a PDF document while 
preserving the accessibility and structure of the main content.

 PDF/A-3b. PDF/A-3b ensures visual integrity and support for attachments but does not require  
preservation of the semantic structure.

 PDF/A-3u. PDF/A-3u combines the capability to embed files of different formats with enhanced 
accessibility, making it useful for storing a variety of information.

If the document contains XFA forms and the Convert static XFA to standard PDF when opening file 
option is disabled, the Convert to PDF/A feature will be unavailable. To use this feature, it is recommend 
enabling the Convert static XFA to standard PDF when opening file option. 
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Closing

If you work with multiple documents and you need to close current PDF file, press Close button on the 
tab. You can also choose File > Close in main menu. Press Close button in Master PDF Editor window to 
close all documents.

If you work with single document, just click Close button in Master PDF Editor window.

PDF Files View

To adjust how the opened PDF file looks in the view area, use the View menu or the View toolbar (see 
below):

NOTE: The toolbar configuration shown in the screen above is not standard. How to customize toolbars,  
you can read here: Toolbars.

Zooming

To zoom contents  of  the PDF document,  use the  View >  Zoom menu or the toolbar.  The following 
zooming options are available:

 Zoom In.  Zoom in the document. You can also press Ctrl + “+” or scroll the mouse wheel up 
while holding Ctrl. 

 Zoom Out.  Zoom out the document. You can also press Ctrl + “–” or scroll the mouse wheel 
down while holding Ctrl. 
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 Actual Size.  Zoom the document to its actual size (100% scale). You can also press Ctrl + “0” 
to set the actual size of the document. 

You can set any specific scale manually by selecting it in the Zoom dropdown list or typing it there:

View modes

There are several page display modes in Master PDF Editor:

 Fit Page.  In this mode the contents of the document are displayed so that the entire page fits 
the view area. You can switch to this view mode by pressing Ctrl+1. 
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 Fit Width.  The contents of the document are displayed to fit the width of the view area. You 
can switch to this view mode by pressing Ctrl+2. 

 Facing pages.  This mode repeats the layout of books by displaying two pages side by side. 
You can use Facing pages with either Fit Page or Fit Width modes and with any custom scale. 

When the Facing mode is enabled, you can turn on/off displaying of the document’s cover page as a 
standalone page using the View > Page Display > Show Cover Page during Facing option.
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 Continuous.  While scrolling, pages are displayed continuously. 

Displaying grid

You can turn on displaying of the grid in the menu: View > Grid or using the Ctrl+U keyboard shortcut.

Grid is essential for accurate editing, to place aligned objects. To simplify this, you can turn on grid  
snapping using the View > Snap to Grid menu.
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Replacing document colors 

Color replacement makes easier viewing documents with highly variable color schemes or low-contrast or 
poorly distinguishable font and background colors.

To enable color replacement, select  View >  Replace document colors. It will replace the colors of the 
document to those specified in the settings: Tools > Settings > Display.

To adjust replacement colors, go to the Tools > Settings menu and switch to the Display section:

Rotating the page

 To rotate the page clockwise, click the Rotate 90 degrees clockwise button . 

 To rotate the page counterclockwise, click the Rotate 90 degrees counterclockwise button . 

Copyright © 2026 Code Industry Ltd



Page Alignment 

In Master PDF Editor, you can set page alignment to the left, center, or right. Alignment is performed 
relative to the page with the largest size in the document. 

To align pages in the document: 

1. Go to the main menu and select View > Align to Largest Page.  

2. Choose the desired alignment: Left, Center, or Right.

 By default, all pages are centered relative to the largest page.  
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Document Comparison

The document comparison feature allows you to find differences between two versions of a file. This is  
useful when working with updated documents, reviewing edits, or analyzing changes in contracts, reports, 
and other important files.

The comparison is performed based on the textual content of documents.

To compare documents, follow these steps:

1. Select the comparison function from the main menu:  View >  Compare. The  Compare Files dialog 
box will open.

2. Select documents for comparison:

 In the Old File field, specify the original document using one of these methods:

• Select from the list of open files.
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• Click Browse... to load a file from your computer.

 In the New File field, specify the new document for comparison using one of these methods:

• Select from the list of open files.
• Click Browse... to load a file from your computer.

You must select two different files for comparison.

3. To swap the Old and New files, click the Swap Files button between the file thumbnails.

4. Optionally, specify page ranges to limit the comparison to specific document sections. Set the page 
range for each document as needed.

5. Enable the  Compare with Shift Tolerance option to ignore simple shifts of entire text blocks on a 
page while detecting changes when individual text objects are moved to different areas of the page. 
This option helps focus on significant content changes.

6. Click OK to begin comparing documents. Master PDF Editor will display the comparison results in a 
new document.

Reviewing the comparison results

When the file  comparison is  finished,  a  file  named  The Result  of  Comparison.pdf is  generated and 
opened in a new tab. 

The result file displays the Old File on the left and the New File on the right, side by side with changes 
highlighted in color and accompanied by comments.

Three types of changes are marked in the result file:

 Addition. Highlighted in green.
 Deletion. Highlighted in red.
 Modification. Highlighted in blue.

Comments on changes are listed in the Navigation Panel on the left. 
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Comments for each change can also be viewed if you double-click the highlighted objects, or hover over 
them with a mouse. 
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To view comments added to the document before comparison, along with comments on changes, go 
to Comments > Comment View > Show by Reviewer in the main menu, then select All Reviewers. 

To save the comparison results, go to File > Save in the main menu, or press the Ctrl+S hotkey.

Document Navigation

Master PDF Editor offers several ways you can use to navigate opened documents.

Switching between PDF documents 

Master PDF Editor can open multiple PDF documents at once and allows you to switch between them.
All open documents display as tabs above the view area.

Click a tab to switch between open documents.
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Thumbnails

You can use page thumbnails to quickly move to the required page. 

To display the thumbnails of pages, click the Pages tab  in the Navigation Panel.

This will open the side panel with thumbnails of pages. Scroll through the panel to find a page you need, 
then click its thumbnail to get to it.

For a better experience, you can change the size of thumbnails and the Navigation Panel. Right click a 
thumbnail and choose Enlarge Page Thumbnails or Reduce Page Thumbnails in the context menu.
If you remove, copy, or move a thumbnail, the same action is applied to the corresponding page.

Page navigation 

To navigate through pages of the document, use the View > Go To menu, the View toolbar, or keyboard 
shortcuts.

 To go one page down, press PgDown.
 To go one page up, press PgUp.
 To go to the first page, press Home.
 To go to the last page, press End.
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If you know the exact page number you want to go to, type the number in the box on the View toolbar, 
then press Enter to go to that page.

View navigation

Views in Master PDF Editor are specific states of the view area that you can switch back and forth. A 
close analogy is Back and Forward buttons in a browser. When you click Back in your browser, you  
return to the previous page you viewed. The same way you can return to previous  views in the opened 
PDF document. This tool effectively allows you to quickly navigate through specific pages, search results,  
and various parts of the document without navigating to them directly again and again.

 To switch to the previous view, use the View > Go To > Previous View menu command, or click 

the Previous View toolbar button . 
 To switch to the next view, use the View > Go To > Next View menu command, or click the Next 

View toolbar button . 
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Searching in the PDF document

There are two ways in Master PDF Editor you can search through the PDF document:

 Use the search box on the toolbar.
 Use the Search side panel. 

Toolbar search box

To make a search using the toolbar box, type any keyword into the search box on the toolbar, then press 
Enter. To find the next occurrence of the keyword, press F3.

Search settings

Click the button  to bring up the search settings:

 Case Sensitive. Search for the keyword taking into account the exact case of symbols. 
 Include Comments. Search for the keyword in both the text of the document and the comments. 
 Whole Words Only. Search for the keyword as a whole word only, not a part of other words. 
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Search panel

To open the search panel, click the Search tab on the side panel , or press Ctrl+F. This will open the 
side panel. Type the keyword in the search box and press Enter.

In the below part of the left side panel, you will see all the results containing the specified keyword.

Clicking a result opens the corresponding page of the PDF document in the  Document Area and the 
keyword is highlighted in the text.

You can adjust the search preferences below the search box.

 Case Sensitive. Search for the keyword taking into account the exact case of symbols. 
 Include Comments. Search for the keyword in both the text of the document and the comments. 
 Whole Words Only. Search for the keyword as a whole word only, not a part of other words. 

Search history

The search history saves keywords entered into the toolbar search box or the search panel. This allows  
using search requests carried out before for the next searches. 

To open your search history, click the search box on the toolbar or on the left side Navigation Panel, or 

press the down arrow  of the drop-down box.

There are two ways to save keywords:    

1. Document history. Saves search requests for a particular document. 
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To clear the document history:

 Click the button  next to the keywords that should be removed.
 Or select the Clear document history option to delete all the search requests.

2. Global history. Saves search requests to use them in any document. 

To clear the global history:

 Click the button  next to the keywords that should be removed.
 Or select the Clear global history option to delete all the search requests.

Settings for the search history

To disable the document history and enable the global history:

1. Click the drop-down menu at the search box. 
2. Put a tick next to the Use global history option.
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Navigating using bookmarks

You can use bookmarks to go to specific locations in the document. Bookmarks are displayed as a tree in  
the Navigation Panel.

To navigate the document using bookmarks, click the  Bookmarks tab   on the left side panel. Then 

choose the required bookmark. You can expand its content with the Expand icon , or minimize it with 

the Collapse icon . 

Navigating to a bookmark not only restores the saved location in the document, but also the zoom 
level.

Apart from going to the required destination in the document, you can perform the following actions 
using bookmarks: open another file, a web link, reset forms, show or hide forms, submit forms, launch a 
JavaScript.

Please refer to the Managing bookmarks section to learn how you can add, delete, and modify bookmarks.
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Managing pages of PDF documents

Insert blank pages to PDF 

Master PDF Editor allows you to insert blank pages into the document to add the necessary text, images,  
forms, various controls etc.

To add blank pages to the document, select in the main menu Document > Insert blank pages  or press 
Ctrl+Shift+N.

In the Insert Blank Pages dialogue window, set page size and orientation, content size and number of 
pages in the document.

 Page Size. Choose one of default formats in the list or set custom page size, which can be 
measured in points, inches or millimeters. 

 Contents Size. Set size of margins to display document pages partially. 
 Position. Choose one of page insertion options: insert before the current page, after the current 

page, before the first page, or after the first page. 
 Number of pages. Set the number of pages. 
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Replace pages

To replace some PDF pages with new content, use the Document > Replace pages menu item or click the 

Pages button  on the left side panel to open the Thumbnails panel.

Select pages you want to replace from the PDF document. To select multiple pages, you can hold Ctrl and 
click pages, or hold  Shift and select a range of pages by clicking the first one then the last one in that 
range. 

Then, right-click the thumbnails and select Replace Pages. 
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The following window appears:

Here, you can specify which pages of the current document you need to replace, which new pages to add  
and replacements options:

 Pages To Replace. Select pages of the current document you want to replace. If Selected Pages in  
Navigation Panel enabled,  pages  selected in  the  current  document  will  be  replaced with  new 
pages. 

 New Pages. Select new pages to replace current pages with. Choose the source PDF file of new 
pages or the current document to add new pages. 

 Page Range. Specify page range of new pages.

 Replacement options. Set additional options for page replacement. 

• Import bookmarks. Import bookmarks from the selected pages.

 Pages will be reorganized according to the order they are listed in the document after replacement. 
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Split and Merge PDF Files

While the document is being developed, its content may require drastic changes. It can be assembled into  
a  single  document  out  of  several  sections.  Some  pages,  paragraphs,  and  sections  may  be  modified, 
rewritten, moved, or copied into a separate document. With Master PDF Editor you can perform these 
tasks effortlessly.

Split PDF Files

Splitting a PDF document is extracting some of its pages into a new PDF file with a new filename.

This section explains splitting PDF files in detail.

Extracting pages from one document and saving them to another

To split a PDF document into two or more parts and save them as separate documents, use the Document 
> Extract Pages... menu or press Ctrl+Shift+E. The following window appears:

Here, you can specify which pages of the current document you want to extract and save under a new 
name.
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 Pages are extracted in a new document with the name [original file name]_[indexes of extracted 
pages].

 The File Name box allows you to specify or browse for a file to save the extracted pages to. 
 The Page Range section determines what pages are extracted. 
 Extraction Format.

• Extract to single file. If enabled, this option extracts all the selected pages as a single PDF 
document. 

• Extract by page range. If this option is selected, the document is split into separate documents 
based on the specified page ranges. Example of page ranges: 1,6-8,12.

• Extract to multiple files. This option saves each of the selected pages as an individual 
document. 

 Export bookmarks. If there are some bookmarks pointing to the specified pages, those bookmarks 
are exported too. 

 Delete pages after extracting. This option removes the extracted pages from the original 
document, effectively splitting the PDF document into two or more documents: the extracted 
one(s) and the original document saved without the extracted pages. This action cannot be undone. 

 Create a bookmark with the name of imported document. If enabled, a bookmark will be created 
with the same name as the imported document has. 

Click Export to extract pages.

 Extracting of pages from some PDF files may be restricted by their owners. Restrictions can be  
found here: File > Properties > Security. 
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Merge PDF Files

This function allows merging and systematizing multiple separate PDF documents in a single file.

Merge using the Insert Pages tool

To merge two or more PDF documents into one, click the Document >Insert Pages... menu or click 
Ctrl+Shift+I. The Insert Pages dialog opens:

Here you can browse for all PDF files you want to assemble into one single document.

1. Click the Add Files or the Add Folder button to add a specific PDF or image file(s) or the entire 
contents of a folder to the below list. 

2. In the list, rearrange the added PDF files in the order their contents must follow in the final 
document by using the Up and Down buttons. 

3. For each document, you may specify a page range to import from that document by clicking the 
Page Range button. 

4. Set the position where all the selected documents and pages should be inserted: Before current 
page, After current page, Before first page, After last page. 
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5. The Import Bookmarks option transfers bookmarks associated with the imported pages too. If 
Create a bookmark with the name of imported document is enabled, a bookmark will be created 
with the same name as the imported document has. 

Click OK to import pages. Master PDF Editor will open the specified documents and import the given 
pages to the current document from them inserting them to the position you have set.

Deleting and Moving Pages

With Master PDF Editor you can remove or move one or multiple pages. To delete page(s), open Pages 
tab of Navigation Area. 
To delete one or more pages in a PDF document you can use one of two ways available in Master PDF 
Editor.

Delete pages using the menu

In the Document menu select Delete Pages or press Alt+Del (Alt+Fn+Del on macOS) on the keyboard. 
The following dialog appears:

Here, you can specify numbers of pages you want to delete from the PDF document. You can either 
specify page numbers in the Pages box or select a continuous range of pages by select the corresponding 
option. The default option is deleting the currently selected page.

When you click OK the specified pages will be removed from the document.
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Delete pages in the thumbnails panel

This visual method is convenient when you don’t know the exact numbers of pages you want to delete.

Click the Pages button  in the left side panel to open the Thumbnails panel.

Select pages you want to delete from the PDF document. To select multiple pages, you can hold Ctrl and 
click pages, or hold  Shift and select a range of pages by clicking the first one then the last one in that 
range.

Then, right-click the thumbnails and select Delete Pages.

This will bring up the same  Delete Pages dialog as described above with the pages range box already 
filled  in  according  to  your  selection.  Confirm  the  deletion  to  remove  the  selected  pages  from  the 
document.

 Please note that Delete Pages command can't be undone. Removed pages can't be restored. 
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Editing Page Layout and Cropping in PDF

Master PDF Editor allows creating documents that contain different page sizes by modifying page values 
or cropping pages. 

 Changing page size.
To change the layout of a page including its size and margins, click Document > Page Layout or press the 
Ctrl+Shift+L shortcut.
Set the values of the page size, contents size and identify the page range in the dialog box. 

In this window, you can see a preview of the page on the left and layout settings on the right. The values 
are represented in one of three available units: Points; Inches; Millimeters. 

The Unit drop-down box allows you to select a preferable unit.

 Page size (MediaBox).

This section sets the size of the page or the PDF media box.

• Page Size. Select one the standard page sizes. 
• Orientation. Portrait or Landscape. 
• Left and Right. Set the width of the page. 
• Top and Bottom. Set the height of the page.
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If you want to change the format of the page, modify these values.

 Content size (CropBox).

This section if enabled sets the margins of the page’s inner content. By default, margins are disabled and 
are zero. If you turn on Content size, you can specify non-zero margins to crop the contents of the page 
that don’t fit the margins. This is called the crop box in PDF documentation.

There is also a visual and handier way to crop a page or pages. It is described below.

When you have finished adjusting the layout of the page you can choose what pages it should apply to: the 
current page only, all pages of the PDF document or pages in a specified range. You can also make the 
program apply the settings to odd or even pages only, which is convenient when the layout is dependent 
on the position of a page on a two-page opening.

Click OK to apply the changes to the document.
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Cropping a PDF page

To crop a page, select Document > Crop Pages menu or press Ctrl+K.

A crosshair mouse cursor indicates that you should select a crop area now. 

Define a rectangular area on the page encompassing the content that you want to keep.

Once you define the area, the Page Layout window opens.
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Here you can precisely edit the crop region as well as the page size to contain it. 

In the Units drop-down you can select units to measure all the dimensions: points, inches or millimeters.

The  Page Range section allow you to apply the same cropping to multiple pages of the document: all 
pages, the current page only, even or odd pages only, or a specific page range.

When you finish, click the OK button to apply the cropping. All the specified pages will be cropped as you 
have set.

 When cropping pages, the only thing that changes is the contents size displaying in a document. The 
page size isn’t changed. You can place temporary objects in the document area that doesn’t display.

 Cropping pages doesn’t change the file size because the cropped data is hidden but not deleted. Thus, 
you can restore the origin page size and all the data, unchecking Contents Size. 
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Moving Pages

Moving pages within a document

To change the order pages follow in a PDF document, you can move them in the Thumbnails side panel.

To move one or more pages:

1. Click the Pages button to open the Thumbnails side panel. 
2. Select the page or pages you want to move to another place in the document. To select multiple 

pages: 

 Hold Ctrl and click pages you want to add to the selection 
 Or hold Shift, then click the first and the last page of a range. All pages in between will be 

selected. 

3. Start dragging the selected pages with the mouse, then drop them where you want these pages to 
be. Note that the blue indicator shows the place where the page or pages will be inserted. 

In this example we move page number 6 between pages 2 and 3.
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Moving pages between documents

If you run another copy of Master PDF Editor you can move pages between different documents using the 
same technique.

1. Open the documents you want to transfer pages between. 
2. Right-click a document tab, then click Move to New Window. 

This will open a second copy of Master PDF Editor and will open the document.

3. Open the Thumbnails panel as described above and select pages you want to move. To select 
multiple pages hold Ctrl or Shift as described above. 

4. Drag-and-drop pages from one window to another with your mouse. 

The same way you can drag and drop a PDF or an image file from any Windows Explorer window to 
Master PDF Editor to insert pages of that document to the currently opened PDF.
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Rotating a PDF Page

You can rotate  pages of  a  PDF document by 90 degrees clockwise or  counterclockwise and by 180  
degrees to get them upside down.

To rotate a page, click  Document >  Rotate Pages menu item or press  Ctrl+R. The following window 
displays:

Choose pages you want to rotate: 

 Page Range. Select pages you need to rotate.
 Direction. Select rotation direction. 

• Clockwise 90 degrees.
• 180 degrees.
• Counterclockwise 90 degrees.

Click OK to rotate the selected pages in the specified direction.
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Alternatively, you can open the Thumbnails section by clicking the Pages button  on the side panel, 
right-click the thumbnail of a page you want to rotate and select either rotation option.
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Selecting multiple pages for editing

You can select multiple pages via the Navigation Panel for further editing. Once selected, you can 
simultaneously delete, rotate, or extract these pages. For more details on all available options, refer to the 
Managing pages of PDF documents section.

To select a page, click the checkbox located in the top-left corner of its thumbnail. Repeat this step for 
each page you want to select.

To cancel your selection, click the empty space next to a page thumbnail in the Navigation Panel.

To hide check boxes on page thumbnails, uncheck the Show check boxes to select pages option in 
the program settings. To do this, go to the main menu Settings > Options, then to the Editing tab, make the 
change, and save the settings.
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Convert to Scanned Pages 

You can change the pages of your document so that they look like they were scanned. 

To add a scanned texture effect to your document, choose Document > Convert to Scanned Pages in the 
main menu. 

The following dialog window appears: 

These options are available:

 Skew.  Adds skew to  the  document  pages.  When the  checkbox is  selected,  the  Angle can be 
adjusted to change skew of the pages. 

 Add  White  Gaussian  Noise.  Adds  grain  effect  to  the  document  pages.  When  enabled,  the 
Strength can be adjusted to set the needed noise level. 

 Add contrast. Adds contrast to the document pages. When the checkbox is selected, the Contrast 
can be adjusted to change the contrast level.

 Add brightness.  Adds brightness to the document pages. Select the checkbox to set the needed 
Brightness level.

 DPI. Allows changing image resolution of the document pages. A lesser value of DPI decreases 
image quality of the page. 

It is also possible to reset all the parameter values back to the default  values if you press the  Defaults 
button. 
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Attachments

To add an attachment to the document, open the Attachment tab on the left panel.

Click the Insert icon  to add the files as attachments to the document. To delete the attachment, click 

the Delete icon  or press Del key.

 After the attachment is deleted, the command can not be undone.

To save the file, click the Save icon . The Open icon  opens all the selected files in Attachments. 
PDF documents will open in new tabs.

To select multiple files, hold Ctrl key and click them one by one.
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You can also edit the attachment by right-clicking the file. The context menu with the following 
commands will pop up:

 Insert (Ins). Add an attachment to the document.

 Rename. Rename the attachment.

 Delete (Del). Delete the attachment.

 Save as… Save a copy of the attachment in the specified folder (directory).

 Open. Open the attachment in the third-party software set as default in the system. PDF files will 
open in a new tab.

 Select all. Select all the attachments in the list.

 The commands Delete, Save as… and Open also allow editing multiple attachments if selected.
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Attaching a file as a comment

PDF document may include files of any format as attachments. Attached files are stored within document 
they are attached too. When moving document to another folder, all attached files are moved with it.

To attach a file as a comment to the PDF document, do the following:

1. Select the Hand Tool on the toolbar  or in the Tools menu (Alt+6). 

2. Click the Attach a File as a Comment button  on the toolbar. The mouse cursor will change to 
the crosshair. 

3. Click where you want to place the attachment in the document. 
4. Browse for a file you want to attach and open it. 

Master PDF Editor will load this file and attach it to the PDF document.
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You can adjust the text of the comment or bring up the Object Inspector window (Ctrl+F11) to adjust 
other parameters of the comment.

To open the attached document, double-click the attachment object in the working area. If the attached file 
is a PDF document, it is opened in Master PDF Editor in a new tab. Other documents are opened in their 
associated applications.
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Also, you can see all files attached to the PDF document in the Attachment section on the left panel:

Click an attachment in the list to open it in the working area or double-click to open it.
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Managing bookmarks

In Master PDF Editor, bookmarks are used to navigate to a specific location in the document. This is 
especially useful when creating a table of contents. A bookmark directs you to the page that was open or 
specified when the bookmark was created, which is referred to as the bookmark's destination. The 
destination also includes the current position on the page and the zoom level.

Additionally, bookmarks can be used to perform various actions, such as opening a file or a web link.

Adding bookmarks

To add a bookmark to a PDF document, press the Ctrl+B shortcut or click the Bookmarks tab  on the 
left side panel. 

It is possible to add a bookmark in the following ways:  

• Select Add Bookmark ;

• Right-click on an empty area of the panel and choose Add Bookmark.
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The Bookmark Properties window opens.

Enter the text of the bookmark in the Text field providing enough information about where it points to. 
Optionally, adjust the appearance of the bookmark in the Appearance section. 

When the Go to a Page View option is enabled, it sets a jump to the specified in the  Page Number field 
page. The Set current position option bookmarks the currently opened page and the current position on 
that page.  

The Go to a Page View option is enabled by default.

Click OK to create the bookmark.
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Adding a sub-bookmark  

Bookmarks  can  contain  other  bookmarks,  indicating  that  they  are  related.  Some are  main  or  parent  
bookmarks, while others are their sections or sub-bookmarks.  

You can add a sub-bookmark in several ways:  

 Right-click on the main bookmark and select Create Bookmark.  

 Click and hold the selected bookmark, then drag it onto the main bookmark.

Changing the position in the bookmark tree

Drag bookmarks within the bookmarks tree to modify their relative location.
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Deleting a bookmark

You can remove a bookmark in the following ways:  

 Select the bookmark and click Delete Bookmark .  

 Right-click on the bookmark and choose Delete Bookmark.

To delete multiple bookmarks:

 Hold Ctrl and click bookmarks you want to select one by one.
 Or hold Shift and click the first and the last bookmarks to select all bookmarks in between. 

Then right-click and click Delete Bookmark to delete all selected bookmarks.

 Please note, bookmark removal cannot be undone. 

Editing a bookmark

To edit a bookmark, right-click it and select Bookmark Properties.

If you want to assign a different page view to a bookmark, follow these steps:  

1. In the document area, navigate to the location you want to set as the new destination.  

2. If needed, adjust the zoom on the page.  

3. Right-click the bookmark in the bookmark list and select Set Destination.

Set Destination sets the bookmark's destination in the document, including the page number, location on 
the page, and the current zoom level.  

You can only modify the destination of a single bookmark. 

It should be noted that you can only modify the destination for a bookmark that has the "Go To a 
Page View" action.
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Select Set Zoom to adjust the zoom for a single bookmark.  

This will open the Set Zoom for Bookmark window. 

In the Set Zoom for Bookmark window, you can set zoom level for the selected bookmark within the 
page to which it refers. When you modify the zoom, both your position on the page and the page itself 
remain unchanged.  

The zoom adjustment options include:  

 Current Zoom. Sets the current zoom level displayed on the page.  

 Disable Zoom. Removes any set zoom settings. When zoom is disabled, the Zoom Mode is set to  
Custom, and the Zoom is set to Auto.

If you want the bookmark to preserve the current zoom level of the document without restoring it back to 
the saved one, you should edit the bookmark as follows:

1. Right-click the bookmark and click Bookmark Properties. 
2. Switch to the Action tab. 
3. Select Go to a Page View action in the list and click Edit. 
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4. Master PDF Editor will ask whether you want to set the current position. Click Custom. This will 
bring up the following dialog: 

5. Select Custom in the Zoom Mode dropdown box and set Zoom to “0” (“auto”). Click OK. 

Read more about setting actions to a bookmark below.

Advanced bookmark capabilities

With bookmarks you can navigate not only across the document, but also open external web links, execute 
files, open other documents and even execute JavaScript.

For example, here is how you can make a bookmark open a URL.
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1. Right-click the bookmark list to add a bookmark. 
2. In the Bookmark Properties window switch to the Actions tab. 

3. Select the action you want to perform when the bookmark is clicked. In our case we want to open a 
link, so select Open a web link item. Click Add.

Insert URL and press OK to add a bookmark. 

Now, when this bookmark is clicked, the following dialog appears:

 You can assign multiple actions to the same bookmark. In this case all of the actions are executed 
starting from the first one.

The following actions are available:

 Go to a Page View. The default action that navigates to a specified place in the document. 
 Open/execute a File. This action opens a specified file or runs an executable. 
 Open a web link. The action allows you to open any URL in the default browser. 
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 Reset form. Select fields of a PDF form or forms to reset. The contents of these fields will be 
removed. 

 Show/Hide fields. You can select which fields of a form or forms should be visible. When this 
action executes, the selected fields will turn their visibility as specified. 

 Submit a form. This action allows you to initiate submitting of the selected fields of a form using 
one of available formats and submission methods. 

 Run a JavaScript. Selecting this action, the JavaScript editor opens where you can compose a 
script that will be executed when this action is activated. This allows you to perform conditional 
formatting, calculate field values, validate information entered to a form, and so on.
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Since you can assign multiple actions to a bookmark, you can first execute a JavaScript to validate form 
contents, then run the Submit a form action to submit it.

Managing layers

Layers  are  used in  PDF documents  to  configure  the  visibility  of  content  when viewing,  printing,  or 
exporting. 

Creating a new layer

Only an object added to a layer can have its visibility configured. First you need to add a new layer if the  
document doesn't already have any layers.  

To add a new layer to a PDF document, do the following:

1. Click the Layers tab  on the left side panel.

2. Press the Create new layer button .

3. Insert the layer name in the dialog box.
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A new layer will be added to the layer list.

The Layers panel provides additional options to manage a layer after it is created:

 To rename the layer, double-click the layer with the left mouse button. 

 To sort layers in alphabetical order, click the Sort layers by alphabet button .
 To order layers, you can nest multiple layers into one. To nest layers, press and hold the child layer 

with the left mouse button and drag it onto the parent layer on the tab. To split layers, press and 
hold the child layer with the left mouse button and drag it to the blank area of the tab.
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Adding an object to the layer

In Master PDF Editor, you can add an object to a layer in one of several ways:

Using the main menu

 Select the object with the Edit Document tool on the document page. 
 Select Set layer to selected objects in the Edit tab from the main menu.
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Using the context menu

 Select the object with the Edit Document tool on the document page. 
 Right-click the object. 
 Select Set layer to objects in the context menu.

Using the Object Inspector

 Select the object with the Edit Document tool on the document page. 
 Open the Layer tab in the Object Inspector.
 Select the needed layer from the Layer drop-down menu.
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Using the default layer option

 Select the needed layer in the drop-down list Default layer on the Layers tab.
 Create a new object.

The object will automatically be added to the default layer.

You can select several objects for adding them to the layer. Select the Edit Document tool and do one 
of the following:

 Press and hold the Ctrl button and select the objects.
 Hold the mouse button and move the mouse to define a rectangular selection area as shown below. 

All the objects intersecting with this rectangle will be selected.
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Configuring layer visibility

On the Layers tab, you can find the following settings to configure layer visibility:

 Show all . Shows all layers.

 Hide all . Hides all layers.
 Show a layer. Shows a specific layer when check is in the box next to the layer name.
 Hide a layer. Hides a specific layer when there is an empty box next to the layer name.

 Reset layers to default visibility . Resets layer visibility to the state specified in the 
document's default visibility settings.

Layer visibility by default

The Layer Visibility by default parameter allows configuring layer visibility in Master PDF Editor for the 
newly  opened  documents.  The  parameter  takes  priority  over  the  visibility  settings  configured  in  the 
document.

 Use configuration in document. When a document is opened, layers are displayed as they were 
previously saved in the settings for default visibility in the document. 

 Show all layers. Shows all layers when opening a document.
 Hide all layers. Hides all layers when opening a document.

To make this parameter work properly, remove the check mark next to the option Restore last view 
settings when reopening. To disable the option, select the Settings from the Tools main menu, then select 
the General tab.
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Default visibility in a specific document 

To configure layer visibility in a specific document, use the following settings on the  Layers tab in the 
drop-down menu Set visibility.

 Set current state of visibility as default. Saves the current state of layer visibility as default in the 
document.

 Set all layers as visible by default. Saves layers as visible by default in the document.
 Set all layers as invisible by default. Saves layers as invisible by default in the document.

These parameters save the selected layer visibility for a specific document,  regardless of the the 
software settings used to view the document.
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Layer visibility when opening a document

To configure layer visibility when opening a document for the first time, right-click the layer name on the  
Layers tab. Then, select one of the following options from the drop-down menu:

 Always initially visible in document. Always shows the layer when opening a document for the 
first time.

 Always initially invisible in document. Always hides the layer when opening a document for the 
first time.

 Visible by default. Layer visibility depends on the tick next to the layer name.
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Exporting layers

To configure layer visibility when exporting a document to an image, right-click the layer name on the 
Layers tab. In the drop-down menu, select one of the following visibility options:

 Always visible on export. Shows the layer when exporting the document to an image.
 Always invisible on export. Hides the layer when exporting the document to an image.
 Export as configured. Layer visibility depends on the tick next to the layer name.
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Printing layers

To configure layer visibility when printing a document,  right-click the layer name on the  Layers tab. 
Then, select one of the following options from the drop-down menu:

 Always visible on print. Shows the layer when printing the document.
 Always invisible on print. Hides the layer when printing the document.
 Print as configured. Layer visibility depends on the tick next to the layer name.

To select multiple layers for the same settings when exporting a document to an image or printing it:

 Press and hold the Ctrl button, then click on the layers with the left mouse button on the Layers 
tab.

 Or click on the first layer, press the Shift and hold it. Click on the last and release the Shift to 
select all layers in between.

Deleting layers

To delete layers, use the following settings on the Layers tab:

 Delete all. Deletes all layers in the document.
 Delete selected. Deletes the selected layers.
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Editing Objects in the PDF Document

Every PDF documents consists of PDF objects: images, text boxes, forms, vector objects. Editing a PDF 
document  basically means editing properties of those objects. Despite being quite different in essence,  
PDF objects share many properties that can be edited the same way.

Master PDF Editor provides a range of tools for effortless editing of PDF objects.

Selecting PDF objects

To select an object in the PDF document, click the Edit document  toolbar button, click the Tools > 
Edit document menu or  press  Alt+1 on the keyboard.  Then click an object  in  the work area of  the 
document.

Selecting images, forms and text objects

While the  Edit document tool   allows you selecting any objects in the document, there are also a 
number of tools to select specific types of objects:

 Edit Text Objects tool allows you to select text objects. You can also select this tool in the 
Tools > Edit text menu or by pressing Alt+2. 

 Edit Forms  tool is for selecting PDF forms (Alt+3). 

 Edit Images  tool allows you to select images (Alt+4).

 Edit Vector Images  tool is for selecting vector images only (Alt+5). 
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Selecting multiple objects

To select several objects at once, use one of the following ways:

 Hold Ctrl and click objects you want to select.
 Hold the mouse button and move the mouse to define a rectangle as shown below. All objects 

intersecting with this selection rectangle will be selected. 

Moving objects

With mouse

To move an object, select it, then hold the left mouse button and move the object to a new place.

With keyboard

To move an object using keyboard, select the object and press arrow keys on the keyboard. With each 
press of an arrow key the object moves by 5 pixels in the corresponding direction. Hold  Ctrl for more 
precise movement by 1 pixel each press.
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Using Object Inspector

You can specify the exact coordinates to place the object at. To do this, select an object you want to edit, 
then  click  the  Object  Inspector button  in  the  right  side  (or  press  Ctrl+F11)  to  display  the  Object 
Inspector. Open the Geometry section. Specify the coordinates of the object in the Left and Top boxes.

Maximum value that can be set: 10000 pt, 138.889 inches, or 3571.429 mm. 

       Minimum value that can be set: -10000 pt, -138.889 inches, or -3571.429 mm.

The coordinates in the Left and Top boxes can also be specified with a numerical expression. The result 
of an expression is used as the coordinates.

Supported mathematical operators:

Operator Description

+ Adds numbers.

- Subtracts numbers.

/ Divides numbers.

* Multiplies numbers.
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Parentheses can be used as mathematical notation within a numerical expression:

 Character  Description

 ( )

This character is used to define the order of carrying out 
operations when performing calculations.  
Example: (189.55+34.00)*2 pt 
As a result of this expression, 447.10 pt will be populated 
in the calculated field.  

 You can only move objects within the same page of the PDF document. If you need to move the 
object to another page, use the Cut/Paste operation (see below).

Snapping to the grid

You can move objects across the page and keep them snapped to the grid.  This simplifies arranging 
objects on the page and keeping them aligned with each other.

To enable snapping to the grid, choose the  View >  Snap to Grid menu item or press  Ctrl+Shift+U. To 
display the grid, choose View > Grid or press Ctrl+U.

You can configure grid parameters in the Tools > Settings menu, the Grid section.
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Cutting, copying, and pasting objects

To copy an object to the clipboard, select it and use the Edit > Copy menu command or click the Copy 

toolbar button  or press Ctrl+C.

To cut and object – that is, copy it to the clipboard and then delete from its original location – select the  

object and use the Edit > Cut menu command or click the Cut toolbar button  or press Ctrl+X.

To paste an object from the clipboard to its new place, use the Edit > Paste menu command or click the 

Paste toolbar button  or press Ctrl+V.

The same commands are also available in the context menu:
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Pasting to multiple pages

You can insert the object in the clipboard to multiple pages in one action. To do this, click the  Edit > 
Paste to Multiple Pages menu item or press Ctrl+Shift+V. The following window appears:

Choose where you want this object to paste and click OK. This function is helpful when you need to paste 
the same header all over the document or add some information block to every page.

Resizing objects

With mouse

Select the object you want to resize. Drag a handle to resize the corresponding side or corner of the object 
box.

 Hold Shift while dragging to maintain the aspect ratio of the object.
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Using Object Inspector

Select the object you want to resize. Then bring up the Object Inspector by clicking its button in the right 
side panel or by pressing Ctrl+F11. Open the Geometry section. Then, enter the exact Width and Height 
of the object to the corresponding boxes.

Maximum value that can be set: 10000 pt, 138.889 inches, 3571.429 mm. 

Minimum value that can be set: 2.50 pt, 0.035 inches, 0.893 mm.

You can also resize the object in the Width and Height boxes using a numerical expression. Find more 
information about mathematical operators below.

Supported mathematical operators:

Operator Description

+ Adds numbers.

- Subtracts numbers.

/ Divides numbers.

* Multiplies numbers.
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Parentheses can be used as mathematical notation within a numerical expression:

 Character  Description

 ( )

This character is used to define the order of carrying out 
operations when performing calculations.  
Example: (189.55+34.00)*2 pt 
As a result of this expression, 447.10 pt will be populated 
in the calculated field.  

Turn on the Maintain aspect ratio option to keep the aspect ratio of the resized object.

 The clipping path is not resized along with the object. You will need to remove the clipping path by 
clicking  the  Remove button  in  the Clipping Path section  of  the  Object  Inspector.  Read  more  about 
clipping paths here.

You can also resize an object to make it fit the page entirely. Select an object, then right-click it and 
choose Set Fit to Page item in the context menu.

 Fit to page does not work for formatted text objects, forms and comments.
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Rotating objects

Objects can be rotated either by specifying the rotation angle value in the Object Inspector or with the 
Rotation handle.

Rotating objects using the Object Inspector

To rotate objects, first select them and open the Object Inspector (Ctrl+F11). 

Navigate to the Geometry section, then input the desired rotation angle into the Rotate field and press 
Enter.
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Rotating objects with the Rotation handle

Select an object using the Edit Document  tool or another appropriate tool. Once the object is selected, 

a Rotation handle  will appear above it.

When multiple objects are selected, the Rotation handle will appear at the top of the object you 
clicked on last.

Hold the Rotation handle to rotate the object. Drag the Rotation handle left or right to adjust the rotation 
of the objects. As you rotate, the degree of rotation will be displayed.

Copyright © 2026 Code Industry Ltd



Hold the  Shift key while rotating to lock the rotation to angles that are multiples of 45 degrees,  
ensuring a precise result.

 The clipping path is not rotated along with the object. You will need to remove the clipping path by  
clicking the  Remove button in  the  Clipping Path section of  the  Object Inspector.  Read more  about 
clipping paths here. 
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Aligning objects

To align one or more objects, you need to select them first. Then, apply one of Align commands using 

either the Edit > Align Objects menu or the Align toolbar buttons: align by left edge , by right edge 

, by top edge , by bottom edge  or center align vertically  or horizontally .

If one object is selected, it is aligned by the edge of the page:

If multiple objects are selected, all selected objects are aligned by the edge of the active object (the one 
with handles):
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If multiple objects are selected, all selected objects are aligned by the edge of the active object (the one 
with handles):

Using Object Inspector to align objects

Select multiple objects as described in the Selection section above. Make sure there is an active object in 
the selection. Normally, when you select objects while holding Ctrl the last clicked object remains active.

Then, in the Object Inspector panel you can adjust the position and alignment of the selected objects.

Let’s say you want to align all the selected objects by the left edge of the page and put them 40 points  
away from the edge. Here is what you should do:

1. Select objects 
2. Bring up the Object Inspector by clicking its button in the right panel or pressing Ctrl+F11. 
3. Set the Left parameter to 40, the Coordinates option to Absolute and the Units drop-down to 

Points. 
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If you need to align these objects by the top edge, do the following:

 Switch the Coordinates to Relative.
 Enter the Top.

All the selected objects will be aligned by the top edge of the page, and the distance between objects will 
remain the same.

Changing Z-order of objects

Z-order defines the order in which intersecting objects on the page appear. Objects with higher Z-order 
overlap objects with lower Z-order.

The following commands allow you to modify Z-order of the selected object(s):

 Send to Back.  Sends the selected object back on the page. It will appear as lying below any 
other objects overlapping with it. 

 Bring to Front.  Makes the selected object the topmost on the page. It will appear as lying on 
top of any other objects overlapping with it. 

 Send Backward.  Send the selected object backward by one position. The selected object 
exchanges Z-order positions with the object lying right below it. 

 Bring Forward.  Bring the selected object forward by one position. The selected object 
exchanges Z-order positions with the object lying right above it. 

To change the Z-order, use the Edit menu or the corresponding buttons on the toolbar.
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Deleting objects

To delete one or more objects, select them and do one of the following:

 Press Del on the keyboard.
 Right-click and select the Delete command in the context menu.
 Use the Edit > Delete menu command.

 Click the Delete Object  button on the toolbar.

Undo and Redo operations

To undo the last operation, do one of the following:

• Click the Undo  toolbar button.
• Choose the Edit > Undo menu command.
• Press Ctrl+Z.

To redo the last undone operation, do one of the following:

• Click the Redo  toolbar button. 
• Choose the Edit > Redo menu command. 
• Press Ctrl+Y.

 You can undo only operations with objects (i.e. texts, forms, images, annotations). Operations over 
pages such as: moving a page, rotating a page or removing a bookmark cannot be undone.
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Editing Text in PDF Documents

The PDF format supports two types of text objects: simple text objects and formatted text objects. For the 
latter one, please refer to the section Editing formatted text in PDF documents.

Inserting text to the PDF document

To insert a text object to the page, click the Insert Text  button on the toolbar or use the Objects > Text 
menu or press Ctrl+T, then click a place on the page where you want this text object to be and type the 
text. Click anywhere outside the edit box or press Esc to finish editing.

Editing text

To edit a text in the PDF document, select the text object using the Edit Document  tool or the Edit 

Text  tool. Then double-click the text object you want to modify.
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Changing styles of the text

You can change the font name, font size, color and style of the text in the Object Inspector panel. Bring 
up the Object Inspector by clicking its button on the right side panel or by pressing Ctrl+F11.

Open the Font section:

Here you can select font size and family, specify font type and color, and adjust character and word 
spacing and line height.

Moving and resizing the text

Just like any other PDF object, a text object can be resized and moved to another place. You can read how 
to move and resize objects in this section.

 Rotating the text.

There are three ways to rotate a text:

• Specify the rotation angle in the Object Inspector which is described in this section.

• Use the Rotation handle . 
• Use the transformation matrix 

 Aligning the text object on the page.

You can align a text object using the Align command on the toolbar or in the Edit menu. Please read more 
about aligning objects in this section.

 Do not confuse aligning a text object on the page with aligning text within a formatted text object.
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Copying and pasting text

Copying from

If you want to copy text from some text objects to paste it to another application or another object, follow 
these steps:

1. Choose the Select Text  tool on the toolbar or in the Tools menu (Alt+7). The mouse cursor 
will be changed to a crosshair. 

2. Hold the mouse button and drag the selection rectangle over the text you want to select 
3. Right-click and select Copy in the context menu or press Ctrl+C. 
4. Then, you can paste this text wherever you want. 

 This will only copy text, not the text objects themselves. Copying and pasting objects is described 
here.
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Pasting to

If you want to paste a text copied from another source to a PDF page, you should insert a text object or a  
formatted text object in the document and then paste the text from the clipboard to the edit box.

Here, the previously copied text is pasted to a new PDF document.

Editing Formatted Text in PDF Documents

The PDF format supports two types of text objects: simple text objects and formatted text objects. For the 
former one, please refer to this section.

Unlike simple text, formatted text can use formatting, styles and alignment.
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Inserting formatted text to the PDF document

To insert a formatted text object to the page, click the Insert Formatted Text  button on the toolbar or 
use the Objects > Formatted Text menu or press Ctrl+T, then click a place on the page where you want 
this text object to be and type the text. Click anywhere outside the edit box or press Esc to finish editing.

Editing formatted text

To edit a formatted text in the PDF document, select the formatted text object using the Edit Document 

 tool or the Edit Text  tool. Then double-click the formatted text object you want to modify.

Changing formatting

To change formatting of the formatted text, bring up the Object Inspector panel using the corresponding 
button in the right-side panel or press  Ctrl+F11.  Then, initiate editing of the formatted text object as 
described above. You should see the Format section then:
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Now you can edit the text of the object. For instance, you can change font style, color or family of selected 
parts of the text, and align text lines using the Align Left, Align Center and Align Right buttons.

Moving and resizing the formatted text

A formatted text object can be moved to another place just like any other PDF object. You can read how 
to move objects in this section. You cannot directly resize the formatted text object, because the size of the 
object depends on the text content.

Rotating the formatted text

There are three ways to rotate a formatted text:

 Specify the rotation angle in the Object Inspector which is described in this section  .  

 Use the Rotation handle . 
 Use the transformation matrix  .  

Aligning the formatted text object on the page

You can align a formatted text object using the Align command on the toolbar or in the Edit menu. Please 
read more about aligning objects in this section.

Aligning the formatted text object on the page does not change the alignment of its text content:

Center align of the formatted text

Right align of the formatted text
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Copying and pasting formatted text

Copying from

If you want to copy text from some text objects to paste it to another application or another object, follow 
these steps:

1. Choose the Select Text  tool on the toolbar or in the Tools menu (Alt+7). The mouse cursor 
will change to a crosshair. 

2. Hold the mouse button and drag the selection rectangle over the text you want to select 
3. Right-click and select Copy in the context menu or press Ctrl+C. 
4. Then, you can paste this text wherever you want. 

 This will only copy text, not its formatting or the formatted text objects themselves. Copying and 
pasting objects is described here.

Pasting to

If you want to paste a text copied from another source to a PDF page, you should insert a text object or a 
formatted text object in the document and then paste the text from the clipboard to the edit box.

Editing Images

To edit an image in the PDF document, select it using the Edit Document  tool or the Edit Image  
tool. Then click the image object you want to modify.

Inserting images to the PDF document

To insert a new image to the document, click the Insert Image  button on the toolbar or use the Edit > 
Insert Image menu command or press Ctrl+I.

The mouse cursor will change to the crosshair. Click where you want to place the image. The Open Image 
window will show. Browse for an image you want to insert and open it.
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Master PDF Editor supports the following image formats: SVG, TIFF, JPEG, BMP, PNG and PPM.

Moving and resizing

An image object can be moved and resized just like any other PDF object. Please refer to this section to 
learn how to move and resize objects.

Resizing an image does not accordingly resize its clipping path which may result in the resized image 
looking like this:

To make it fill the entire area, you need to remove the clipping path. Open the Object Inspector panel by 
clicking its button in the right-side panel or pressing Ctrl+F11. Open the Clipping Path section and click 
the Remove button.

Copyright © 2026 Code Industry Ltd



Rotating images

To rotate an image on the page, select it and specify the rotation angle in the Object Inspector panel 

or use the Rotation handle  as described in the Rotating objects section.

Rotating an image does not accordingly resize its clipping path, so you may end up with the rotated image  
not fitting the clipping path as shown below:

To fix this, remove the clipping path in the Clipping Path section of Object Inspector.

External editing

You can edit an image in a third-party application by right-clicking it and selecting Edit Image item in the 
context menu. This will launch the associated application and the image will be opened for editing there.
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You can also save image to a file to open that file later in some other application. Right-click the image 
and select Save Image to File menu item.

Vector Images

Vector images are graphical pictures of geometric shapes like dots, lines, rectangles, circles, ellipses and  
curves. Vector images need much less space to be stored then raster images.

Creating Vector Images

Tools for vector images creation are listed below.

Button Function Description

Line
Draw a straight line of any length.

Rectangle
Use to draw rectangles and squares of any size.

Ellipse
Draw ellipses and circles of different sizes.

Pencil
Allows to draw custom lines and curves.
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To draw a vector image, choose the corresponding tool in the Insert menu or press the required button on 
the toolbar. Left click a spot in the workspace to set coordinates for the first object node and drag the  
cursor in the required direction and distance while holding the left mouse button.

Copying and Pasting Vector Images

Vector images are copied and pasted in Master PDF Editor same way as any other objects in Master PDF 
Editor.

To copy a vector image choose the Edit Document  tool. Select the required vector image with left 
click and choose the Copy (Ctrl+C) item in the Edit menu or right-click the image and choose the Copy 
command in the context menu. The copied vector image will be stored in the clipboard. It later can be 
pasted into this or any other Master PDF Editor document.

To paste a vector image into Master PDF Editor choose the Paste (Ctrl+V) item in the Edit menu or press 

the  Paste  button on the toolbar. You can also right-click the document page and choose the same 
command in the context menu. If you paste the vector image onto the current page, it will be initially  
located above the original image copied to the clipboard. If you paste vector image on another page (or  
another Master PDF Editor document), it will have same coordinates as the original one. You can move 
the image then to any new location.

The copied vector image can also be pasted to all document pages or specified pages range. To do it, use 
the Edit menu and choose Paste to Multiple Pages.

 A vector image can only be pasted into Master PDF Editor. It can’t be pasted into a document of any 
other application.

Modifying Vector Images

To align vector  images,  choose the required alignment in the  Edit >  Align Objects menu out  of  the 
available options:  align by left edge, right edge, top or  bottom edge. Otherwise you can press required 

button on the toolbar:   Align Left,   Align Right,   Align Top,   Align Bottom, Align Center  

Vertically , Align Center Horizontally .

Example: You need to align several vector images by top edge.

Enter edit mode by clicking the  Edit Document or  Edit Vector Images button on the toolbar (or 
choose one of these items in the Tools menu). Select the required vector images. Alignment works by the 
top edge of the last selected (active) vector image. Object Inspector will display parameters for the active 
vector image. If you selected a group of vector images at once, there won’t be an active vector image, and  
the selected ones will be aligned by the top edge of the page.

When modifying vector images, 4 tabs are available in Object Inspector: Geometry, Style, Matrix and 
Clipping Path.
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Geometry tab

Geometry tab displays settings for active vector image. If a group of vector images was selected with 
selection box, there won’t be an active vector image and Object Inspector won’t display settings.

 Width and height. These items of Geometry tab allow to specify size of vector image. To do it, 
select required image and specify the data in corresponding items. 

 Left. Distance from left page border to the left border of the vector image. 
 Top. Distance from top page border to the top border of the vector image. 
 Coordinates. Sets offset when aligning vector images with settings in left and top items. 

Coordinates can be absolute or relative. 
• Relative. When aligning forms using top and/or left items distance between vector images 

remains same. 
• Absolute. When aligning all vector images will be moved irregularly and will be positioned 

in coordinate point set in top and/or left items. 
 Maintain aspect ratio. If enabled, vector image’s aspect ratio isn’t changed when its height and 

width are being modified. 
 Rotate. Allows to rotate vector image. 

 Units. Select a unite for object measuring. 

 Please note, that clipping path (if current vector image has one) won’t be rotated. It should be 
removed. To do it, go to Clipping Path tab of Object Inspector and click Remove button.
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Style tab

 Type. Vector image type. Options: fill, stroke, fill and stroke. (It is not always possible to set this 
item. Some images have only one type – stroke.) 

Depending on chosen image type, fill and stroke parameters can be set:

 Fill. Vector image fill. 
• Color. Color of vector image fill. To choose custom color, press More… item in the end of 

the list. 
• Opacity. Opacity of fill in percents. 

 Stroke. Vector image stroke. 
• Color. Color of vector image stroke line. To choose custom color, press More… item in the 

end of the list. 
• Opacity. Opacity of stroke in percents. 
• Line Width. Thickness of stroke line. Can be set with 1 pixel step. 
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Matrix tab

Transformation matrix serves for vector images transformation. More detailed information can be found in 
Transformation Matrix

Clipping Path tab
Information about this tab can be found in Clipping Path. 

When creating new vector image, options of last changed vector image will be used.
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Editing vector image anchor points

After inserting a vector image to the page, you can edit its anchor points to adjust the shape to something 
more suitable for you.

To do this, select the  Edit Document or  Edit Vector Images button on the toolbar and double-
click the vector image. This will turn on the anchor point editing mode. Use the mouse to drag points how 
you feel appropriate. When you are done, press Esc.

Clipping Path

Clipping path is vector image containing an object inside. Current version allows only to remove it. To do  
this, press Remove button in Clipping Path tab in Object Inspector.

Next versions will introduce clipping path editing features.

Transformation Matrix

Transformation matrix is used to calculate new coordinates of transformed object. By changing values of 
transformation matrix, it is possible to apply any transformations to objects (scaling, mirroring, rotating, 
moving etc). Any transformation preserves parallel lines. 

Coordinates in PDF are described in 2-dimensional space. Point (x,y) in 2-d space can be described as [x y 
1] in vector form. Constant third member of the vector (1) is required for simplicity of calculations with  
3x3 matrices, described below.

Copyright © 2026 Code Industry Ltd



Transformation between two coordinate systems is described as 3x3 matrix. In matrix form it looks as 
following:

Coordinate transformations are written as cross product:

Since last row doesn't effect calculations result, it is omitted. Transformation coordinates are calculated as 
follows:

Identity matrix

Identity matrix is one which has a and d values equal to 1 and others equal to 0. This matrix is applied by 
default since it doesn't lead to any transformation. This is why it is base for further transformations.

 Scaling. To increase object's horizontal or vertical size value a or d respectively must be changed,  
other values must stay as in identity matrix. 
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Example:  To increase object's horizontal size, a value must equal to 2 and other values must stay as in 
identity matrix.

Calculating new object's coordinates:

 Mirroring.  To get  horizontal  mirroring,  it  is  required  to  set   a =  -1,  or  d =  -1  for  vertical 
mirroring. It is possible to change both a and d to get both horizontal and vertical mirroring.
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 Skew. To vertically or horizontally skew object value b or c respectively must be changed. b/-b is 
skew up/down, c/-c does left/right skew.

Example: To vertical skew object set b = 1.

Calculating new object’s coordinates:

As a result, object is skewed by y coordinate only, which is increased by x.

 Rotate. Rotate is a combination of scale and skew, but in order to maintain initial object’s aspect  
ratio, transformation must be exactly calculated with the use of sin and cos.

Object is rotated counter-clockwise,  α sets rotation angle in rad.

 Moving. Moving is preformed by changing following values: e (for horizontal) and f (for vertical). 
Values are measured in pixels.
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Matrix is rarely directly used for movement, because this operation can be done with other methods, for 
example, dragging object with mouse in the workspace.

Since transformation matrix has just 6 elements available for modification, it is visually displayed in PDF 
as  [a b c d e f].  Such matrix can represent any linear transformation from one coordinate system to 
another. Transformation matrices are formed following way:

 Movements  are  represented  as [1  0  0  1  tx ty],  где  tx и  ty — distances  from coordinate  axis 
horizontally and vertically correspondingly.

 Scaling is represented as  [sx 0 0 sy 0 0]. This scales coordinates so that 1 unit in horizontal and 
vertical measurements in new coordinate system equals sx and sy units in old coordinate systems 
correspondingly. 

 Rotations are preformed with matrix [cosθ sinθ −sinθ cosθ 0 0], which matches counter clockwise 
rotation of all coordinate system by θ rad.

 Skew is represented as [1 tanα tanβ 1 0 0], which matches skew of x axis by α angle and axis y by 
β.

Image below shows transformation samples. Move direction, rotation and skew angles shown on image 
correspond to positive matrix values.

Matrix multiplications are not commutative, so it makes difference in which order you multiply 
matrices.
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Table below lists possible transformations and corresponding matrix values.

Original picture Transformed picture Matrix Description

1       0
0       2
0       0

Vertical scale. If changed value > 1, object is 
stretched, otherwise narrowed.

2       0
0       1
0       0

Horizontal scale. If changed value > 1, object is 
stretched, otherwise shrinks.

-1      0
0       1
0       0

Horizontal mirroring.

1       0
0      -1
0       0

Vertical mirroring.

1       1
0       1
0       0

Vertical skew up.

1      -1
0       1
0       0

Vertical skew down.

1       0
1       1
0       0

Horizontal skew right.

1       0
-1      1
0       0

Horizontal skew left.

1       0
0       1
0       1

Moving up in pixels.

1       0
0       1
0      -1

Moving down in pixels.

1       0
0       1
1       0

Moving right in pixels.

1       0
0       1
-1      0

Moving left in pixels.

Nevertheless, the transformation matrix is very easy and effective to use for transformation. There’s no 
point is applying it for rotation, for example, since the Rotate function on the Geometry tab can be used. 
However, it’s essential for object mirroring. 
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Commenting PDF Files

Commenting allows you to review a PDF document and add your annotations, comments and other text 
and graphical information regarding its content. Comments may address certain parts of the document that  
require changes, or be used as a part of collaborative work on the document to tell other authors your 
thoughts and opinions. Commenting tools do not alter the original content of the PDF document, and 
comments are not displayed in the printed document.

In Master PDF Editor you have a number of commenting tools:

 Sticky notes  .
 Attach a file as a comment  .
 Highlight, strikeout or underline text  .
 Drawing tools  .
 Measurement tools  .
 Typewriter  .
 Callout  . 
 Stamps  .

You can also view comments and export and import them.
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Sticky Notes

Sticky notes are comments displayed over the original content of the document. You can use them to  
suggest changes in the PDF document, ask clarifying questions to the author of the document or if you’re 
the author explain or comment your content to collaborators.

Adding a sticky note

To add a sticky note to the document, click the Add Sticky Note button  on the toolbar, use the 
Comments > Add Sticky Note menu command or press Ctrl+6.

The mouse cursor changes to the crosshair. Click in the work area of the program where you want to add a 
sticky note to.

Then, type the text of this sticky note. You can do this directly in the balloon window, or use the right-side 
Object Inspector panel.
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Now, when a user points to the sticky note symbol in the document, a tooltip containing your comment 
appears:

The Object Inspector panel allows you to adjust how the sticky note looks. You can change the following 
settings:

 Author. Set the author of this comment.
 Subject. A brief title of the note.
 Text. A comment to some specific fragment or element of the PDF file.
 Type. Choose the type of the icon displayed. Using different icons for different types of comments 

simplifies reviewing and makes it easier for the author to understand your annotations. 

 Color. Set the color of the sticky note icon.
 Opacity. Set the opacity level of the sticky note icon. 
 Status. This allows you and your collaborators to track the status of the comment. You can choose 

one of four statuses and switch between them: 
• Accepted. Means the sticky note is accepted and the suggested changes will possibly be 

made by the author.
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• Canceled. Means the sticky note is not actual anymore for some reason.
• Completed. Means the issues this sticky note addresses is fixed.
• Rejected. Means the suggested changes were rejected or the issue the sticky note addresses 

cannot be fixed.
 Locked. Means the sticky note can only changed by its author. 

Editing a sticky note

To modify a sticky note, follow these steps:

1. Switch to the Hand tool mode using the Hand tool button  on the toolbar or the Tools > Hand 
Tool menu or by pressing Alt+6. 

2. Bring up the Object Inspector panel by clicking its button in the right panel or by pressing 
Ctrl+F11. 

3. Click the sticky note you want to edit. 

This will display the parameters of the selected sticky note in the  Object Inspector, so you could edit 
them.

To adjust the balloon tooltip, double-click the sticky note.

Here, you can quickly modify the text of the comment, or move the balloon tooltip to another place by 
dragging it with the mouse. To resize the balloon, drag the bottom right corner of the tooltip.

The Options link allows you to quickly manage the status of the sticky note, reply to it or delete it.
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You can also right-click the sticky note icon to bring up the same menu.

Deleting a sticky note

To delete a sticky note, select the Hand Tool  as described in the beginning of this text, then do one of 
the following:

 Right-click the sticky note and select Delete in the context menu.
 Click the sticky note, then press Del on the keyboard. 
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Highlight, strikeout or underline text

These  tools  allow you  to  make  corrections  to  the  PDF document  such  as  striking  out  wrong  parts,  
highlighting  important  parts  or  underlining  parts  you  want  to  emphasize.  Unlike  text  editing  tools,  
commenting tools do not alter the actual content of the document. So, for example, stricken out text looks 
like that only for the purposes of reviewing.

Highlighting the text

To highlight the text, click the Highlight Text button  on the toolbar, or select the tool using the 
down arrow:

Then, select the text you want to highlight:

This will make the selected text highlighted.
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Strikeout the text 

Click the Strikeout Text button  on the toolbar, or select the tool using the down arrow to strikeout 
some text in the PDF document.

Next, select the text you need to strikeout. Then, the selected text will be strikeout.

Underlining the text

To underline some text in the document, either click the Underline Text toolbar button  or select it 
from the drop-down menu. 

Select the text you want to underline after that. The selected text will get underlined as a result.
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Editing highlighted, underlined or strikeout text properties

Select  the  Hand Tool using the corresponding toolbar button   or  the  Tools menu (Alt+6)  to edit 
properties of the highlighted, underlined or strikeout text, s. Then, click the text you want to modify.

Specifically, you can adjust color and opacity of the highlight background, as well as the line width, and 
specify comment that displays when a user puts the mouse pointer over the text:
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Typewriter

The  Typewriter tool allows you to quickly to add some remark text to a PDF document without much 
editing.

Using typewriter

Click the Typewriter button  on the toolbar or use the Comments > Typewriter menu to select the 
Typewriter tool.

Then, click where you want to add the text comment.

A user can modify Typewriter parameters, using the Object Inspector. Namely, the following properties 
can be modified: 

 Text format, including font (name, style, size) and alignment.

 Border line style, width and color, including background color.
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Editing Typewriter text 

Select toolbar button  or the Tools menu (Alt+6) to edit recently added Typewriter comment. Then, 
click  Typewriter comment to select it. Now editing the parameters is available in the Object Inspector  
panel:

Double-click the Typewriter objects to edit the text of typewriter, modify its color or font:
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Callout

With the Callout tool you can add text comment with an arrow to point to the specific spot on the page, so  
that readers turn their attention to this location. 

Using Callout

Click the Callout button  on the toolbar or use the Comments > Callout menu item to select the 
Callout tool. 

Next, click any place on the page you want to be pointed out and drag the comment to any location of the 
document where text needs to be added.    

A user can modify Callout parameters using the Object Inspector. You can change the properties shown 
below: 

 Text format, including font (name, style, size) and alignment.
 Border line style, width and color, including background color.
 Arrow size and style. 
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Editing Callout text 

Edit  Callout comment in the same way as  Typewriter comment: use Hand tool button  or the Tools 
menu (Alt+6) to edit added Callout comment. Next, click Callout comment to select it. Now, you can edit 
the parameters of the comment in the Object Inspector panel:

Double-click the Callout object with Edit Document tool  to edit the text of callout:
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Stamps

Stamp in PDF documents serves as a comment tool that is similar to an imprinted stamp on paper.
To add a stamp to a document, go to the  Comments  menu and select  Stamp, or  click the appropriate 

button on the toolbar ), then select the required sample from the available stamp palette. 

You can add a description to the stamp, as well as to any other commenting tool, and it will be displayed 
in  the  comment  window.  The  parameters  of  the  comment  window  can  be  modified  in  the  Object  
Inspector.

You can use preset stamps or create your own with Master PDF Editor. Preset stamps can be standard or 
dynamic.

Standard stamps contain only static stamp title.

Along with  the  stamp title  and author's  name,  dynamic  stamps include  information  obtained from a 
computer when the stamp is placed: system date and time.

You can modify the author's name in Tools > Settings menu on Comments tab. The dynamic stamp name 
will remain unchanged as well as the standard.

Master  PDF Editor  also allows making custom stamps that  differs  from the default  ones and have a 
custom title. Click the Settings button in the stamp palette to create a custom stamp.
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Press Add button in Custom Stamps window to see Edit Stamp dialog window. There define the stamp 
title, choose the template and insert the text to be displayed on the stamp. After pressing the OK button, 
the created stamp will be displayed in  Stamps list. After you close the window, it will be available in 
stamps palette.

To edit or remove existing stamps, select the stamp in Custom Stamps pop up window and press Edit or 
Remove button.
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View comments 

Use Comments List to view all comments you have in a PDF document. You can also apply Comment 
filtering to easily view comments. 

Comment list 

The Comment List may be viewed in three ways:

 Use the Comments > Comment View > Show Comment List menu command;

 Use the Comment View toolbar button  or select Show Comment List command:

 Use the Object TreeView button  on the left panel. 

This will open the comment list, where you can quickly review all comments made and navigate through 
them.

Click a comment in the comment list to go to that comment in the document and select it.
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Comment filtering 

Use the Comment View tool to filter out unnecessary comments in a document. 

Click the Comment View toolbar button  or go to the Comments > Comment View menu. Then, you 
may apply a filter by the type of comment:

…by reviewer:
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…or by status:

The filter can be applied to both comments in the document and those in the Comment List.

Select Show All Comments to cancel all filters. Select Hide All Comments to remove all comments.

Exporting and importing comments

The comment export feature allows you to save all notes, highlights, and annotations from a document  
into a  separate file.  This  is  convenient  when you need to share only the feedback and remarks with  
colleagues without sending the entire PDF file. When imported, comments are restored in the document 
while preserving their original position, appearance, and content.

Supported formats:

• Export: FDF, TXT, XML, JSON.

• Import: FDF only.

Exporting comments

To export comments:

1. Open the document containing comments.

2. In the main menu, select Comments > Export Comments Data….

3. In the save dialog, specify a filename and choose the desired format (FDF is selected by default).

4. Click Save.

Copyright © 2026 Code Industry Ltd



Exporting to text-based formats (TXT, XML, JSON) is useful for analyzing comment content in external  
applications. The FDF format preserves the complete annotation structure, including positioning on pages, 
and is intended for subsequent re-import into a PDF document.

Importing comments

To import comments:

1. Open the PDF document into which you want to add comments.

2. In the main menu, select Comments > Import Data….

3. In the file dialog, locate and select the FDF file containing the saved comments.

4. Click Open.

After  import,  comments  will  appear  on the same pages and in  the same positions as  in  the original  
document. This feature is especially helpful when working with multiple revisions of the same document 
or when consolidating feedback from different reviewers.

Drawing Tools

Drawing tools allow you to point at specific elements in the PDF document, emphasize certain parts or 
attract attention of other authors to specific comments you made.

NOTE:  Do  not  confuse  drawing  tools  used  for  commenting  with  vector  images.  Unlike  the  latter,  
commenting drawing tools do not alter the actual content of the document and are not printed.

You can select a drawing tool using the toolbar or the Comments menu.
The following tools are available:

 Arrow.   Draws an arrow.

 Line.  Draws a straight line

 Rectangle.  Draws a rectangle

 Ellipse.  Draws an ellipse

 Pencil.  Draws free-hand lines and drawings

 Brush.  The same as above, but the trail is thicker

 Polygon.  Draws a polygon.

 Cloud.  Draws a comment is the shape of a cloud.

Inserting drawings to comment PDF documents

To insert  a  drawing,  use  the  Comments > Drawing menu or  click  the  corresponding button  on  the 
Comments toolbar. Clicking the down arrow on that button allows you to choose a drawing tool.
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Click and hold the left mouse button to specify the first point of the drawing, then move the mouse to the  
second point and release the button. For the  Pencil and  Brush tools, drawing goes while you hold the 
button and ends when you release it.

To stop drawing, press Esc or click the right mouse button.

Adjusting drawing parameters
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To modify a drawing, select the Hand Tool  by clicking its button on the toolbar or using the Tools > 
Hand Tool menu (Alt+6). Then click the drawing object you want to modify. If the Object Inspector panel 
is not visible, display it by clicking the Object Inspector button on the right panel or press Ctrl+F11.

In the  Object Inspector  window you can modify parameters of the selected drawing: adjust line width, 
color, opacity and also add a text comment to that object. The Status option sets the current status of the 
comment: Accepted, Cancelled, Completed, or Rejected.
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Double-clicking the object pops up the balloon tooltip displaying the text comment and all the replies:

Copyright © 2026 Code Industry Ltd



Editing Pencil and Brush drawings

When you use Pencil and Brush tools you can only adjust their parameters while drawing them. Use the 
Path section in the Object Inspector panel to do this:
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When you finish drawings by pressing Esc or right-clicking, the Pencil and Brush objects are transformed 
to stamps and cannot be further edited as path lines. You can only edit the text of the comment and the 
color of the balloon tooltip:

You can read more about here.

Measurement Tools

Measurement tools allow you to measure distances, perimeters and areas in the PDF document. You can 
use measurement tools to control and specify measurements in PDF blueprints, or make sure the actual 
size of the document elements fits the paper size before printing. 

The following measurement tools are available:

Line.  Measures the distance between two points.

Perimeter.  Measures the length of some perimeter.

Area.  Measures the area of some part of the document.
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Using measurement tools

To use a measurement tool, click its corresponding button on the toolbar   or use the  Comments > 
Measurements menu.  Clicking  on  the  down  arrow  of  the  toolbar  button  allows  you  to  select  a 
measurement tool:

Using distance measurement tool

Click and hold the left mouse button to start drawing the Distance measurement tool. Move the mouse to 
the next point and release the button.

While you’re moving the mouse the current coordinates and the distance are displayed in the  Object  
Inspector window.

Press Esc or right-click to finish drawing.
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To select the distance measurement line, select the Hand Tool  and click the line. This will display its 
properties in the Object Inspector window.

Double-click the line to display the balloon tooltip with the text comment:
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Using perimeter measurement tool

The Perimeter  Tool allows  you  measuring  cumulative  length  of  several  straight  fragments.  To  start 
drawing with the Perimeter Tool, click with the left mouse button at the beginning of the first fragment, 
then click the second point, then go to the third one and so on until you go around the entire perimeter.

The distance of the latest fragment and the entire perimeter length so far are displayed in the  Object  
Inspector panel.
Double-click when the final point of the perimeter is set. Press Esc or right-click to finish drawing.
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To select the perimeter object, select the Hand Tool  and click the perimeter:

The parameters of the perimeter are displayed in the Object Inspector.
Double-click the perimeter to bring up the balloon tooltip.
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Using the area measurement tool

To measure an area in the document, select the  Area Tool.  Click the first point, then the second and 
following points until you mark the entire area you want to measure.

The Object Inspector panel displays coordinates, the distance of the latest fragment and the angle of the 
current  fragment.  To end the  area,  right-click  or  double-click.  The  remaining fragment  will  be  built  
automatically from the current point to the beginning point.
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The area of the specified polygon is calculated automatically based on the current scale (see below).

To select the area measurement drawing, switch to the  Hand Tool   mode and click the area. In the 
Object Inspector window you will see properties of the selected object.

Double-click the area measurement  drawing in the document  to  display the balloon tooltip  with text 
comments and all the replies.
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Setting the scale ratio of measurement tools

Scale ratio allows you to display real length and area when you use measurement tools.

To set the scale ratio, select any of measurement tools. The settings of the tool will be displayed in the 
Object Inspector.

The Scale Ratio parameter allows you to set relation between lengths in the document and the real ones.
The left box sets the value and the unit in the document, the right box sets the real value.

For example, if  the blueprint says the scale is 1:10, this means each one millimeter in the document 
corresponds to ten real millimeters.

If the Scale Ratio is set, Master PDF Editor will display scaled values in the measurement tools.
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Here, we measure the same length on the drawing, but set different scale ratios. Hence, the resulting 
distance displays different values.

PDF form fields

PDF files can include two kinds of forms: interactive and non-interactive. Interactive form is a PDF form 
with fields, which can be filled without any additional functions. Non-interactive form is just a file with  
text and lines to write your data over them. Master PDF Editor allows to fill non-interactive forms with  
Insert Text tool.

Interactive forms can be filled with Hand Tool . You can print filled document and save it.

Filling Interactive Forms

If  a  document contains interactive PDF forms,  then you will  see a  pop up message  «This document  
contains interactive form fields» when opening it. Message will appear if the application’s setting weren’t 
changed. To set Pop up message display when opening PDF with forms, open Tools > Settings > Forms 
tab. Enable/disable a checkbox near Always hide document message bar item.

Enable Hand Tool  to fill interactive PDF forms.  You can enable menu item  Forms >  Highlight  

Fields, this will help you notice forms easier, because they will be displayed on color background set in 
Master PDF Editor Settings. 
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When positioning mouse cursor over form field, it will be changed to one of the following:

  icon will appear when hovering the cursor over a checkbox, radio button, push button, list or combo 
box. Depending on field kind, when filling form you’ll have an option to choose an item or several items 
of predefined set. Left click the field to fill it.

Icon (cursor) will appear when hovering mouse cursor over  Text Field.  Position a cursor there by left 
clicking the field. When you’ve finished typing text,  press  Tab or  Shift+Tab to move to the next or 
previous field. You can also just mouse click a field you want to fill next.

To remove data from all document forms use Reset Forms command in Forms menu. 

Please note, that forms data won’t be restored with “Undo” command. 

You can edit document with PDF forms just like any other PDF document, if file’s author hasn’t  
restricted this ability. 

Exporting and Importing Forms Data

This feature is designed for working with interactive PDF forms and allows you to save and restore form 
field values separately from the document itself. Like comment export, form data export helps reduce the  
volume of transmitted data when sharing completed forms.

Unlike comments, only the values of interactive form fields are subject to export and import.

Supported formats:

• Export: FDF, TXT, XML, JSON.

• Import: FDF, XML, JSON.

Exporting form data

To export form data:

1. Open the document containing  a filled interactive form.

2. In the main menu, select Forms > Export Form Data….

3. In the save dialog, specify a filename and choose the desired format (FDF is selected by default).

4. Click Save.

The exported file contains only the field values of the form and does not include the document layout or 
visual appearance.

Importing form data

To export form data:
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1. Open the PDF document into which you want to import the form data.

2. In the main menu, select Forms > Import Form Data….

3. In the file dialog, locate and select a file in FDF, XML, or JSON format.

4. Click Open.

Form fields will be automatically populated with values from the file. The document structure and visual  
appearance remain unchanged.

Creating and Modifying Interactive PDF Forms

One of the most demanded functions of PDF editors is a possibility to create PDF forms. Master PDF 
Editor allows to place in documents any interactive forms, which later can be filled, signed with digital  
signature, printed, saved or sent via email.

In Forms menu you can choose an option for new form fields creation. Forms settings are displayed in 
Object Inspector window. It allows to specify settings for one or multiple forms at once.

To edit form fields, enable editing mode by pressing Edit Document  or  Edit Forms  button on 

toolbar or choosing either of these tools in Tools menu.

PDF file may contain following kinds of forms:

Button Name Description

Link
Enables user for a quick move to another place of current, attached or 
any other document, to other files and web sites. Can also be used to 
initiate predefined event.

Push Button Allows to initiate predefined event like opening a files, sending data to 
web-server, forms reset etc.

Check Box Allows to set enabled or disabled condition. If a form contains several 
check boxes, users may choose any number of options.

Radio Button Offers a set of options and allows user to choose only one of them 
when filling a form.

Combo Box Provides user a possibility to choose an item out of a list or specify 
custom value.

List Box Allows user to choose one or multiple items out of list.

Text Field
Field to specify custom text like name, address, date, phone number 
etc.

Signature Empty field for digital signature.

Link 

Link enables user for a quick move to another place of current, attached or any other document, to other  
files and web sites. Can also be used to initiate predefined event. 
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To add link to the document choose Forms > Link (Ctrl+L) in menu or press  Insert Link button on 
the toolbar. This will show a marker, allowing you to choose field for link (Tool can be deactivated with 
Esc or right mouse button). You can set options and define actions for link in Object Inspector. 

Geometry tab enables user for more precising positioning of the link field on the document page. For more 
details see Geometry Objects     and Geometry Forms sections.

Following settings can be set for link in Options tab:
 Line Thickness. Thickness of lines framing the link (in pixels).
 Border Color. Color of lines framing the link.
 Line Style. Style of lines framing the form. Options: solid, dashed, underline.
 Highlight.  Setting is  currently not  supported.  Feature added only for  compatibility with other 

editors.
Actions tab allows setting a kind of action and a trigger, which has to be fired in order for the action to be  
performed.

Trigger item is used to specify a kind of event, which must be initiated by user for defined action to be 
preformed.  Following actions(events)  can be set  as  trigger:   Mouse Up, Mouse Down, Mouse Enter,  
Mouse Exit, On Receive Focus, On Lose Focus. 

Action  item allows specifying a kind of action, which will be preformed after trigger is fired:  Go to a  
Page View, Open/execute a file, Open a web link, Reset form, Show/hide fields, Submit a form, Run a  
JavaScript. For more details, see Actions tab.

Link attributes can be changed any moment according to your requirements.

Button

To create a push button, choose corresponding item in Forms menu. Click a spot of the document page, 
where you want to locate the button. Application will create a button of default size. Instead, you can hold  
left mouse button and draw a rectangle box of required size. You can create multiple instances of push  
button. Names of newly created button are same as first button’s name, but with index number. If you  
create new buttons by copying the first one, they will have completely identical name. Button copies work  
independently of each other.

If required, copied button can be pasted to all pages of the document or specific range of pages. To do it,  
choose Paste to multiple pages item in Edit menu.

Settings for buttons in Object Inspector Geometry, General, Appearance and Actions tabs are similar to 
these settings for other form fields. For more details see Geometry Objects and PDF Forms properties.
Following settings can be set for Push Button in Options tab:

 Layout. Select the push button label and icon layout. 
 Behavior. Sets option of button behavior on mouse click: invert, push, outline, none.
 Up Label. Text label to be displayed on button in inactive state.
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 Down Label. Text label to be displayed on button in pressed state.
 Rollover Label. Text label to be displayed on button when received focus.

Check Box

Check box is used to provide a user Yes/No kind of input to express agreement with document items. 
Usually this kind of form is used when required to choose several options out of a list. If only one option 
has to be chosen, then radio buttons are usually used. To create a check box on the document, choose 
Forms > Check Box in menu.

Settings  for  check  boxes  in  Object  Inspector  window  are  identical  to  other  form  fields  settings  in 
Geometry, General, Appearance, Actions tabs. See Geometry Objects and PDF Forms properties.

When creating a check box, it is possible to make it required to be filled by user. To do it, check Required 
item in General tab of Object Inspector window. When user fills forms, required fields are highlighted.

Options tab. 

Style item allows to choose check box kind: check, circle, cross, diamond, square, or star. Export Value 
item is used to specify a value for export, if the field is enabled by user when filling forms. If Checked by  
Default is enabled, check box will be checked when resetting forms (menu item Forms > Reset Forms 
resets data in all document forms. Fields are set to default values or cleared, if there’s no default value.)

Please note, that right after this option is enabled, check box won’t be checked by default. You have  
to Reset Forms first.

Master PDF Editor allows to set several behavior patterns for check boxes:

To make other check boxes enable themselves when one of them is enabled by user, all of these check 
boxes are to have identical Names (General tab) and same Export Values (Options tab). Such fields can 
be located at different pages.

For a possibility to choose only one check box out of a group, all the group has to have same Names and 
different Export Values.

For check boxes to be filled independently from each other, their Names and Export Values have to be 
different. 

All  the  actions  with  check  boxes  (creation,  movement,  resizing,  creating  copies,  duplicating  and 
removing) are conducted the same way as for all other kinds of form fields.
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Radio Button

To create  radio  button form field,  choose  Forms >  Radio Button menu item.  Radio button is  most 
common way to give user possibility to choose one option out of a set. Radio buttons always work in 
groups unlike check boxes. Accordingly, all the form fields of a radio button group have to own identical 
Names (General tab) and different Export values (Options tab). All radio button settings are identical to 
those of check boxes.

All  the  actions  with  radio  buttons  (creation,  movement,  resizing,  creating  copies,  duplicating  and 
removing) are conducted same way as for all other kinds of form fields.

All the radio button settings in  Object Inspector  window are identical to other form fields settings in 
Geometry, General, Appearance, Actions tabs. See Geometry Objects and PDF Forms properties. 

List Box

Choose Forms > List Box menu item to create a list.

When filling,  user may choose one or multiple list  box items. Possibility of such choice depends on 
settings, applied by the document’s author. When creating several list box fields in PDF document, all of  
them have to own unique Names (General tab).

Options tab.
 Item. To add an item to the list, specify its text in item field and click Add button. To remove it 

from the list, choose the item in the list and click Delete button.
 Export value. If required for export value to be different from selected list item when exporting 

data, specify custom export value at this item. (If Export value isn’t set, it will be automatically 
set to the text of the chosen item.)

 Up and Down. These buttons allow to move selected item up and down the list.
 Sort Items. If enabled, buttons Up and Down are locked, and list items are automatically sorted in 

alphabet order. 
 Multiple selection. If enabled, users will be able to select multiple items of the list.
 Commit selected value immediately.  If  enabled,  value as saved right  after  user  selects  it.  If 

disabled, value is saved only when user switches focus from current field to another form.

All the actions with lists (creation, movement, resizing, creating copies, duplicating and removing) and 
settings in Geometry, General, Appearance, Actions tabs are same as for all other kinds of form fields. See 
Geometry Objects     and PDF Forms properties. 

Combo Box

With combo box user can choose an item out of a predefined set or specify custom value.
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Settings of combo box in Options tab are same to those of a list box, except for the only item Allow user  
to enter custom text. If this item is enabled, user may enter custom value when filling the form.

Text Field 

Text Field allows user to enter custom text when filling PDF form.

To create edit box choose Forms > Text Field menu item and click a spot of the document page, where 
you want to locate text field. Application will create a text field of default size. Instead, you can hold left 
mouse button and draw a rectangle box of required size.

When creating multiple text fields in PDF document, they all have to own unique Names (General tab). In 
case it’s not done, data will be duplicated in all text fields with the same name when one of them is filled  
by a user.

Options tab.
 Default value. Allows to specify default text.
 Formatted text. If enabled, possible to enter formatted text (bold, italic, underline etc.) (Current 

version doesn’t support formatted text.)
 Alignment. This item allows to specify text position in form field (left, center, right). 
 Multi-line. If  enabled, entered text will be written to separate lines. Otherwise all text is written 

into single line.
 Password.  If  enabled, text will be displayed as start when entered by user. (Available only if 

Check spelling is disabled)
 Scrollable. If enabled, user may input text, which exceeds the borders of the text field.
 Check spelling. If enabled, spell-check is performed on the text in the edit box.
 Limit to. Allows to specify maximal amount of characters to be entered by user.
 Split into. Allows to split text field into specified number of cells for characters input.

PDF Forms Properties

You can set parameters and define actions for form fields in Objects Inspector.

Options Tab

Options tab contains individual settings for different form fields.

Geometry Tab

 Width and height. These items of Geometry tab allow to specify size of single or multiple forms 
at once. To do it, select required form(s) and specify the data in corresponding items.

Geometry tab  displays  settings  for  active  form  only.  If  a  number  of  forms  are  selected 
simultaneously, no active form will be selected and settings won’t be displayed in Object Inspector.
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 Left. Distance from left page border to the left border of the form.
 Top. Distance from top page border to the top  border of the form.
 Coordinates. Sets offset when aligning forms with settings in left and top items. Coordinates can 

be absolute or relative:
• Relative. When aligning forms using top and/or left items distance between forms remains same.

• Absolute. When aligning all forms will be moved irregularly and will be positioned in coordinate 
point set in top and/or left items.

 Maintain aspect ratio. If enabled, form’s aspect ratio isn't changed when its height and width are 
being modified.

 Units. Select unit to measure object. 
 Align. Automatically move or align selected objects. There are 6 types of alignment: Left, Right, 

Top and Bottom.
 Send to back. Move selected element to the background.
 Send backward. Move the selected element to the back by only one object.
 Bring forward. Move the selected element to the front by only one object.
 Bring to front. Move selected element to the foreground.

General Tab

 Name. Unique form name. Required for correct form fields data import and export. 
 ToolTip. Text which will appear in pop up menu when hovering mouse cursor over the form.
 Orientation. Data orientation in the form (for all form fields except for links).
 Form Field. Option of form field display on screen and when printing. Has 4 options: visible; 

hidden; visible, but not printable; printable, but not visible.
 Read Only. If enabled, form won’t be used for filling and users will only be able to view data 

displayed in this field.
 Required. If enabled, form will be required for filling. This item can be enabled for all kinds of 

form fields except for List and Push Button.

For your comfort, Master PDF Editor allows to highlight all forms required for filling. Use main 
menu to choose Tools > Settings > Forms.

 Locked. If enabled, the application won’t allow fill this PDF form.

Appearance Tab

 Line Style. Style of lines framing the form. Options: solid, dashed, beveled, inset, underline.
 Line Thickness. Thickness of lines framing the form. Options: thin, medium, thick.
 Fill Color. Color of form fill.
 Border Color. Color of lines bordering the form.

Object Inspector  allows to specify size, color and font family for records in all form fields except for 
check boxes and radio buttons. Records themselves are specified in Options tab.
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 Size. Records font size. If set to Auto, font size will be changed accordingly to the form’s size.
 Color. Records font color.
 Font. Records font family.

Actions tab

Actions tab allows setting a kind of action and a trigger, which has to be activated in order for the action 
to be performed. 

Trigger item is used to activate actions. Specify a kind of event which must be initiated by a user for a 
defined action to be performed. The following events can be set as a trigger:

 Mouse Down. Activates when a form is pushed down with the left mouse button.
 Mouse Up. Activates when a user pushes a form with the left mouse button and then releases it.
 Mouse Enter. Activates when a user hovers the cursor over a form.
 Mouse Exit. Activates when a user hovers the cursor over a form and then moves the cursor away 

from it.
 On Receive Focus. Activates when a form area gains focus through tabbing or a mouse action.
 On Lose Focus. Activates when a form loses focus.

If it  is needed, several triggers can be selected for a form and each of them can have a few actions 
assigned to it.

For Link only a kind of action can be set. For Signature actions and triggers are not defined.

Action item allows specifying a kind of action to be performed after a trigger is fired: Go to a Page View,  
Open/execute a File, Open a web link, Reset form, Show/Hide fields, Submit a form, Run a JavaScript.

Choose the required trigger and specify an action to be performed. Press Add button. This will pop up a 
dialog window, which allows specifying data depending on Action option.

 Go to a Page View. Set page number and scale.
 Open/execute a File. Opens or launches local file from the drive. Input file name or press Browse 

button to choose a file in dialog window.
 Open a web link. Opens link in default web browser. Specify a link in dialog window.
 Reset form. Resets form values in the document. Default values will be set or form fields will be 

emptied.
 Show/Hide fields. Hides or shows a form, specified in dialog window.
 Submit a form.  Sends data of chosen forms in specified formats. Currently Master PDF Editor 

allows to send data only in FDF formats. Data can be saved to local file or sent with FTP or HTTP 
(File delivery via email is currently not supported in Master PDF Editor).

When saving data to local file specify file name or choose it in dialog window with Browse button. 
When  sending to FTP server  specify server address, user name and password if required. Otherwise 
enable Anonymous checkbox. 
When sending to HTTP or HTTPS server, specify server address.
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 Run a JavaScript. Execution of your JavaScript code.
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Securing PDFs with a Password

Password protection allows you to prevent unauthorized persons from performing certain actions with the 
document. Without the password, a user cannot open the document or is not allowed to edit, print or 
comment the document.

Adding a password to a PDF document

To protect a PDF document with a password, open the PDF document you want to protect, then click the  
File > Properties menu. This will bring up the Document Properties window. Switch to the Security tab.
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By default, a PDF document uses no encryption. Click the drop-down box and select Password 
encryption there. A new window will pop up, Password Security.

PDF documents can be encrypted with two types of passwords.

 The first one is a password to open the document. If you just want to share the document with 
another person and don’t want others to be able to open it, you most likely need a password to 
open.

 The second type is a permission password. A permission password allows only the selected actions 
and prohibits  all  others.  So,  for  instance you may create a  password that  allows viewing and 
commenting the PDF document, but does not allow printing or editing.
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Adding a password to open the document

Enable the Requires a password to open the document option in the Password Security window. Then 
enter the password in the first box and re-enter it in the second box. Click OK to save the security settings.

Next time this document will be opened in any application, a password dialog will be shown. For instance, 
in Master PDF Editor the open password dialog looks as follows:

Adding a permission password

Enable the Permissions option in the Password Security window. Enter the password in the first box and 
re-enter it in the second box. Then select actions that are permitted. Deselected actions will be disabled in 
this PDF document. Click OK to save the security settings.
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Now, changing permissions of this document will prompt for the correct permission password.

 Unlike the password to open a document, a permission password does not actually encrypt the data 
in the PDF document. Hence, it is still possible to open the protected document in a third-party application 
and perform all the disabled actions as long as that software disregards the permission password.

Selecting encryption type

You can select between  128 bit RC4  and  256 bit AES algorithms. Both provide firm security for your 
documents when using a password to open the document.

256 bit AES encryption requires Acrobat 9 or higher compatible application to read it.
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Encryption of PDFs with a Certificate

Securing a PDF file using a certificate is a reliable way to limit the scope of persons who can access the 
document. The encrypted document will only be accessible by recipients whose certificates are explicitly  
included to the list of valid recipients for this PDF document.

PDF encryption using a certificate

To encrypt a PDF document with a certificate:

1. Make sure the required certificate is imported to your local certificate storage. 

In order to use a certificate for encryption, that certificate must include a public key.

You can check all the imported certificates in Certificate Manager. To open Certificate Manager, click 
the Tools > Settings menu and switch to the Certificates tab.
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2. Click the File > Properties menu and switch to the Security tab in the Document Properties 
window. 
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In the drop-down box select Certificate Encryption. A Certificate Security dialog opens.

3. In the Recipient drop-down box select a certificate you want to add to the recipient list, then click 
Add. The list displays all certificates that include a public key. 

Add all recipients that you want to be able to open this PDF document.

IMPORTANT: Make sure to add your own certificate too in order to be able to open the encrypted PDF  
document yourself.

4. Adjust permissions. If you want to limit the scope of actions allowed to perform in the PDF 
document, turn on the Permissions option and select which actions are allowed. 

5. Select encryption method. You can select between 128 bit RC4 and 256 bit AES algorithms. 
Both provide firm security for your documents when using a password to open the document.

256 bit AES encryption requires Acrobat 9 or higher compatible application to read it.

Now, the PDF document is encrypted with a certificate and can only be opened by the owner of the 
private key of that certificate. Otherwise, an error message will be displayed. For instance, Master PDF 
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Editor displays the following message when a PDF document encrypted with a certificate absent in the  
system is opened:

Signing PDF document with a certificate

What is a digital certificate

A digital certificate is an electronic document that verifies the identity of a user and prevents forgery of 
the document content. Simply put, the certificate makes sure the author of a document is who he claims to 
be and the content of the document was indeed written by this author.

A digital certificate is issued by a Certificate Authority (CA, the issuer) – an entity that verifies the 
identity of the applicant. CA signs the public key of the applicant with its own digital signature – trusted 
and publicly available. This allows any software to identify this public key as valid and trusted and use it 
to encrypt or sign documents.

To get a digital certificate, you must submit an inquiry to a Certificate Authority that will issue a digital 
certificate. Common sources of digital certificates are:

• VeriSign;

• Thawte;

• DigiCert;

• GlobalSign; 

• DocuSign;

• Comodo. 

Some Certificate Authorities offer digital certificates for free, others require payment.

NOTE: Master PDF Editor itself does not provide any digital certificates. You should acquire a 
certificate from a CA before using it to sign documents.

How to create and verify digital signature

Digital signature is an effective way to protect documents from changes and to identify the true sender.

A digital signature ensures that the signed document wasn’t changed by anyone other than its author. It is 
the most common way to assure the authenticity of the document content. PDF signature has a digital 
certificate issued by a trusted certificate center.

Master PDF Editor allows validating digital signatures, creating them and signing PDF documents with 
them.
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NOTE: Do not confuse digital signature with inserting initials. While digital signing allows for 
authentication, integrity and non-repudiation of a PDF document, initials are merely an “autograph” to 
inform readers about the authorship of the document.

Creating Signature and Signing

To create a signature, you must own a digital certificate. The common source of certificates is various 
Certificate Authorities (VeriSign, Thawte etc.) that act as a trusted third party ensuring the validity of the 
signature. Certificate Authorities issue and validate certificates as owned by a certain person or entity.

On macOS, the certificate must be previously copied to the system certificate storage. On Linux, you 
have to import the certificate into the Certificate Manager beforehand.

To create a digital signature, choose Forms > Signature in the main menu or click the Signature button 

 on the toolbar. In the document, define a rectangle where the digital signature must be located. 

Now you can sign the document, provided you have a digital certificate. 

To add a digital signature to a document:

1. Select a rectangular signature area in the document. You can do this using any of these ways: 

• Click Edit Document  on the toolbar, then double-click the signature area.
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• Click Hand Tool  on the toolbar, then click the signature area once.

• Right-click the signature area and select Signature Properties.

The Signature Properties window will appear.

2. Select the certificate in Sign As.  

3. Adjust some other parameters if needed:

• Saved Settings. Choose the previously saved settings.

• Reason. Select one of the predefined reasons or specify your own.

• Location. Insert information about the location.

• Lock document after signing. Prohibit changing the content of all forms after signing the 
document.

• Signature Preview. Displaying the appearance of the signature.
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• Appearance Settings. Set appearance preferences of the signature. 

• Text.

◦ Show Text. Enable/disable the display of text in the signature. It is also possible to hide specific 
signature text: Name, E-mail, Date / Time, Signed By.

◦ Data format. Change the calendar date and time format.

• Custom. Use your signature text by entering it in the corresponding field. 

• Date Format. Change the calendar date and time format.

If you select the Custom option, you will be able to edit the signature text in the Text Editor pop-up 
window. Thus, you can change and format the text of the signature. 
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• Border.

◦ Show Border. Show/hide signature border.

◦ Rounded Border. Round corners of the signature border.

◦ Color. Select the color of the signature border.

• Image.

◦ Show Image. Enable or disable the ability to add and display an image in the signature.
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◦ Stretch Image. Show the image in full size.

4. Click Sign to sign the document.

5. Save As… window opens in which you need to set a file name and the location and then press 
Save. Now your document is signed with a digital signature.

On macOS, you’ll have to permit the application to access the certificate storage. 

IMPORTANT:  Singing should be done on the final version of the document, when you are done with the 
editing. If the document is modified after signing, these changes will corrupt the signature, making it 
invalid.

Invisible Signature

When it is necessary to digitally sign a document, but a signature field should not be displayed in the 
document, the invisible signature can be used. In this case the signature field is not visible to a user but 
they can still see that the e-signature was added to the document when opening the Signature tab in Master 
PDF Editor.

Master PDF Editor does not provide any digital certificates. Please acquire a certificate from a 
Certificate Authority or create a self-signed certificate yourself before signing documents. 

You can read more information about digital certificates here.

To add a hidden signature field to your document:

1. Choose Forms > Invisible Signature in the main menu. 

2. The Signature Properties window opens. Select your certificate in Sign As.
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On macOS, the certificate must be previously copied to the system certificate storage. On Linux, you 
have to import the certificate into the Certificate Manager beforehand.

3. Adjust some other parameters if needed:

• Saved Settings. Choose the previously saved settings.

• Reason. Select one of the predefined reasons or specify your own.

• Location. Insert information about the location.

• Lock document after signing. Prohibit changing the content of all forms after signing the 
document.

6. Click Sign.

7. A Save As… window opens in which you need to set a file name and the location and then press  
Save. Now your document is signed with an invisible signature.
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Information about an invisible signature is only displayed in the Signatures tab of the Navigation Panel. 
This is how the invisible signature looks like on the left panel when the document is signed:

Signing should be done in the final version of the document after you finish the editing. If the 
document is modified after signing, these changes will corrupt the signature making it invalid.

To delete the invisible signature, select it in the Signatures tab on the left panel and press the button 
Delete. The Edit Document tool needs to be chosen beforehand for the Delete button to be active.

You can also enable the Strong verification of signatures parameter in the main menu Tools > 
Settings and then choosing the Certificates tab. This parameter makes invalid the previously added 
signatures after inserting a new one, even if no other changes were made in the document.

Batch Signature

When it is necessary to sign multiple documents at once, the batch signature can be used. Batch signing 
can help to save time and increase efficiency when it is needed to sign a large number of similar 
documents.

Master PDF Editor does not provide any digital certificates. Please acquire a certificate from a 
Certificate Authority or create a self-signed certificate yourself before signing documents. 

You can read more information about digital certificates here.

To sign multiple documents:

1. Select Forms > Batch Signature in the main menu. A dialog box for adding documents will 
appear.
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2. Add  documents to the list using one of the following options: 

• Add Files. Add specific documents.

• Add Folder. Add all documents from the selected folder.

• Add Open Files. Add all documents already open in the program.

3. If necessary, change the document order using Up and Down.

4. To remove a document from the list, use Delete. To remove all documents from the list, use Clear 
All. 

5. Click OK  to proceed to Signature Properties. In this window, select a certificate in Sign As. 
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On macOS and Windows, the certificate must be first imported into the system certificate storage. On 
Linux, the certificate must be first imported into the Certificate Manager.

6. Configure the remaining parameters if needed:

• Saved Settings. Select the previously saved settings.

• Reason. Choose one of the predefined reasons or specify your own.

• Location. Add information about the location.

• Lock document after signing. Prohibit changing the content of all forms after signing the 
document.

• Invisible Signature. Sign the selected documents with an   invisible signature  .

• Signature Preview. Display the visual appearance of the signature.
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• Appearance Settings. Configure the visual style of the signature.

• Text.

◦ Show Text. Enable or disable test display. It is also possible to manage the display of fields 
such as Name, E-mail, Date / Time, and Signed By.

◦ Custom. Use arbitrary signature text by entering it in the corresponding field.

◦ Date Format. Change the format of the calendar date and time.

If you enable Custom, a Text Editor window will appear, allowing you to edit and format the signature 
text directly in Master PDF Editor.

• Border.
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Creating a custom signature text



◦ Show Border. Show or hide the signature border.

◦ Rounded Border. Round the corners of the signature border.

◦ Color. Select the border color.

• Image.

◦ Show Image. Enable or disable the ability to add and display an image in the signature.

◦ Stretch Image. Display the image in full size.

• Position.

◦ View on page. Preview the signature placement on the page.

◦ Select Page. Specify a page number or choose First page or Last page.

◦ Left. Set the horizontal position of the signature on the page.

◦ Top. Set the vertical position of the signature on the page.
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◦ Width. Set the signature width.

◦ Height. Set the signature height.

 

7. To modify the document list, click File List.

8. Click Sign.

9. A dialog box showing the signing status of the documents will open. Here you can verify whether each 
document was signed successfully.

 If a page has a non-standard size, the signature can be cropped or placed outside of the page 

boundaries. 
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This window displays the signing status of each document



Always sign the final version of a document after all editing is complete. Any modifications made 
after signing will invalidate the signature.

You can also enable the Strong verification of signatures parameter by selecting Tools > Settings, 
the  Certificates tab in the main menu.  This parameter invalidates all previous signatures when a new 
signature is added, even if no other changes were made in the document.

Digital Signature Validation 

Validating digital signature allows you to verify, if the document is authentic and no changes were made 
into it by anyone else other than the author who signed it.

To validate a digital signature:

1. Open the PDF document in Master PDF Editor.

2. Select the signature in the document. You can do this using any of these ways: 

• Click Edit Document  on the toolbar, then double-click the signature.

• Click Hand Tool  on the toolbar, then click the signature once.

• Right-click the signature and select Signature options. 
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This will bring up the Signature Properties window.

There you can see who signed the document and the signing reason as well as the validation summary:  
whether the signature is valid or invalid, or if validity is unknown. 
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Signature is VALID

The signing certificate is trusted, and its parent certificates are trusted. The document content was not  
altered  after  signing.  If  the  digital  signature  is  valid,  you  should  see  the  following  message  in  the 
Signature Properties window: 
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Signature is INVALID

Issues occurred when validating the signature. Document was changed or damaged after signing.
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Signature validity is UNKNOWN

The signing certificate is not trusted or the parent certificate of the issuing authority (the organization that 
issued the signing certificate) is not trusted. However, the document was not altered after signing. The 
following message is displayed in the Signature Properties window: 
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Making a certificate trusted 

For Windows and Mac OS X: You must add certificate's open key to system certificate storage.

For Linux: Press Information button, view certificate properties and then press Add to Trusted Identities 
button.

Viewing the signed version of the PDF document

The structure of the PDF format leaves a thin possibility that the original signed content of the document 
could be replaced by the altered content. And this altered content is then shown when the PDF document 
is opened. However, the signed version of the PDF document is still available in the file.

To view the version of the document that was actually signed, do the following:

1. Open the PDF document 

2. Switch to the Signatures tab on the left panel. 

3. Click Click to view this version. 
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This displays the original version of the document that was signed by its author and hence prevents 
forging of the PDF document content.

IMPORTANT: Always view the signed version as described here when opening documents signed with a 
signature of unknown validity.

Redacting PDF Document

Redacting allows you to permanently hide private or sensitive information in a PDF document. The 
redacted parts appear as colored boxes instead of the original information. Redacting is helpful if you want 
to publish a document but don’t want to or cannot disclose certain parts of it for some reason.

IMPORTANT: Redacting a PDF document permanently removes the redacted data from the document, so  
make sure to save the redacted PDF under a different file name than the original document, otherwise the  
redacted data will be lost.

To redact a document:

 Select Document > Redaction in the Main menu. 
 Use the Redaction toolbar.

You can select objects for redacting in two ways:

 Click the Mark for Redaction  button on the toolbar (or click Document > Redaction > Mark 
for Redaction menu) 

 Click the Search and Redact  button on the toolbar (or click Document > Redaction > Search 
and Redact menu) 
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Marking Objects for Redaction

Click the Mark for Redaction  button on the toolbar or select the corresponding item in the Document 
menu. The mouse cursor changes to a cross. Select one or more areas in the document that you want to 
redact.
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Now click the  Apply Redactions   button on the toolbar or select the same item in the  Document > 
Redaction menu to redact the selected blocks.
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Redacting PDF by Certain Keywords

When you need to redact the same text in multiple places across the document, use the Search and Redact 
tool instead.

Click the Search and Redact  button on the toolbar or select the corresponding item in the Document 
> Redaction menu. A side panel appears. Type keywords you want to search the document for and check 
the results that you want to mark for redaction. You can review each result in the document by clicking it 
in the list.
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After checking the results click the Mark Checked Results for Redaction button. This will mark all results 
for reduction in the document. 

Now click the  Apply Redactions   button on the toolbar or select the same item in the  Document  > 
Redaction menu to redact the selected blocks.
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Configuring Redaction Properties

To configure how the redacted fragments should look, open the Document > Redaction > Redaction 
Properties menu or Tools > Settings > Redaction.

The following properties are available:

 Redacted Area Fill Color. Specifies the default color to fill the redacted area blocks. 
 Use Overlay Text. This option puts a specified text over each redacted block. You can specify 

Font, Size, Color and alignment of the text. 
 Auto-size text. Automatically adjust the size of the overlay text to the size of the redacted area. 
 Repeat Overlay Text. This option will fill the entire redacted area with the specified text repeated 

multiple times. 

Also, you can adjust settings of each individual redaction area.

Click the  Edit Document   button on the toolbar or use the  Tools > Edit Document menu or press 
Alt+1. Click the redacted area you want to adjust.
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A side panel will open:

Here you can configure how the redaction area looks.

 Geometry allows to specify exact position and size of the selected redaction area 
 Style allows adjusting fill color and opacity, and stroke color, opacity and line width 
 Matrix specifies coefficients for matrix transformation. 
 Clipping path allows setting a closed vector path to constrain shape of a selected set of objects.
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Inserting Initials

Signing a document with your initials is a way to autograph your work and let readers know about the 
authorship.

 Do not confuse initials with a digital signature. Unlike a digital signature, inserting initials does  
not guarantee authenticity of the PDF document and cannot be used to verify validity of the document or  
prevent unauthorized changes.

To insert initials to a PDF document, go to the menu Objects > Place Initials.

There are four ways to add initials:

 Click Create New Initials to create new initials.
 Choose one of the available initials to insert them into the document.
 Use Open Containing Folder to access the folder where all the available initials are stored as PDF 

files.
 Select Choose Default Initials to set specific initials as default for quick access from the toolbar.
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Creating New Initials

You can create new initials to add them in the collection of initials available for placing in documents. 

To create new initials:

1. Go to Objects > Place Initials > Create New Initials. 

2. In the dialog that appears, choose one of three methods to create initials: 

 Type initials  : Enter initials as text and customize their style. 
 Draw initials  : Create initials by hand-drawing them. 
 Use an image as initials  : Upload an image to use as initials. 

The interface will adjust based on your selected method.
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Typing initials

You can type initials if you want to enter initials as text and adjust their style. 

To type your initials: 

1. From the drop-down list, select Type my initials.

2. Enter your initials in the text box. 

A preview will be displayed instantly below the input field. 

You can choose a style from the predefined styles or create a custom style by adjusting the font, size and 
color.
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Drawing initials

You can draw initials if you want to enter your initials as a hand drawing. 

To draw initials:

1. From the drop-down list, select Draw my initials.

2. Use the central drawing area to create your initials by hand. 

You can adjust color and stroke width to customize the appearance of your initials.
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Loading initials from an image

The Select initials image option allows you to create initials using an uploaded image.

To load initials from an image:

1. From the drop-down list, select Select initials image.

2. Click Browse button and choose the image file you want to use as your initials.
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Choosing Default Initials

You can set specific initials as default to have easier and quicker access from the toolbar. 

To set default initials:

1. Go to Objects > Place Initials > Choose Default Initials in the main menu.

2. In the Choose Default Initials window, click the set of initials you want to set as default.

To insert default initials in the document, click the Place Initials icon on the toolbar, then place the 
initials on the desired page.

 Before setting initials as default, make sure you have already created at least one set of initials.
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Placing Initials in the PDF Document

To insert initials into your document: 

1. Go to the menu Objects > Place Initials and click on the initials you want to use. 

2. Click and drag to position the initials where you want them on the page.

 If you have set default initials: simply click the Place Initials icon  on the toolbar and place 
the initials directly in the document.

You can adjust the Geometry of the initials using the options in the right side panel.
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Watermarks in PDFs

Watermark is a text or an image, positioned behind document content. Usually it contains information,  
identifying document author. You can specify size, font, style, color, page position, number of pages to 
display watermarks etc. An image from PDF file can also be used as watermark. Different watermarks 
may be used in single file, and every page can have multiple watermarks.

Watermark settings may be saved for later use.

Add watermarks

To  add  watermarks  to  PDF  document  use  Document > Watermark > Add menu  item  or  press 
Ctrl+Shft+W. 

 Saved setting. List of saved watermark templates. 
To add a template, set required watermark parameters and press Save. Specify title for the template 
in a pop up window. To remove template, choose it in the list of saved settings and press Delete. 

 Source. Choose source for watermark. It can be text or image.
• Text. If this option is checked, then inserted text will be source material for watermark.
• Font. Here you can set options for the font of the watermark text: font family, size, color 

underlining. 
• File. If this option is checked, then an image loaded from PDF or image file will be used as 

source for watermark.
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• Browse. Choose source PDF or image file for watermark.
• Page number. Number of the page in the source file to be used as watermark.
• Total pages. Pages count of the source file.
• Scale. Scale of the watermark to source image from PDF file. To make this option active, 

remove Appearance > Scale relative to target page. 
 Appearance. Appearance settings of the inserted image.

• Rotation. Rotation value (in degrees) relative to the document page.
• Opacity. Opacity value (in percents).
• Scale relative to target page. Watermark scale relatively to the page it will be inserted on. 

 Position. Set watermark position on the document page.

• Vertical Distance. Value for vertical watermark offset relative to selected position: Top, 
Center or Bottom.

• Horizontal Distance. Value for horizontal watermark offset relative to selected position: Top, 
Center or Bottom.

• Units. Measurement units to specify offset distance. 

• Place. Select watermark place: on the background or in the foreground. 

 Preview. Preview a PDF file before adding watermark. 

• Preview Page. Select a page for preview. 

• Pages Range Options. Number of pages to add watermarks.

Manage Watermarks

To edit watermarks added to the document, choose  Document > Watermark > Manage  in the main 
menu. The Manage Watermarks dialog will pop up.

Copyright © 2026 Code Industry Ltd



The dialog contains a list of all watermarks added to the currently opened document. On the top of the  
dialog, the following actions are available:

 Add. Open the Watermark dialog to add a watermark.

 Edit. Open the Watermark dialog to edit the selected watermark.

 Remove. Delete the selected watermark.

 Remove all. Delete all watermarks added to the document.

If  you click  Remove all,  all  watermarks  will  be  deleted even if  the  Text  Watermark or  File 
Watermark option is selected from the Show list (see below).

 Zoom In. Increase the scale of watermark thumbnails.

 Zoom Out. Decrease the scale of watermark thumbnails.

 Zoom Original. Restore the default scale of watermark thumbnails.

To show only a specific watermark type in the list, select one of the options from the  Show list at the 
bottom of the dialog:

 All. Show all watermarks added to the document.

 Text Watermark. Show only the text watermarks.

 File Watermark. Show only the watermarks imported as images from external files.

Remove all watermarks

To remove watermarks, use Document > Watermark > Delete. All the watermarks in the document will 
be removed. 
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Backgrounds in PDFs

Background is solid color or image positioned behind the document context. PDF allows to use only a 
single background per page. For each document page you can set a unique background.

For a background you can choose an image from file, set color and position on the page, specify number 
of the pages where the background will be displayed and save parameters for further use.

Add background, with an open document

To add a background to PDF, use Document > Background > Add menu item or press Ctrl+Shft+B. 

 Saved settings. List of saved background templates.

To add a template, set required parameters and press Save. Specify template name in a pop up window.

To remove a template, choose it in the list of saved fields and press Delete. 

 Source. Choose type of inserted background. It can be an image from PDF file or a solid color
• Color. If chosen, document background will be a solid color fill. Choose the color from the list. 
• File. If chosen, an image loaded from the PDF file will be used as background.

• Browse. Choose source PDF file for background.
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• Page number. Number of the page in the source file to be used as background image (Pages 
count of the source file will be displayed in Total pages).

• Total pages. Pages count of the source file.

• Scale. Scale of the background to source image from PDF file. To make this option active, 
remove Appearance > Scale relative to target page mark. 

 Appearance. Appearance settings of the inserted image.
• Rotation. Rotation value (in degrees) relative to the document page.
• Opacity. Opacity value (in percents).
• Scale relative to target page. Background scale relatively to the page it will be inserted on. 

 Position. Set background position on the document page.

• Vertical Distance. Value for vertical background offset relative to selected position: Top, 
Center or Bottom.

• Horizontal Distance. Value for horizontal background offset relative to selected position: Top, 
Center or Bottom.

• Units. Measurement units to specify offset distance. 

 Preview. Preview a PDF file before adding background. 

• Preview Page. Select a page for preview. 

• Pages Range Options. Number of pages to add background.

Manage Backgrounds

To edit backgrounds added to the document, choose Document > Background > Manage in the main 

menu. The Manage Backgrounds dialog will pop up.
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The dialog contains a list of all backgrounds added to the currently opened document. On the top of the 
dialog, the following actions are available:

 Add. Open the Background dialog to add a background.

 Edit. Open the Background dialog to edit the selected background.

 Remove. Delete the selected background.

 Remove all. Delete all backgrounds added to the document.

If you click Remove all, all backgrounds will be removed even if the Color Background or File 
Background option is selected from the Show list (see below).

 Zoom In. Increase the scale of background thumbnails.

 Zoom Out. Decrease the scale of background thumbnails.

 Zoom Original. Restore the default scale of background thumbnails.

To show only a specific background type in the list, select one of the options from the Show list at the 
bottom of the dialog:

 All. Show all backgrounds added to the document.

 Color Background. Show only solid color backgrounds.

 File Background. Show only the background images imported from external files.

Remove a background from all pages

To remove a background in the PDF document, navigate the menu to Document > Background > Delete. 
The background on all pages will be removed. 
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Headers and Footers for PDFs

Master PDF Editor allows adding headers and footers into PDF documents. These elements may contain 
text, page number or date. For convenience, each header and footer fields are divided into left, right, and 
center. For headers and footers it is possible to set size, font, style, color and specify numbers of pages 
where headers and footers will be shown. Different headers and footers may be used in a single document, 
and their settings can be saved for later usage.

 Add headers and footers

To add headers and footers to a PDF document, use Document > Header and Footer > Add or press 
Ctrl+Shift+H.

Specify the following settings in the dialog box:
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 Saved Settings. List of saved customized headers and footers.

To add another template, specify required settings and press Save. Specify template name in the 
new dialog box.

To remove a template, choose it in the list of the saved templates and press Delete.

 Font. Set font family, size and color, or underline text to highlight it.

Font settings are applied to all headers and footers in the document.

 Margins. Adjust header and footer margins. 
• Units. Choose units to specify distance.
• Left margin. Distance from document edge to the left edge of header and footer.
• Right margin. Distance from document edge to the right edge headers and footers.
• Top margin. Distance from document edge to the header.
• Bottom margin. Distance from document edge to the footer.

 Text. Insert headers and footers text.

 Insert Page Number. Add page number to header or footer.

 Insert Date. Add date to header or footer.
 Insert Bates Number. Add Bates numbering to header or footer.

 Page number and date format.
• Date Format. Set date format.
• Page Number Format. Set page number format.
• Start Page Number. Set first number to begin page count with.

 Page Range Options. Specify page range to add headers or footers.

 Show preview. Show/hide page preview in the dialog box.

• Preview Page. Select a page for preview. 

Bates numbering can be added in the Headers & Footers dialog box.
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Add headers and footers to multiple documents

To add header and footer or Bates numbers to multiple documents at once, select  Document >  Header 
and Footer > Add to Multiple Files from the main menu.

The following options are available to add files to the list:

 Add Files. Add the selected files to the list.
 Add Directory. Add files of the selected directory.
 Add Open Files. Open a dialog box to select the currently open documents to add to the list:

As needed, do any of the following:

 To change the document order to assign Bates Numbers, use the Move Up and Move Down 
buttons; to remove a document from the list, use Delete.
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 Sort files, selecting the required columns to be displayed from the Show drop-down list.

 If the Save and close files after numeration option is enabled, all files will be automatically 
closed after header and footer being added.

Manage header and footer

Master PDF Editor allows adding or editing previously added header and footer or  Bates numbering by 
selecting Document > Header and Footer > Manage from the main menu.

The dialog box that appears displays the header and footer, and Bates numbering added to the currently  
open document. The following actions are available:

 Add. Display the Header and Footer window to add headers or footers or Bates numbering.
 Edit. Display the Header and Footer window to edit previously added headers or footers or Bates 

numbering.

If Use Page Range of the currently edited Pagemark is disabled, you can specify the Page Range to 
make changes.

 Delete. Delete the selected header or Bates numbering.
 Delete All. Delete all header and footer, and Bates numbering.

Both header and footer, and Bates numbering will be removed, even though Bates numbering only or 
Header and Footer only is displayed on the list. 

 Zoom In. Zoom in on a header and footer thumbnail.
 Zoom Out. Zoom out a header and footer thumbnail.
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 Zoom Original. Restore the default scale of thumbnails.

If Header and Footer is selected from the Show drop-down list, Header and Footer only are displayed on 
the list.

Remove all headers and footers

To remove headers and footers, use Document > Header and Footer > Delete menu item. All headers and 
footers in the document will be removed.
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Bates Numbering

Use Bates numbering to uniquely identify each page by assigning page numbers that are automatically 
incremented. When adding Bates numbering, each page is assigned a unique number or combination of 
numbers and letters. Bates numbers can include an alphanumeric prefix or suffix, and also be combined 
with other header and footer text.

Add Bates numbering

Select Document > Header and Footer menu item to add a Bates numbering header or footer.
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Then, choose Insert Bates Number to adjust the following parameters:

 Number of Digits. Specify the number of digits making up the Bates number. 
 Start Number. Start number of Bates numbering. Enter the number to assign to the first PDF page 

on the list. 
 Prefix. Type any text or digits to display before the Bates number. 
 Suffix. Type any text or digits to appear after the Bates number. 

Add Bates numbering to multiple documents

You can add Bates numbering to multiple documents by adding them in a batch. To add Bates numbering 
to multiple documents, choose Document > Header and Footer > Add to Multiple Documents from the 
main menu. The methods to add files are described here, Add headers and footers to multiple documents.

Bates numbering is added in a sequential order, starting from the first document on the list. The document  
order can be changed. As needed, do any of the following:

 To change the  document  order  to  assign Bates  Numbers,  use  the  Move Up and  Move Down 
buttons, to remove a document from the list, use Delete.

 Sort the list, selecting the required columns to be displayed from the Show drop-down list.

 If  the  Save and close files after numeration option is  enabled,  all  files will  be automatically 
closed after headers and footers being added.

Manage Bates Numbering 

Select  Document >  Header  and  Footer >  Manage main  menu  item to  add,  edit,  or  remove  Bates 
numbering in the open document. Available actions are described here. 
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If Bates  numbering from the  Show drop-down  list  is  selected,  the  added  Bates  numbering  only  is 
displayed on the Header and Footer list.

Remove Bates numbering

To remove Bates numbering, select Document > Header and Footer > Delete in the main menu. You can 
delete Bates numbering from certain pages. 
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Optical character recognition in PDF

Optical character recognition allows converting images containing text to editable PDF text format, which 
supports document text search, copying, edition and all other PDF text functionality. Text recognition can 
be performed only if it is not locked in PDF document permissions.

To use optical character recognition, choose Document > OCR menu item. 

Set the following parameters in the dialog box:
 Page Range. Set pages where optical character recognition must be performed.
 Languages. Set language(s) of recognized text. In order to optimize text recognition quality, it is 

best to choose minimal number of languages.

If text recognition is used for the first time, the languages list will be empty. To add languages, press  
Install languages button.
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 Install languages. Check  marks  to  choose  required  languages.  The  following  window  lists 
languages, which recognition is supported in Master PDF Editor.

 Font Family. Select the predefined font family that will be applied to the recognized text. This 
option  ensures  that  the  font  family  of  the  recognized  text  matches  the  text  in  the  original 
document. By default, the font family is set to Helvetica.

 Searchable Text. If this option is chosen, recognized text will be available for search and copying 
only. It will be inserted into the document as an invisible layer under its image.

 Editable Text.  With this option, recognized text will be available for editing. The text will be 
inserted in front of the image that contains it. The image itself will be covered with background 
color.

It’s  possible  to  use  languages  for  text  recognition  that  are  not  listed.  To  do  this,  you  need  to 
place .traineddata file in the directory specified in the  OCR settings,  Default path to tesseract ocr data  
files. 

You can also set Advanced settings in the OCR Engine dialog.

 Deskew.  Straighten  and  deskew  all  the  content  on  the  page  automatically.  Also,  a  scanned 
document content can be also deskewed.
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 Minimal confidence level. A numerical value indicating the degree to which the engine is certain 
that it has recognized the component correctly.

 Force manual text editing if confidence level not achieved. If it’s enabled, a dialog box for text 
edition will be opened during text recognition. It will display:
• Original.  A piece  of  image with  text.  Automatically  recognized text  corresponding to  the 

image. 
• Text. Automatically recognized text corresponding to the image.

The dialog box Recognized text will successively show each part of the PDF document image with 
corresponding recognized text. This allows to edit text before inserting it into the document.

 Yes. Automatically recognized/edited text will be inserted into document. The dialog box will  
display next image and corresponding text.

 Yes to All. All images will be automatically recognized and written into the document. This dialog 
box won’t appear again during this recognition.

 Not Text. The image does not contain text. Cancel text insertion for current image.
 Cancel. Cancel text recognition.

Automatic Text Recognition

Automatic recognition is performed sequentially when navigating through pages. 

To enable automatic text recognition, check the  Automatically recognize text option in the program 
settings. To do this, navigate to the main menu Settings > Options, and select the Text Recognition tab. 

When you select the  Document Editing  or  Hand  tools, the automatic text recognition mode is 
activated.
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Once recognition is complete, the text will be available for searching and copying.

Before starting text recognition, ensure that a language is properly configured. To check, navigate to the 
main menu  Settings > Options, select the  Text Recognition tab. Under the  Automatically recognize 
text, select the language to be used for automatic recognition. 

Install a language if necessary.

When Automatically recognize text is enabled, OCR will automatically process pages that contain 
only images and vector graphic.
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Print

PDF Document Printing

You can print the document only if your computer is connected to local or network printer and it has  
required drivers installed. 

 Choose File > Print item in Main menu or press  Print (Ctrl+P) button on the toolbar.
 Choose one of the available devices for printing in following pop up window.
 Specify pages to print: all, current page, selected pages or pages range.
 Specify number of document copies.
 Press Print.

Master PDF Editor allows to set printing PDF with additional settings. 

 Print Presets. Save print settings to choose them for the next printing.
 Printer. The name of the printer used for printing. Specify the paper size, as well as the orientation 

(portrait, landscape) and page margins.
 Page Range. Select all pages, current page, current page view, or set custom range of pages.

Copyright © 2026 Code Industry Ltd



 Number of copies. Select the number of copies to be printed. The Collate option allows to keep 
pages in order when printing multiple copies.

 Choose paper source by paper size. Use the PDF page size to set parameters of the printer tray. 
This option is useful when printing PDF files with mixed-size pages using printers which have 
different-sized trays.

 Print as Grayscale. Enable if the document contains a variety of different colors and the printer 
only prints in black & white. 

 Duplex Printing. Enable printing on both sides of the paper. 
• Auto. Print documents in automatic mode if the printer supports the corresponding function. 
The device will automatically pull the pages back in and print on the other side. The binding 
method will depend on the printer settings.
• Long side. Print documents along the long edge.

• In portrait orientation, pages will be turned side-to-side like a book. This binding method 
ensures continuous reading from left to right when turning the page.
• In landscape orientation, every other page will be flipped. This binding method ensures 
continuous reading from up to down when turning the page.

• Short side. Print documents along the short edge.
• In portrait orientation, every other page will be flipped. This binding method ensures 
continuous reading from up to down when turning the page.
• In landscape orientation, the pages will be turned side-to-side like a book. This binding 
method ensures continuous reading from left to right when turning the page.

• Manually print on both sides. Print documents on both sides manually if the printer does not 
support duplex printing. While printing, Master PDF Editor will prompt you to turn over the stack 
and load it into the printer again.

Before printing the entire document on both sides manually, print a few test pages to understand 
which side of the paper should be loaded in the paper tray.

 Reverse Pages. Print pages in reverse order.
 Orientation. Select portrait or landscape orientation. 
 Page (1) of X (Current Page: Y). Select a page to preview before printing. In this case, X is the 

number of pages or spreads (Multiple mode) that will be printed, and Y is the number of the 
document page displayed in the preview, or the first page number, if there are several pages.

 Print. Print the document only or the document and annotations.

Press the Properties button to open additional settings dialog:

 System Settings. Settings dialog provided by the printer driver. Its appearance and the set of 
available options based on the driver.

 Page setup. Dialog to set main page parameters.

The list at the top right allows you to set the measurement units for paper size and margins: points, inches 
and millimeters.

 Paper Source allows selecting a specific paper source.
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 The Paper section allows selecting a page size from a list of preset ones. If a specific size is 
selected, the width and height items will be automatically set to the corresponding values of the 
paper page (sheet). When selecting a Custom page size, you can enter your own size values.

 The Margins section allows setting four margins on the page (blank spaces between your data and 
the edges ). You can select top, bottom, right and left values in the corresponding fields. 

 Use the Resolution drop-down list to select the resolution in dots per inch.

Attention! All settings available in the Printer Settings dialog (Properties > Page Setup) are provided to 
the user without checking whether the printer driver supports them. The actual result may differ from what 
is specified in this window.

Available print modes:
 Size. Normal printing mode, one page of the document is printed on one side of the paper.
 Poster. One page of a document is printed on several sheets of paper.
 Multiple. Multiple pages of a document are printed on a single sheet of paper.
 Booklet. Pages of a document are printed two pages per each side of a sheet, arranged so that they 

are in the correct order when folded into a booklet.

Select the print mode by clicking the corresponding button. Each mode has its own set of settings.
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Size mode settings 

 Aspect ratio. Apply when actual PDF page size and the print paper size are different, that is, the 
page may just take up a little of the printed sheet’s area or stretch over its borders. If the Actual 
size enabled, this option is disabled and ignored.

 Ignore aspect ratio. Stretch the page to actual print sheet size.
 Keep aspect ratio. Stretch page to shortest sheet side saving aspect ratio.
 Keep aspect ratio by expanding. Stretch page to longest sheet side saving aspect ratio.
 The Fit Page option resizes the document page to fit the paper sheet.
 Shrink to printable area reduces the document page to a printable area of the sheet.
 Enable Actual Size to print the page at its actual size.
 If you need to directly set the printed page size as a percentage of the original size, enable the 

Scale option. 
 The printed page is centered on the sheet by selecting the Center item. When the option is 

disabled, the page will be printed in the sheet's upper left corner. 
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Poster mode settings 

 Scale. You can specify the poster size as a percentage of the original document page size. The 
number of sheets of paper to be used for printing is determined by the scale.  

 Overlay item allows to specify how much the content of the edges of the poster segments (sheets 
of paper) will be overlaid. You may select points, inches or millimeters for the units the overlay is 
displayed in from the list below.  

 To center the page on the entire paper, enable the Center item. The page will be on the top left if it 
is not enabled.   

                            Poster preview, overlay is disabled                              Poster preview, overlay is enabled (10 mm) 
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Multiple mode settings 

 Pages per sheet. Number of pages to be positioned both horizontally and vertically. You may 
select the page order from the list. In the list you can select the page order.  

Page order when using Multiple mode

Horizontal Horizontal Reversed

Vertical Vertical Reversed

 If Center page in cells enabled, each page will be placed in the corresponding “cell” in the center. 
If disabled, it will be located at the top left of its "cell" on the sheet.

 Additional spacing. Select additional space between pages on a single sheet. You can select the 
interval units of measurement from a list next to it, which includes points, millimeters or inches.
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Booklet mode settings 

Booklet mode allows printing a document with pages automatically arranged in the correct sequence for 
creating a folded booklet or book.

Printing a multipage document in Booklet mode.

The following settings are available in Booklet mode: 
 Center. Centers the pages on the left and right sides of the sheet. If this option is disabled, pages 

will be positioned at the top left of each side.
 Right Binding. Adjusts the binding direction for right-to-left reading.
 Additional spacing. Adds additional space between pages on the same sheet. You can select the 

spacing units such as points, millimeters, or inches from the drop-down list next to the interval.

Recommendations for printing in Booklet mode:
1. Print a few test pages before printing the entire document to ensure the layout is correct.
2. Use PDF-documents with an even number of pages for optimal result.
3. For correct page order in a printed document, paper sheets should be folded in half and inwards 

after printing.

As needed, select Advanced to set additional settings.
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 Print as image. PDF document is provided to printer as bitmap image, so images and fonts quality 
can be decreased. But this can be compensated for by increasing DPI. Use this function if you are 
experiencing issues with normal printing.

 Queue In Subset Pages. Document is separated into multiple sup-documents according to the 
number of pages chosen.
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Hotkeys

Every user has his own habits of work on his keyboard. Master PDF Editor provided possibility to set 
keyboard shortcuts according to individual preferences, which can drastically increase speed of your work 
with Master PDF Editor.

Following hotkeys can help you navigate document in Master PDF Editor faster:

File menu Window and Linux Mac OS X

Blank PDF Ctrl + N Cmd + N
Open Ctrl + O Cmd + O
Save Ctrl + S Cmd + S
Save As... Ctrl + Shift + S Cmd + Shift + S
Save Optimized As... Ctrl + Alt + S Cmd + Alt + S
Export – Convert to PDF/A Ctrl + Shift + A Up Arrow + Cmd + A
Print Ctrl + P Cmd + P
System Print Ctrl + Shift + P Cmd + Shift + P
Properties Ctrl + D Cmd + D
Close Ctrl + W Cmd + W
Exit Ctrl + Q Cmd + Q

Edit menu Window and Linux Mac OS X

Undo Ctrl + Z Cmd + Z
Redo Ctrl + Y Cmd + Y
Cut Ctrl + X Cmd + X
Copy Ctrl + C Cmd + C
Paste Ctrl + V Cmd + V
Paste at Cope Position Ctrl + Shift + V Cmd + Shift + V
Paste to Multiple Pages Ctrl + Alt + V Cmd + Alt + V
Delete Del Delete
Select All Ctrl + A Cmd + A

View menu Window and Linux Mac OS X

First Page Home Fn + Left Arrow
Previous Page Page Up Fn + Up Arrow
Next Page Page Down Fn + Down Arrow
Last Page End Fn + Right Arrow
Go  to Page Ctrl + Alt + G Fn + Alt + G
Zoom In Ctrl + + Cmd + +
Actual Size Ctrl + 0 Cmd + 0
Zoom Out Ctrl + - Cmd + -
Fit Page Ctrl + 1 Cmd + 1
Fit Width Ctrl + 2 Cmd + 2
Facing Pages Ctrl + 3 Cmd + 3
Grid Ctrl + U Cmd + U
Snap to Grid Ctrl + Shift + U Cmd + Shift + U
Find Ctrl + F Cmd + F
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Find Next F3
Find Previous Shft + F3 Shft + F3
Object Inspector Ctrl + F11 Cmd + F11
Menu F12
Full Screen F11

Objects menu Window and Linux Mac OS X

Text Ctrl + T Cmd + T
Image Ctrl + I Cmd + I

Comments menu Window and Linux Mac OS X

Add Sticky Note Ctrl + 6 Cmd + 6

Forms menu Window and Linux Mac OS X

Highlight Fields Ctrl + H Cmd + H
Edit Forms Alt + 3 Control + 3
Link Ctrl + L Cmd + L
Text Field Ctrl + E Cmd + E

Document menu Window and Linux Mac OS X

Insert Blank Pages Ctrl + Shift + N Cmd + Shift + N
Delete Pages Alt + Del Fn + Option + Delete
Crop Pages Ctrl + K Cmd + K
Page layout Ctrl + Shift + L Cmd + Shift + L
Rotate Pages Ctrl + R Cmd + R
Extract Pages... Ctrl + Shift + E Cmd + Shift + E
Insert Pages... Ctrl + Shift + I Cmd + Shift + I
JavaScript Console Ctrl + J Cmd + J
Add Header and Footer Ctrl + Shift + H Cmd + Shift + H
Add Watermark Ctrl + Shift + W Cmd + Shift + W 
Add Background Ctrl + Shift + B Cmd + Shift + B 

Tools menu Window and Linux Mac OS X

Edit Document Alt + 1 Control + 1
Edit Text Alt + 2 Control + 2
Edit Forms Alt + 3 Control + 3
Edit Images Alt + 4 Control + 4
Edit Vector Images Alt + 5 Control + 5 
Select Text Alt + 7 Control + 7
Hand Tool Alt + 6 Control + 6

Bookmarks menu Window and Linux Mac OS X

Add bookmark Ctrl + B Up Arrow + B
Delete bookmark(s) Ctrl + Shift + R Up Arrow + Cmd + R
Set destination Ctrl + Shift + D Up Arrow + Cmd + D 
Properties Ctrl + Shift + O Up Arrow + Cmd + O
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If you hold Ctrl(Cmd) key when scrolling mouse wheel, this will increase/decrease current zoom.
Hold Ctrl(Cmd)  and left mouse button to choose several objects at once. To cancel selection of one of the 
selected objects, left click it again while holding Ctrl(Cmd)  key.

Information about default system keyboard shortcuts can be found on following pages:
For Windows: https://support.microsoft.com/en-us/kb/126449
For Mac OS X: https://support.apple.com/en-us/HT201236

Virtual PDF Printer

With  Master  PDF Editor  you  can  easily  print  any  documents  from any  applications,  which  support 
printing (for example, Microsoft Word and Excel or OpenOffice).

Master PDF Editor is installed as virtual PDF printer. After successful installation it appears in your list of  
Printers and Faxes. In order to create PDF file, you have just to print the document with Master PDF 
Editor. Open document (with Microsoft Word, WordPad, NotePad or any other application), press Print 
and choose Master PDF Editor printer (see screenshot).

This will open Master PDF Editor with your “printed” document. To save it as PDF file, choose File > 
Save As… item in Main menu.
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Open Settings, System tab to select a folder to save files printed with a virtual printer: Directory for files  
from printer, Files from printer section. 

Available paper sizes:

9×11, 10×11, 10×14, 11×17, 12×11, 15×11, A0, A1, A2, A3, A3 Extra, A3 Rotated, A4, A4 Extra, A4 
Plus, A4 Rotated, A5, A5 Extra, A5 Rotated, A6, A6 Rotated, B2 ISO, B3 JIS, B3 ISO, B4 JIS, B4 ISO,  
B4 (JIS) Rotated, B5 (JIS), B5 (JIS) Rotated, B6 (JIS), B6 (JIS) Rotated, C size sheet, D size sheet, E size  
sheet, Envelope, Envelope #9, Envelope #10, Envelope #11, Envelope #12, Envelope #14, Envelope DL, 
Envelope C3, Envelope C4, Envelope C5, Envelope C6, Envelope C65, , Envelope B4, Envelope B5, 
Envelope B6, Envelope Monarch, Envelope Invite, Executive, Folio, Fanfold, F size sheet, German Legal 
Fanfold, Japanese Postcard, Japanese Double Postcard, Ledger, Legal, Legal Extra, Letter, Letter Plus,  
Letter Extra, Note, Quarto, Square, Statement, Super A, Super B, Tabloid, Tabloid, Extra.

Available resolution (DPI):
100×100, 200×200, 300×300, 600×600, 1200×1200.

Virtual PDF  printer is included only with Master PDF Editor version for Windows 7, 8, 10 and 11.
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License Agreement

IMPORTANT-READ CAREFULLY: Code Industry Ltd.(hereinafter referred to as the Author”) 
License Agreement ("License" or "Agreement") is a legal agreement between You (either an individual or 
an entity, who will be referred to in this License as "You") and Code Industry for the use of Master PDF 
Editor ("Software"). By installing, copying, downloading, accessing or otherwise using the product, you 
agree  to  be  bound by the  terms of  this  license  agreement.  If  you do not  agree  to  the  terms of  this 
agreement, you have no rights to the product and should not install, copy, download, access or use the 
product.

1 GRANT OF LICENSE

1.1 You are granted a non-exclusive right to install and use the registered version of the Software.
1.2 You are allowed to store, install, launch and use the Software, access it or communicate with  

other means, not contradicting this Agreement.
1.3 By downloading and installing the Software, You agree to be bound by the terms of this License.
1.4 Unless otherwise stipulated by the contract, single registration code allows installing and use one 

copy of the Software on one computer for one end user, and install one additional copy of the Software for 
exclusive use by the same user on a home or mobile computer. In some cases, at the user's request, an 
increase  the  number  of  devices  (systems)  on  which  the  Software  copy will  be  installed  and used  is 
possible.

1.5 If You want to install and use the Software in the network (on a computer used as terminal 
server), You must purchase a registration code for every end user, who can access the Software, unless 
otherwise stipulated by the contract.

1.6 After a registration code is purchased, for a year You are provided with technical support and 
updates for installations of the Software registered with this registration code. After that term is over, You 
may extend it to further receive technical support and Software updates for an additional fee.

2 UNREGISTERED VERSION
2.1 Users may use an unregistered version of Software for free in order to test it during any time on 

any number of devices.
2.2 User may use the unregistered version of Software for personal, noncommercial purposes to 

view documents, fill PDF forms, comment and print documents.
2.3 Users who use an unregistered version of Software are not eligible to receive technical support.

3 TECHNICAL SUPPORT
3.1 Technical support includes consultations on installation, activation, and usage of the Software.
3.2 Consultations are provided via e-mail on Russian and English languages.

4 ADDITIONAL LIMITATIONS
You may not reverse engineer, decompile, disassemble the Software or create any derived products, 

based on Software or any of its components.
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5 TRANSFER
You may transfer the Software to a single recipient on a permanent basis only provided that you 

retain no copies of the Software (including backup or archival copies) and the recipient agrees to the terms 
and conditions of this License.

6 TERMINATION.
The License is in effect until terminated. The License will terminate automatically if you fail to  

comply with the limitations described herein. On termination, you must destroy all copies of the Software.

6 USE OF LOGOS AND TRADEMARKS.
You  may  not  use  the  Author’s  name,  logos,  or  trademarks  in  any  manner  including,  without 

limitation,  in  your  advertising or  marketing materials,  except  as  is  necessary to  affix  the appropriate 
copyright notices as required herein.

7 MISCELLANEOUS.
This Agreement represents the complete agreement concerning this License between the parties and 

supersedes all prior agreements and representations between them. This Agreement may be amended only 
in writing and when executed by both parties.  THE ACCEPTANCE OF ANY PURCHASE ORDER 
PLACED BY YOU IS EXPRESSLY MADE CONDITIONAL ON YOUR ASSENT TO THE TERMS 
SET FORTH HEREIN,  AND NOT THOSE CONTAINED IN YOUR PURCHASE ORDER.  If  any 
provision of this Agreement is held to be unenforceable for any reason, such a provision shall be reformed  
only to the extent necessary to make it enforceable and the remainder of this Agreement shall nonetheless 
remain in full force and effect.

8 LIMITED WARRANTY:
THE SOFTWARE IS PROVIDED “AS IS” WITHOUT A WARRANTY OF ANY KIND. TO THE 

MAXIMUM  EXTENT  PERMITTED  BY  APPLICABLE  LAW,  THE  AUTHOR  FURTHER 
DISCLAIMS  ALL  WARRANTIES,  INCLUDING  WITHOUT  LIMITATION  ANY  IMPLIED 
WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NON 
INFRINGEMENT. THE ENTIRE RISK ARISING OUT OF THE USE OR PERFORMANCE OF THE 
SOFTWARE AND DOCUMENTATION REMAINS WITH THE RECIPIENT.

9 LIMITATION OF LIABILITY:
UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, TORT, CONTRACT, OR 

OTHERWISE, SHALL THE AUTHOR OR HIS SUPPLIERS OR RESELLERS BE LIABLE TO YOU 
OR ANY OTHER PERSON FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL 
DAMAGES OF ANY CHARACTER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS 
OF GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, DATA LOSS, 
OR ANY AND ALL OTHER COMMERCIAL DAMAGES OR LOSSES, OR FOR ANY DAMAGES IN 
EXCESS  OF  THE  AUTHOR’S  LIST  PRICE  FOR  A  LICENSE  TO  THE  SOFTWARE  AND 
DOCUMENTATION,  EVEN  IF  THE  AUTHOR  SHALL  HAVE  BEEN  INFORMED  OF  THE 
POSSIBILITY  OF  SUCH  DAMAGES,  OR  FOR  ANY  CLAIM  BY  ANY  OTHER  PARTY.  THIS 
LIMITATION OF LIABILITY SHALL NOT APPLY TO LIABILITY FOR DEATH OR PERSONAL 
INJURY  TO  THE  EXTENT  THAT  THE  APPLICABLE  LAW  PROHIBITS  SUCH  LIMITATION. 
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FURTHERMORE,  SOME  STATES  DO  NOT  ALLOW  THE  EXCLUSION  OR  LIMITATION  OF 
INCIDENTAL OR CONSEQUENTIAL DAMAGES AND, THEREFORE, THIS LIMITATION AND 
EXCLUSION MAY NOT APPLY TO YOU.

10 LICENSE TERMINATION OR CHANGE OF SERVICES
10.1 You accept that Code Industry Ltd may stop developing, updating and supporting the Software 

at any time, same as stop distribution of any previous Software versions. Code Industry Ltd is to continue 
providing technical support for the paid period according to this License.

10.2 Code Industry Ltd reserves the right to change terms of services and support, but this must not 
cause the deterioration of the quality of support or material losses for Code Industry LTD or infringement 
of your material rights.

Copyright © Code Industry Ltd All rights reserved.
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